Ubuntu

Sync supertux 0.3.3-5 (universe) from Debian experimental (main)

Reported by Vincent Cheng on 2012-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
supertux (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync supertux 0.3.3-4 (universe) from Debian experimental (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * Don't include nonexistent header.
  * Don't include nonexistent header.
  * gcc-4.6.patch: fix FTBFS due to missing header (LP: #832874).
  * gcc-4.6.patch: fix FTBFS due to missing header (LP: #832874).

Patches in Ubuntu diff have all been applied to the Debian package as well.

Changelog entries since current quantal version 0.3.3-2ubuntu2:

supertux (0.3.3-5) experimental; urgency=low

  * Add debian/patches/fix_gcc4.7_ftbfs.patch to fix FTBFS with gcc 4.7.
   (Closes: #671538)

 -- Vincent Cheng <email address hidden> Fri, 04 May 2012 14:23:56 -0700

supertux (0.3.3-4) experimental; urgency=low

  * Add myself to Uploaders.
  * Bump standards version from 3.8.4 to 3.9.3.
  * Bump debian compat level from 7 to 9.
  * Remove explicit b-d on quilt; also remove --with-quilt call in
    debian/rules and unneeded debian/README.source.
  * Add DEP-3 headers to included patches.
  * Add debian/patches/fix-{desktop_file,spelling_errors}.patch to fix
    minor issues found by lintian.
  * Split debian-changes patch into separate patches.
  * Update Vcs-Browser link.
  * Update package descriptions with version in unstable.
  * Tighten dependency on supertux-data. (Closes: #577223)
  * Add "Suggests: supertux" field to supertux-data in debian/control.
  * Remove redundant debian/supertux.6; upstream already includes a manpage.
  * Fix path to xpm icon mentionned in debian/supertux.lintian-overrides.
  * Install WHATSNEW.txt as upstream changelog.

 -- Vincent Cheng <email address hidden> Sun, 01 Apr 2012 00:50:03 -0700

supertux (0.3.3-3) experimental; urgency=low

  * Import patch by Ilya Barygin <email address hidden> to fix building
    with gcc-4.6 (Closes: #640192)

 -- Christoph Egger <email address hidden> Tue, 11 Oct 2011 22:33:04 +0200

tags: added: sync
Daniel Holbach (dholbach) wrote :

I'm getting this FTBFS on quantal amd64:

/usr/bin/cmake -E cmake_progress_report /tmp/buildd/supertux-0.3.3/obj-x86_64-linux-gnu/CMakeFiles
[ 0%] Building CXX object external/squirrel/CMakeFiles/squirrel.dir/squirrel/sqapi.cpp.o
cd /tmp/buildd/supertux-0.3.3/obj-x86_64-linux-gnu/external/squirrel && /usr/lib/ccache/c++ -I/usr/include/SDL -I/usr/include/GL -I/usr/include/AL -I/tmp/buildd/supertux-0.3.3/external/squirrel/include -o CMakeFiles/squirrel.dir/squirrel/sqapi.cpp.o -c /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqapi.cpp
In file included from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqobject.h:5:0,
                 from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqpcheader.h:16,
                 from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqapi.cpp:4:
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/squtils.h: In instantiation of 'sqvector<T>::~sqvector() [with T = long int]':
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqclosure.h:83:52: required from here
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/squtils.h:38:4: error: 'sq_vm_free' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
In file included from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqpcheader.h:17:0,
                 from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqapi.cpp:4:
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqstate.h:142:6: note: 'void sq_vm_free(void*, SQUnsignedInteger)' declared here, later in the translation unit
In file included from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqobject.h:5:0,
                 from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqpcheader.h:16,
                 from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqapi.cpp:4:
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/squtils.h: In instantiation of 'void sqvector<T>::_realloc(SQUnsignedInteger) [with T = long int; SQUnsignedInteger = long unsigned int]':
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/squtils.h:66:4: required from 'T& sqvector<T>::push_back(const T&) [with T = long int]'
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqfuncstate.h:25:68: required from here
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/squtils.h:97:3: error: 'sq_vm_realloc' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
In file included from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqpcheader.h:17:0,
                 from /tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqapi.cpp:4:
/tmp/buildd/supertux-0.3.3/external/squirrel/squirrel/sqstate.h:141:7: note: 'void* sq_vm_realloc(void*, SQUnsignedInteger, SQUnsignedInteger)' declared here, later in the translation unit
make[3]: *** [external/squirrel/CMakeFiles/squirrel.dir/squirrel/sqapi.cpp.o] Error 1
make[3]: Leaving directory `/tmp/buildd/supertux-0.3.3/obj-x86_64-linux-gnu'

Vincent Cheng (vincent-c) wrote :

FTBFS is caused by gcc 4.7 (see https://supertux.lethargik.org/bugs/view.php?id=933 for upstream bug report + patch).

I'll test the patch and if it works, I'll upload to Debian experimental first.

Changed in supertux:
status: Unknown → New

Hi Vincent,

I'm unsubscribing ubuntu-sponsors. Please feel free to resubscribe when the new sync is ready.

Changed in supertux (Ubuntu):
status: New → Incomplete
Vincent Cheng (vincent-c) wrote :

Hi Andrew,

Updated supertux package is now in experimental and ready to be synced; I've also built it successfully in my PPA (https://launchpad.net/~vincent-c/+archive/vincents-sandbox).

Changed in supertux (Ubuntu):
status: Incomplete → New
summary: - Sync supertux 0.3.3-4 (universe) from Debian experimental (main)
+ Sync supertux 0.3.3-5 (universe) from Debian experimental (main)
description: updated
Daniel Holbach (dholbach) wrote :

This bug was fixed in the package supertux - 0.3.3-5
Sponsored for Vincent Cheng (vincent-c)

---------------
supertux (0.3.3-5) experimental; urgency=low

  * Add debian/patches/fix_gcc4.7_ftbfs.patch to fix FTBFS with gcc 4.7.
   (Closes: #671538)

 -- Vincent Cheng <email address hidden> Fri, 04 May 2012 14:23:56 -0700

supertux (0.3.3-4) experimental; urgency=low

  * Add myself to Uploaders.
  * Bump standards version from 3.8.4 to 3.9.3.
  * Bump debian compat level from 7 to 9.
  * Remove explicit b-d on quilt; also remove --with-quilt call in
    debian/rules and unneeded debian/README.source.
  * Add DEP-3 headers to included patches.
  * Add debian/patches/fix-{desktop_file,spelling_errors}.patch to fix
    minor issues found by lintian.
  * Split debian-changes patch into separate patches.
  * Update Vcs-Browser link.
  * Update package descriptions with version in unstable.
  * Tighten dependency on supertux-data. (Closes: #577223)
  * Add "Suggests: supertux" field to supertux-data in debian/control.
  * Remove redundant debian/supertux.6; upstream already includes a manpage.
  * Fix path to xpm icon mentionned in debian/supertux.lintian-overrides.
  * Install WHATSNEW.txt as upstream changelog.

 -- Vincent Cheng <email address hidden> Sun, 01 Apr 2012 00:50:03 -0700

supertux (0.3.3-3) experimental; urgency=low

  * Import patch by Ilya Barygin <email address hidden> to fix building
    with gcc-4.6 (Closes: #640192)

 -- Christoph Egger <email address hidden> Tue, 11 Oct 2011 22:33:04 +0200

Changed in supertux (Ubuntu):
status: New → Fix Released
no longer affects: supertux
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.