Ubuntu

Please apply supertux-0.3.1-gcc43.patch from Fedora

Reported by Nathan Handler on 2008-07-16
6
Affects Status Importance Assigned to Milestone
supertux (Ubuntu)
Medium
Nathan Handler

Bug Description

Binary package hint: supertux

Fedora has released supertux-0.3.1-gcc43.patch. This patch fixes building with gcc-4.3. The patch has currently not been applied in supertux as of version 0.3.1d-0ubuntu1.

Related branches

Changed in supertux:
assignee: nobody → nhandler
status: New → In Progress
Nathan Handler (nhandler) wrote :

supertux (0.3.1d-0ubuntu2) intrepid; urgency=low

  * Applied supertux-0.3.1-gcc43.patch from Fedora (LP: #249195)
    - Fix building with gcc-4.3
  * Bump Standards-Version to 3.8.0 (no change)
  * Move Homepage from debian/control Description to its own field

 -- Nathan Handler <email address hidden> Wed, 16 Jul 2008 15:04:46 -0500

Changed in supertux:
assignee: nhandler → nobody
status: In Progress → Confirmed
Andrea Colangelo (warp10) wrote :

Modifying the source inline is deprecated. Please, could you add a patchsystem to fix this bug?

Changed in supertux:
assignee: nobody → nhandler
importance: Undecided → Medium
status: Confirmed → In Progress
Nathan Handler (nhandler) wrote :

supertux (0.3.1d-0ubuntu2) intrepid; urgency=low

  * Add dpatch patch system
    - Add 01_supertux-0.3.1-gcc43.dpatch (LP: #249195)
  * Bump Standards-Version to 3.8.0
    - Move Homepage from debian/control Description to its own field
    - Add debian/README.source

 -- Nathan Handler <email address hidden> Sat, 26 Jul 2008 09:11:38 -0500

Changed in supertux:
assignee: nhandler → nobody
status: In Progress → Confirmed
Daniel Holbach (dholbach) wrote :

Andrea: why? This just adds an additional delta to the packaging.

Andrea Colangelo (warp10) wrote :

Daniel: because I don't like modifying the code inline (for the reasons we all know), and since the package is already at a -0 debian revision, adding some more delta isn't that bad thing. I am not saying that the first debdiff is totally wrong, both the solutions have pros and cons. I just prefer the latter. :-)

Daniel Holbach (dholbach) wrote :

I personally prefer a patch system too (if it's a packaging that I did myself and it's not a project that lives completely in bzr), but in this case it's a package we inherit from Debian. We had complaints from Debian developers before when the diff on merges.u.c they were looking at comprised not only of changes that were necessary, but also changes to the packaging. I'm not going to stop you from doing this, I'd just say: stick to whatever the Debian package does too.

Nicolas Valcarcel (nvalcarcel) wrote :

Daniel: i need to disagree in this one, it would be easier for us to push changes back into debian using a patch system (sending only the specific patch) than with an inline change, also i've had complains from upstream developers since they need to read a huge diff (ours vs his) to find the specific change they are looking for.

But although i find the change good (as far as i have check it) i will pass to sponsor it, and will ask Nathan to forward it to debian and ask them to include a patch system in his package so we can have a better track of changes.

Changed in supertux:
assignee: nobody → nhandler
Daniel Holbach (dholbach) wrote :

One famous example of such a complaint:
http://kitenet.net/~joey/blog/entry/a_bad_taste_in_the_mouth_detailed_ubuntu_patch_review/

I think "stick to what upstream does" makes most sense here. Please upload the package, I don't mind.
Please let's discuss this on ubuntu-devel@ and get more opinions about it - afterwards we can document the pros and cons and it will be less controversial.

Nathan Handler (nhandler) wrote :

Nicolas, it appears that the version of supertux in the Ubuntu repositories is a much newer upstream version than the one in the Debian repositories. Gürkan Sengün, the Debian Maintainer, has not uploaded a new version of the package since 2005. As I doubt we will be able to sync/merge the package from Debian any time soon, is there any point in sending this patch upstream? I am not even sure if it is still needed in the older version of supertux.

Nicolas Valcarcel (nvalcarcel) wrote :

Ok, then nevermind about that.
I've just checked and for some reason is not installing the debian changelog, or at least it's not installed correctly, can you check that and get rid of the other lintian warnings (run lintian on the .deb for more information)

Daniel Holbach (dholbach) wrote :

If you do fix all the other issues, please forward them to Debian. Making the package build again should have more priority though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package supertux - 0.3.1d-0ubuntu2

---------------
supertux (0.3.1d-0ubuntu2) intrepid; urgency=low

  [ Nathan Handler ]
  * Add dpatch patch system
    - Add 01_supertux-0.3.1-gcc43.dpatch (LP: #249195)
  * Bump Standards-Version to 3.8.0
    - Move Homepage from debian/control Description to its own field
    - Add debian/README.source

  [ Michael Bienia ]
  * Call dh_installchangelogs to install the Debian changelog.

 -- Michael Bienia <email address hidden> Sat, 06 Sep 2008 15:38:28 +0200

Changed in supertux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers