Sync supercollider 1:3.6.3~repack-3 (universe) from Debian unstable (main)

Bug #1250813 reported by Artur Rona on 2013-11-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
supercollider (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync supercollider 1:3.6.3~repack-3 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * No change rebuild for Boost 1.54 transition.
  * Fix FTBFS with boost1.50+.
  * Fix FTBFS with boost1.50+.

Debian/upstream has merged Ubuntu changes.

Changelog entries since current trusty version 1:3.5.3~repack-3ubuntu2:

supercollider (1:3.6.3~repack-3) unstable; urgency=low

  * Force use of bundled yaml-cpp
  * Add patch to use system lockfree. Also link appropriate libs on all archs

 -- Felipe Sateler <email address hidden> Thu, 12 Sep 2013 19:21:30 -0300

supercollider (1:3.6.3~repack-2) unstable; urgency=low

  [ Dan Stowell ]
  * Add 2 more files needed in -dev: SCVersion.txt, SC_PlugIn.hpp

  [ Felipe Sateler ]
  * Drop alternative build dependencies on specific libboost versions
  * Bump standards version
  * Upload to unstable

 -- Felipe Sateler <email address hidden> Mon, 09 Sep 2013 22:06:01 -0300

supercollider (1:3.6.3~repack-1) experimental; urgency=low

  [ Dan Stowell ]
  * Imported upstream version 3.6.3
  * Rename language package supercollider -> supercollider-language
  * supercollider is now a metapackage to provide standard install

  [ Felipe Sateler ]
  * Improve supercollider-supernova description.

 -- Felipe Sateler <email address hidden> Mon, 11 Mar 2013 09:22:37 -0400

supercollider (1:3.6.1~repack) unstable; urgency=low

  * Imported upstream version 3.6.1
  * New "supercollider-ide" package for new Qt-based IDE
  * Ensure build with system boost, and now v1.50+ is required
  * Update/refresh patches, remove 4 outdated patches
  * Update copyright file
  * Update install files: supernova plugin path changed
  * Add cmake flags to ensure libscsynth is built (while testsuite not, unneeded)
  * supernova compile fix on x86

 -- Dan Stowell <email address hidden> Thu, 20 Dec 2012 19:22:39 +0000

supercollider (1:3.5.4~repack-2-2) unstable; urgency=low

  * Imported upstream version 3.5.4
  * Note copyright for added file git-archive-all.py

 -- Dan Stowell <email address hidden> Mon, 13 Aug 2012 14:07:48 +0100

Daniel Holbach (dholbach) wrote :

This bug was fixed in the package supercollider - 1:3.6.3~repack-3
Sponsored for Artur Rona (ari-tczew)

---------------
supercollider (1:3.6.3~repack-3) unstable; urgency=low

  * Force use of bundled yaml-cpp
  * Add patch to use system lockfree. Also link appropriate libs on all archs

 -- Felipe Sateler <email address hidden> Thu, 12 Sep 2013 19:21:30 -0300

supercollider (1:3.6.3~repack-2) unstable; urgency=low

  [ Dan Stowell ]
  * Add 2 more files needed in -dev: SCVersion.txt, SC_PlugIn.hpp

  [ Felipe Sateler ]
  * Drop alternative build dependencies on specific libboost versions
  * Bump standards version
  * Upload to unstable

 -- Felipe Sateler <email address hidden> Mon, 09 Sep 2013 22:06:01 -0300

supercollider (1:3.6.3~repack-1) experimental; urgency=low

  [ Dan Stowell ]
  * Imported upstream version 3.6.3
  * Rename language package supercollider -> supercollider-language
  * supercollider is now a metapackage to provide standard install

  [ Felipe Sateler ]
  * Improve supercollider-supernova description.

 -- Felipe Sateler <email address hidden> Mon, 11 Mar 2013 09:22:37 -0400

supercollider (1:3.6.1~repack) unstable; urgency=low

  * Imported upstream version 3.6.1
  * New "supercollider-ide" package for new Qt-based IDE
  * Ensure build with system boost, and now v1.50+ is required
  * Update/refresh patches, remove 4 outdated patches
  * Update copyright file
  * Update install files: supernova plugin path changed
  * Add cmake flags to ensure libscsynth is built (while testsuite not, unneeded)
  * supernova compile fix on x86

 -- Dan Stowell <email address hidden> Thu, 20 Dec 2012 19:22:39 +0000

supercollider (1:3.5.4~repack-2-2) unstable; urgency=low

  * Imported upstream version 3.5.4
  * Note copyright for added file git-archive-all.py

 -- Dan Stowell <email address hidden> Mon, 13 Aug 2012 14:07:48 +0100

Changed in supercollider (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers