Java6 Web Start just opens the Java control panel instead of running the application

Bug #84501 reported by Ilmari Vacklin on 2007-02-11
48
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
openjdk-6 (Ubuntu)
Low
Unassigned
Hardy
Low
Unassigned
sun-java6 (Ubuntu)
Low
Unassigned
Hardy
Low
Unassigned

Bug Description

Binary package hint: epiphany-browser

When opening an application (e.g. jIRCii, ArgoUML) via Java6 web start, instead of opening the application the Java control panel cache viewer is opened. This happens in Epiphany but not in Firefox, which is why I submitted the bug on this package. Could be a Java bug too, I suppose.

Related branches

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in epiphany-browser:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Ilmari Vacklin (wolverian) wrote :

Sorry, but it is unclear to me how to obtain a backtrace when there is no crash involved.

Sebastien Bacher (seb128) wrote :

Ups, read the bug too quickly. Your description is not really clear, ArgoUML is an application, how is it supposed to interact with a webbrowser? Could you describe some simple steps to get the problem or an URL to use for that?

Changed in epiphany-browser:
importance: Medium → Low
Ilmari Vacklin (wolverian) wrote :

Example URL: http://argouml-downloads.tigris.org/jws/argouml-0.22.jnlp

To reproduce the bug: open the above URL in Epiphany.

This is a so called Java Web Start file, which uses the web start feature in Java to download the actual .jar file and then run it using the system Java. It doesn't directly have anything to do with the browser, besides the browser downloading the file and handing it to Java. This needs to happen properly, of course. Feisty's Epiphany seems to be not doing its thing properly here, with Java 6. Again, this might be a Java bug, I'm not familiar enough with Java to say, but the fact that it works in Firefox is probably a lead. (Does Firefox use the system MIME configuratoin?)

Ilmari Vacklin (wolverian) wrote :

Running gnome-open on the URL reproduces the Epiphany behaviour, so I suppose this isn't an Epiphany bug at all. Not sure which package it belongs to.

Edu (martinez-bernal) wrote :

This happens too in kubuntu with konqueror.

Sebastien Bacher (seb128) wrote :

could you download the file on your disk, right click on it, go the nautilus properties and look what application is selected to the "open with" tab?

Ilmari Vacklin (wolverian) wrote :

"Sun Java 6 Web Start". Doubleclicking on the file opens it in the cache viewer, like from Epiphany.

Sebastien Bacher (seb128) wrote :

can you run 'grep "Sun Java 6 Web Start" /usr/share/applications/*.deskop"'? Do you have any other choice listed to open that file?

Ilmari Vacklin (wolverian) wrote :

wolverian@pupu:~$ grep "Sun Java 6 Web Start" /usr/share/applications/*.desktop
/usr/share/applications/sun-java6-javaws.desktop:Name=Sun Java 6 Web Start
/usr/share/applications/sun-java6-javaws.desktop:Comment=Sun Java 6 Web Start

The other options are Amaya 9.53, Epiphany and Firefox.

Sebastien Bacher (seb128) wrote :

/usr/share/applications/sun-java6-javaws.desktop uses "Exec=/usr/lib/jvm/java-6-sun-1.6.0.00/bin/javaws -viewer", running that command on the download file has the same effect, the "-viewer" should be dropped to not get the control panel dialog open, reassigning the bug to sun-java6-bin

Changed in epiphany-browser:
assignee: desktop-bugs → nobody
status: Needs Info → Confirmed
Matthias Klose (doko) wrote :

works fine with firefox; is epiphany doing things different?

Changed in sun-java6:
status: Confirmed → Unconfirmed
Ilmari Vacklin (wolverian) wrote :

Right. As I said in the initial report, Epiphany and all apps using gnome-open(1) exhibits this behaviour. Firefox does not. I don't know why, sorry. :)

Sebastien Bacher (seb128) wrote :

not an epiphany bug. epiphany is using the freedesktop database, applications declare they handle a MimeType from their .desktop, GNOME launchs the preferred applications corresponding to the type

/usr/share/applications/sun-java6-javaws.desktop has "MimeType=application/x-java-jnlp-file;" so it's used on the file which is from that type, and the .desktop uses "Exec=/usr/lib/jvm/java-6-sun-1.6.0.00/bin/javaws -viewer" so the GNOME apps run "/usr/lib/jvm/java-6-sun-1.6.0.00/bin/javaws -viewer URI"

Changed in epiphany:
status: Unconfirmed → Rejected
R. A. Rivas Diaz (rivasdiaz) wrote :

The problem here is the way the javaws is invoked.

Since Java SE 6, if I want to run just the Java Web Start in standalone mode, which is useful if I want to list/delete/run previously downloaded applications, I have to run javaws -viewer as the .desktop file correctly says, but if I need to run an application having the JNLP url or document, I have to execure javaws <URL>. If I run the javaws process without arguments, a simple help is written to the console.

I think that a .desktop is needed to run Java Web Start from the menu, as it works now (javaws -viewer), but when registering the mime type only, we need the Exec field be javaws only. Maybe two .desktops files are needed? (first for the menu entry, second for the mime type registration)

I have fixed it in konqueror by modifying the file association application/x-java-jnlp-file : I've simply added as application entry the command "javaws".

To do this graphically, open konqueror configuration panel (menu Configuration -> configure konqueror), go to the section "File associations", select the type "application/x-java-jnlp-file", then select the tab "General" on the right and click on the button "Add" beside the list of application (where the entry "Sun Java 6 Web Start" should be listed). In the dialog box appeared, type "javaws" in the text input field, and valid.

Jorge (jemarroyo-gmail) wrote :

Thanks Nicolas!!!! I have recently have this problem and solved with your post.
Regards

redacted (redacted) wrote :

Is this going to be fixed in the actual package anytime soon?

redacted (redacted) wrote :

This is happening in Firefox 3 in Hardy as well.

James Stansell (jamesstansell) wrote :

If you install openjdk-6 (6b08-0ubuntu1) in hardy (and possibly icedtea-gcjwebplugin) and use it instead of the sun-java6 is the problem fixed? Recent updates in the openjdk package include:

  * Install a wrapper script for javaws, which calls `javaws -viewer' if no
    arguments are given (or else starting javaws from the desktop menu
    would not do anything).
  * debian/JB-web-start.applications.in: Remove the -viewer option from command.

It sounds like those address this bug, but in the open-source openjdk-6 package instead of the proprietary sun-java6 package. Getting Sun to update sun-java6 can be problematic, but it should be helpful if we can confirm that the problem was fixed in openjdk.

-james.

Darren Albers (dalbers) wrote :

The problem is that the sun-java6-javaws.desktop is incorrect. It currently runs the viewer:
Exec=/usr/lib/jvm/java-6-sun-1.6.0.05/bin/javaws -viewer

It should just be javaws when you want to send it a java webstart app so it should be this:
Exec=/usr/lib/jvm/java-6-sun-1.6.0.05/bin/javaws

You can test this by launching a webstart app from the command line and you will see that with -viewer it doesn't work.

There really is no need to launch the cache viewer this way, it can be found by running the control panel, and clicking view under Temporary Internet Files.

Thanks!

Janek Thomaschewski (thefoxx) wrote :

I can confirm this behavoir on Hardy but with Firefox too. See bug #205399 would be nice to see this fixed in Hardy final.

Steve Langasek (vorlon) on 2008-04-08
Changed in openjdk-6:
importance: Undecided → Low
washeck (vrehak) wrote :

I tried to create a debdiff. As I'm not at all familiar with Ubuntu development/packaging process it would be nice if someone can review it and if correct apply it before Hardy release.

Rui Boon (ruiboon) wrote :

James: I have tried using openjdk-6 (6b08-0ubuntu5) and the same problem still arises.

Well... I guess that the root of the problem lies with the MimeType Association for the jnlp file.

Have attempted to create a debdiff as well, but I am not familiar with the packaging process. It would be great for this patch to be scrutinised by the community before the hardy code freeze.

Daniel Holbach (dholbach) wrote :

Matthias: can you please take a look at it?

Matthias Klose (doko) on 2008-04-16
Changed in openjdk-6:
status: New → In Progress
Changed in sun-java6:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b09-0ubuntu2

---------------
openjdk-6 (6b09-0ubuntu2) hardy; urgency=low

  * Update IcedTea build infrastructure.
    - Fixes build failure on ia64.
  * Compress the man pages, fixing the slave symlinks of the alternatives.
    LP: #211260.
  * javaws.desktop: Add `%u' to the Exec key, remove -viewer option.
    Closes: #436645.
  * openjdk-6-jre: Recommends libnss-mdns.
  * openjdk-6-jre-headless: Warn about unmounted /proc file system.
  * debian/JB-jre.mime.in: Remove the -viewer option from command (Tan Rui
    Boon). LP: #84501.

 -- Matthias Klose <email address hidden> Wed, 16 Apr 2008 13:05:13 +0200

Changed in openjdk-6:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sun-java6 - 6-06-0ubuntu1

---------------
sun-java6 (6-06-0ubuntu1) hardy; urgency=low

  * New upstream bug fix release.
    - Release notes at http://java.sun.com/javase/6/webnotes/ReleaseNotes.html.
    - Fixes Xlib/XCB locking problems. LP: #86103. Closes: #414535.
    - Update timezone information. Closes: #468234.
  * Don't open the control panel when starting a WebStart application.
    LP: #84501.
  * javaws.desktop: Add `%u' to the Exec key, remove -viewer option.
    Closes: #436645.
  * Suggest ttf-wqy-zenhei instead of ttf-arphic-uming (only available in .ttc
    format not supported by Sun Java) (Arne Goetje). LP: #213925.
  * Only use the basename for icons in desktop files. LP: #207413.
  * Add XS-Autobuild: yes attribute. Closes: #473164.
  * ia32-sun-java6-bin: Recommend lib32nss-mdns on amd64. Closes: #430917.
  * JB-bin.postinst.in: Call java -client -Xshare:dump with -Xmx1m, if the
    memory is available. Closes: #425654, #428654.
  * binfmt-support: Handle /usr/share/binfmts/jar as a slave symlink of
    the jexec alternative, install the binfmt file in the jre libdir.
    Use the jexec alternative in the binfmt file.
  * Don't fail on removal, if /var/lib/binfmts/openjdk-6 is missing.
    Closes: #441880.
  * README.Debian: Clarify about configuring the ControlPanel. Closes: #459435.
  * Don't include empty directories in /usr/share. Closes: #472995.

 -- Matthias Klose <email address hidden> Wed, 16 Apr 2008 01:02:07 +0200

Changed in sun-java6:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers