Sun Java 6 Plugin does not work in Firefox after 9.10 upgrade

Bug #632772 reported by Aleksey Covacevice on 2010-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sun-java6-plugin

After upgrading from Jaunty (9.04) to Karmic (9.10) 32 bits, the Sun Java 6 Plugin does not work on Firefox 3.6.8. Browsing around for hours trying to find similar bugs and workarounds, I could not find any solution. Also, since the bug is not exactly relative to Firefox, I was not sure how to use Apport to file this particular bug.

Whenever I try to exhibit a Java applet, the JVM crashes and a lot of "hs_err*" files appear on my home directory. I am attaching one of the logs for further investigation. The header of the logs are all the same and report a problem when accessing libfontconfig.so:

==
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x7f45073f, pid=31118, tid=2141571952
#
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) Server VM (16.3-b01 mixed mode linux-x86 )
# Problematic frame:
# C [libfontconfig.so.1+0x673f]
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
==

I have tried purging/reinstalling the sun-java* packages, messing around with "update-alternatives" and other workarounds, without any success. The plugin is apparently loaded correctly by Firefox (it appears in the "Plugins" window and in the "about:plugins" output), but applets do not work. The Java Test Page also reports that no Java is installed. Firefox does not crash, however, and running a (very simple) Hello World Java program in the terminal does work without any problems. I have not tried to run IcedTea or OpenJDK. As a side note, the mozilla-javaplugin.so alternative is pointing correctly to "/usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so".

Relevant output from "about:plugins" on Firefox:
==
Java(TM) Plug-in 1.6.0_20

    File: libnpjp2.so
    Version:
    The next generation Java plug-in for Mozilla browsers.
==

Package versions:
==
$ apt-cache policy sun-java6-plugin sun-java6-bin sun-java6-jre java-common
sun-java6-plugin:
  Installed: 6.20dlj-0ubuntu1.9.10
  Candidate: 6.20dlj-0ubuntu1.9.10
  Version table:
 *** 6.20dlj-0ubuntu1.9.10 0
        500 http://archive.ubuntu.com karmic-updates/multiverse Packages
        100 /var/lib/dpkg/status
     6-15-1 0
        500 http://archive.ubuntu.com karmic/multiverse Packages
sun-java6-bin:
  Installed: 6.20dlj-0ubuntu1.9.10
  Candidate: 6.20dlj-0ubuntu1.9.10
  Version table:
 *** 6.20dlj-0ubuntu1.9.10 0
        500 http://archive.ubuntu.com karmic-updates/multiverse Packages
        100 /var/lib/dpkg/status
     6-15-1 0
        500 http://archive.ubuntu.com karmic/multiverse Packages
sun-java6-jre:
  Installed: 6.20dlj-0ubuntu1.9.10
  Candidate: 6.20dlj-0ubuntu1.9.10
  Version table:
 *** 6.20dlj-0ubuntu1.9.10 0
        500 http://archive.ubuntu.com karmic-updates/multiverse Packages
        100 /var/lib/dpkg/status
     6-15-1 0
        500 http://archive.ubuntu.com karmic/multiverse Packages
java-common:
  Installed: 0.30ubuntu5
  Candidate: 0.30ubuntu5
  Version table:
 *** 0.30ubuntu5 0
        500 http://archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status
==

Please direct me if any more information is required. Any help is appreciated.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers