Java browser plug-in does not work

Bug #424971 reported by dobey on 2009-09-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running the latest Karmic, and have come across a web site which requires the java plug-in. As such, I installed sun-java6-plugin and restarted firefox. However, Java never appears in the about:plugins list in either firefox 3.0 or 3.5, on 2 separate machines. The java.com version check also fails, and java.com pages that use the plug-in show the "Install additional plug-ins" bar at the top of firefox.

dobey (dobey) wrote :

ld and nm output the following about undefined symbols:

[dobey@lunatari:dpkg]: ld /usr/lib/xulrunner-addons/plugins/libjavaplugin.so
ld: warning: cannot find entry symbol _start; not setting start address
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `operator new[](unsigned int)'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `operator delete[](void*)'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `operator delete(void*)'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `dlsym'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `__gxx_personality_v0'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `_Unwind_Resume'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `dladdr'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `operator new(unsigned int)'
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so: undefined reference to `dlopen'

[dobey@lunatari:dpkg]: nm -u /usr/lib/xulrunner-addons/plugins/libjavaplugin.so
         w _Jv_RegisterClasses
         U _Unwind_Resume
         U _ZdaPv
         U _ZdlPv
         U _Znaj
         U _Znwj
         U __assert_fail@@GLIBC_2.0
         w __cxa_finalize@@GLIBC_2.1.3
         w __gmon_start__
         U __gxx_personality_v0
         U __xstat@@GLIBC_2.0
         U dladdr
         U dlopen
         U dlsym
         U free@@GLIBC_2.0
         U fwrite@@GLIBC_2.0
         U getenv@@GLIBC_2.0
         U memcpy@@GLIBC_2.0
         U printf@@GLIBC_2.0
         U snprintf@@GLIBC_2.0
         U sprintf@@GLIBC_2.0
         U strcpy@@GLIBC_2.0
         U strdup@@GLIBC_2.0
         U strlen@@GLIBC_2.0
         U strncpy@@GLIBC_2.0
         U strrchr@@GLIBC_2.0

dobey (dobey) wrote :

The plug-in also is not working on Jaunty. I have a machine running Jaunty still, as it has a Poulsbo video chipset, and it is not supported under Karmic. I also tried installing sun-java6-plugin on there, with the result being no java listed in about:plugins in Firefox there either.

However, on IRC, a couple of people have noted that it works for them, but they are using the 64-bit builds, while my machines are 32-bit.

kiroh (kiroh) wrote :

I am using karmic up to date, and I'm affected to.
I tried installing java JRE from java web page and from repositories.
I tried also sun-java6-plugin and iced tea, but none of them work.
Sorry for the bad english :s .

BjA (bja) wrote :

I'm was affected too and the solution was very simple. I added a symlink to /usr/lib/mozilla/plugins with the following shell command:

cd /usr/lib/mozilla/plugins/ && sudo ln -s /usr/lib/xulrunner-addons/plugins/libjavaplugin.so libjavaplugin.so

Cheers,
BjA

Same problem on Jaunty 32-bit.

sun-java6-plugin installs, Sun Java the default Java (in update-alternatives), but Firefox 3.6.8 about:plugins shows no plugin installed.

Unlike BjA, the fix for me was to symlink the separate libnpjp2.so in /usr/lib/firefox/plugins *and* /usr/lib/mozilla/plugins. In my build, only libjavaplugin.so was there, correctly symlinked to the /usr/lib/jvm path.

Is this something that's broken with the recent upgrade of Firefox to 3.6 on older Ubuntu releases (such as Jaunty)??

ls -al /usr/lib/mozilla/plugins
[includes only /usr/lib/mozilla/plugins/libjavaplugin.so -> /etc/alternatives/mozilla-javaplugin.so]

ls -al /usr/lib/mozilla/plugins
[includes only /usr/lib/mozilla/plugins/libjavaplugin.so -> /etc/alternatives/mozilla-javaplugin.so]

cd /usr/lib/mozilla/plugins
sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

cd /usr/lib/firefox/plugins
sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

[Test Java plugin]
firefox http://www.java.com/en/download/installed.jsp

Could this also be related to Bug #291135 (since that was supposed to move from libjavaplugin.oji to the apparently newer libnpjp2.so)? Or, at the very least, it would seem that a fix for that should fix this, at least for the configuration I have.

Oops, sorry for multiple posts. To clarify, looks like the libjavaplugin.so version is somehow broken (or has an incorrect name; I remember some forum post about similar issues where they'd had to rename libjavaplugin.so to something else). I didn't need *both* the entries, only to replace libjavaplugin.so with libjpnp2.so (just re-checked by removing the libjavaplugin.so symlinks).

And, to be crystal clear, the original symlinks were indirect, via /etc/alternatives/firefox-javaplugin.so and /etc/alternatives/mozilla-javaplugin.so (just in case anyone else is trying to reproduce my 'fix').

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers