Java: Webbank logon applet freezes Firefox

Bug #372169 reported by GNUbee40 on 2009-05-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

We already know of problems with Java and Webbanking starting under Intrepid. I also experienced these.
Now with Jaunty however things are a little bit different.
On some occasions when opening the logon to my Webbank, the applet won't start and Firefox freezes. However this is not reproducible. Next time i try the applet might load instantly.
I read on the net, that the pop-up blocker of Firefox might interfere with these applets. But deactivating it does not prevent the error from happening.
I am using two danish banks. Links provided below:

I am using the Sun Java 6 applet. (See attachement)

https://web40.prod.bec.dk/signon/servlet/Signon?_Or=_0r6*KuJyfHhkAh54ERSU0R0pY26*1VKC8VAJXVW1-81N*ZZ13BpCHV9ATB18*ZgPB0AkODtxfTYoHvZY9wgL7i2xRxLEIX3me25XPJXKSq__&_Wp=No

https://web30.prod.bec.dk/signon/servlet/Signon?_Or=_aEpFgTA02Xz0fc2gXB*wQ*0j3MS4Ef8vrOvkhsxMOaDFromjvlxVyN2okcN6zRGp&_Wp=No

Tried the error console of Firefox but found only errors regarding CSS style sheets of the page. If someone knows appropriate logs i could post I would be thankful.

Regards

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: firefox-3.0 3.0.10+nobinonly-0ubuntu0.9.04.1
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.28-11-generic i686

GNUbee40 (docnino) wrote :
Alexander Sack (asac) on 2009-05-05
affects: firefox-3.0 (Ubuntu) → sun-java6 (Ubuntu)
James Stansell (jamesstansell) wrote :

Since Java6u10 the sun-java6-jre package has included 2 java plugins for Firefox (and other compatible browsers.) To the best of my knowledge none of the package installation or configuration procedures either report which is being used or give you the option to choose which to use. But to help others reproduce the problem it would help for them to know which plugin is in use in your browser.

In Firefox 3 one way to tell which plugin is being used is to select Tools -> Add-ons and click the Plugins tab. There should be either the OJI 'classic' plugin or the npjp2 'plugin2' plugin. If there is more than one java plugin listed then I would strongly recommend to eliminate all but one.

GNUbee40 (docnino) wrote :

Ok. Have checked plugins by accessing about:plugins in FF. Have attached the HMTL. Seems only the classic plugin is installed.
The error now appears more regularly. The last 5 times i tried it crashed. Still would like to log this...

GNUbee40 (docnino) wrote :

Hello there!

There seems to happen nothing with this bug, which still persist: 9 time of 10 FF freezes, when the Webbank applet is started.
Java Console shows that this happens when a live-connect session is attempted.
There are numerous reports on the www about broken live-connect support under FF3. I also read, that the live-connect method is on the way out as a authentication routine. Never the less, I was under the impression the guys from Mozilla had the will and know-how to fix this problem. Clearly, this hasn't quite happened yet.
In the mean time I can announce a peculiar workaround for this bug: When accessing this live-connect test page
http://developer.apple.com/internet/safari/samples/ColorBlockApplet.html
not only it works correctly, but subsequently, live-connect also succeeds when logging into webbank. I can log in and out numerous time within the same FF session. As soon as I restart FF I need to load the test applet again prior to webbanking, otherwise FF continues to freeze.
FF under Windows XP does NOT show this strange behavior.
I hope someone here can make something out of this and maybe shed some light on the mechanisms.

Regards

GNUbee40 (docnino) on 2009-07-22
Changed in sun-java6 (Ubuntu):
status: New → Incomplete
GNUbee40 (docnino) on 2009-07-22
Changed in sun-java6 (Ubuntu):
status: Incomplete → New
fsando (fsando) wrote :

I can confirm this in intrepid - using the same webbank service.

With FF 3.0.x it typically freezes at the first attempt (with the nice 'java' annimation running), then at the second or third (sometimes fourth) attempt it goes through and works from then on throughout.

With FF 3.5 it freezes each time (with a gray square at the java applet place) the exact same happens with swiftfox 3.5

As an aside: There were similar problems going from FF 2 to FF 3. It worked flawlessly in the later part of FF2's life but not in FF3. It have now worked (sort of) in FF3 for several months.

I've attached installed plugins. I don't know what further info I should provide.

fsando (fsando) wrote :

Could it be the same as this bug regarding Swedish (and possibly Norwegian banks):

Bug #293270 Firefox (on 8.10) crashes on important java applet (Bank-iD)

mic (michal-dobroczynski) wrote :

I can confirm all things written above. I am also using banking services provided by BEC (Denmark). Ubuntu x86 8.10, FF 3.0.x, Java Plugin 1.6.0_10-b33.
If I try to connect to the bank it might take up to 3-6 tries before the application loads (logon applet). If I load the detection applet from java.com first, then usually after third attempt everything works. If I load "a bigger applet", for example from another bank, then it works without any problems and the logon box appears immediately.
What happens when it does not work: in the place of the applet a "Java loading" image appears and after a moment Firefox hangs completely (java_vm process is visible with "ps", state "Sl", CPU 15%).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers