Java 6 plugin install issue and not displaying video game controls correctly for runescape.com

Bug #367470 reported by Toby Meehan on 2009-04-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sun-java6-plugin

When I attempted to install sun-java6-plugin (AMD64) using KPackageKit, it failed noting that it could not display the license agreement. I ran apt-get from the command line and agreed to the license agreement. All went well from there. Probably something that needs to be addressed.

When we tried to run an online Java-based game (runescape.com), parts of the game interface were not displaying properly, making the game unplayable. This works fine on a Windows XP system also using Java6, so pretty sure this is a bug of some kind. This game can be played in limited mode without paying a fee. There's another similar online game (fatalx.net) that is accessible at no cost (requires registration) that has the same basic issue.

KDE desktop effects are disabled and not using proprietary video driver. Fresh install of Kubuntu 9.04 AMD64 with all updates applied. ASUS M4A78T-E motherboard with onboard ATI Radeon HD 3300 video.

I've also logged a bug (367053) regarding the X server crashing upon logout, but I don't think that's related.

uname -a
Linux tam 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux

lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

apt-cache policy sun-java6-plugin
sun-java6-plugin:
  Installed: 6-13-1
  Candidate: 6-13-1
  Version table:
 *** 6-13-1 0
        500 http://us.archive.ubuntu.com jaunty/multiverse Packages
        100 /var/lib/dpkg/status

Toby Meehan (themeehans) wrote :

This bug has been fixed for me. I'm not sure when or what fixed it. I've changed nothing other applying updates as they became available.

There was an upgrade to openjdk and icedtea yesterday. I've attached my dpkg.log file in case it helps.

Matthias Klose (doko) on 2009-07-13
Changed in sun-java6 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers