Firefox 3.5 should be one of the dependency options

Bug #367063 reported by S.Lyons on 2009-04-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

In Jaunty, if Firefox 3.0 is uninstalled and replaced with 3.5, this plugin will be removed too - the dependencies require one of firefox/epiphany/galeon etc. but not firefox-3.5.
This can be easily fixed by adding firefox-3.5 as one of the options in the dependency list.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: sun-java6-plugin 6-13-1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: sun-java6
Uname: Linux 2.6.28-11-generic i686

S.Lyons (sblyons) wrote :
Jeppe Fihl-Pearson (tenzer) wrote :

Can't we get this fixed? Now that the final Firefox 3.5 is in the repositories, there is no need to have both the 3.0 and 3.5 versions installed, if you solely use Firefox 3.5.

Pac Shady (pacshady) wrote :

I'd also like to see firefox-3.5 satisfy the dependencies for sun-java6-plugin. It's a waste of space having to install another browser simply to keep this plugin installed.

If only dependencies could be overridden by the user.

Jeppe Fihl-Pearson (tenzer) wrote :

@Pac Shady
"If only dependencies could be overridden by the user."

Yes, that would be nice, but I think it may have a few side effects. However, I wrote some thoughts about it on my blog, if it has any interest: http://tenzer.dk/some-thoughts-about-dependencies

Mikael Karon (mikael-karon) wrote :

I just saw it on the blog mentioned above that Tenzer suggested that the "equivs" package could be used to work around this.

Then again, 3.5 has been out for a while, and fixing this looks rather easy. Any ideas on why this would take so long to fix?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers