sun-java6-jdk seems not to provide javac

Bug #348677 reported by Mathieu Marquer on 2009-03-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

After completely (--purge) uninstalling every sun-java6-* package, and completely removing unused packages (autoremove --purge), then reinstalling sun-java6-plugin, javac is still not recognized :

$ sudo update-alternatives --config javac

Il n'y a qu'un programme fournissant javac (/usr/lib/jvm/java-6-sun/bin/javac).
Rien à configurer.

$ java
Usage: java [-options] class [args...]
           (to execute a class)
   or java [-options] -jar jarfile [args...]
           (to execute a jar file)
etc etc... so this is OK

$ javac
Le programme « javac » peut être trouvé dans les paquets suivants :
 * ecj
 * gcj-4.3
 * java-gcj-compat-dev
 * openjdk-6-jdk
 * cacao-oj6-jdk
 * gcj-4.2
 * jikes-classpath
 * jikes-kaffe
 * kaffe
 * sun-java5-jdk
 * sun-java6-jdk
Essayez : sudo apt-get install <paquet sélectionné>
bash: javac : commande introuvable

Please let me know if you need additionnal informations.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: sun-java6-jdk 6-12-0ubuntu1
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: sun-java6
Uname: Linux 2.6.29-020629-generic x86_64

Mathieu Marquer (slasher-fun) wrote :
James Stansell (jamesstansell) wrote :

This report is really a question about which package provides the javac command. The output listed in the report shows a list of packages, and the sun-java6-plugin package is not in that list.

The javac command is used by programmers and administrators to compile java programs.
For the inexperienced I would recommend trying the sun-java6-jdk package, which will most closely match the many comments that can be found through an internet search.

Changed in sun-java6:
status: New → Invalid
Bill Sullivan (enkrates) wrote :

The original bug reporter miswrote the title of this bug, and it should be a big on sun-java6-jdk. I'll edit the title to make this more clear.

Changed in sun-java6:
status: Invalid → New
Simon Morgan (sjmorgan) wrote :

The problem is that sun-java6-jdk does not update the alternatives system even when there are no other java implementations installed. The javac binary does exist:

~ $ dpkg -L sun-java6-jdk | grep "bin/javac"
/usr/lib/jvm/java-6-sun-1.6.0.10/bin/javac

A temporary fix for the problem is to run "sudo update-java-alternatives -s java-6-sun".

Changed in sun-java6:
status: New → Confirmed
Mathieu Marquer (slasher-fun) wrote :

Temporary fix is working.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers