Ubuntu

javaplugin alternatives are installed incorrectly leading to errors from update-java-alternatives

Reported by Max Bowsher on 2008-05-05
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
openjdk-6 (Ubuntu)
High
Unassigned
sun-java5 (Ubuntu)
Undecided
Unassigned
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

sun-java6-{bin,demo,jdk,jre,plugin,source} 6-06-0ubuntu1

The postinst script installs an alternative called "xulrunner-1.9-javaplugin.so" but the jinfo file contains the name "xulrunner-addons-javaplugin.so". The mismatch prevents update-java-alternatives from working properly - for example, try "update-java-alternatives --plugin --set java-6-sun" and it reports "No alternatives for xulrunner-addons-javaplugin.so."

I believe all of the above is also a problem for the sun-java5-* packages.

Related branches

Matti Lindell (mlind) wrote :

Looks like .jinfo file installed by sun-java5-bin, sun-java6-bin and openjdk-6-bin need addition of xulrunner-1.9-javaplugin.so.

Max Bowsher (maxb) wrote :

More precisely, it needs "xumrunner-addons-javaplugin.so" CHANGING to "xulrunner-1.9-javaplugin.so"

Federico (81joe81) wrote :

I can confirm it (with sun-java6-plugin), and to let my firefox recognize the java plugin I had to do manually this link:
sudo ln -s /etc/alternatives/xulrunner-1.9-javaplugin.so /usr/lib/firefox/plugins/libjavaplugin.so

Edwin Shin (eddie) wrote :

"Me too" on Hardy x86 32bit with java-1.5.0-sun and java-6-sun

Replacing xulrunner-addons-javaplugin.so with xulrunner-1.9-javaplugin.so in /usr/lib/jvm/.java-1.5.0-sun.jinfo and /usr/lib/jvm/.java-6-sun.jinfo allows me to switch back and forth between versions of the plugins now.

Previously, I was seeing the error message reported above ("No alternatives for xulrunner-addons-javaplugin.so.") when running either "sudo update-java-alternatives -s java-1.5.0-sun" or "sudo update-java-alternatives -s java-6-sun".

Matthias Klose (doko) on 2008-06-05
Changed in openjdk-6:
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-6 - 6b10dfsg-1ubuntu1

---------------
openjdk-6 (6b10dfsg-1ubuntu1) intrepid; urgency=low

  * The rebuilt upstream tarball now has GPL-compatible free software licenses
    and documented copyrights and licenses. LP: #238569.
  * Fixed name of the xulrunner-1.9-javaplugin.so in the .jinfo file.
    LP: #226911.
  * Ignore errors during activation of class data sharing.

openjdk-6 (6b10dfsg-1) unstable; urgency=low

  * Rebuild the upstream tar ball:
    - Remove the jscheme jar files.
    - Apply the patch from Iris Clark (Sun) for the copyright headers
      (http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=141#c4).
    - Remove jdk/src/share/classes/java/lang/instrument/package.html.
    - Upload to main.
  * Update IcedTea build infrastructure (20080628).
  * Build an openjdk-6-dbg package.
  * patches/gcc-mtune-generic.diff: Fix typo.
  * openjdk-6-jre: Depend on ttf-dejavu.
  * debian/copyright: Add two more copyright holders, not directly
    mentioned in the third party readme.
    Replace Apache 2.0 license with pointer to common-licenses.
  * Fix more lintian warnings.
  * debian/sun_java_app.xpm: Downsize icon to 32x32 pixels.
  * Build-depend/depend on rhino.

 -- Matthias Klose <email address hidden> Mon, 30 Jun 2008 13:30:06 +0200

Changed in openjdk-6:
status: In Progress → Fix Released
Matthias Klose (doko) wrote :

fixed in sun-java5 1.5.0-16-0ubuntu1
fixed in sun-java6 6-07-0ubuntu1

Changed in sun-java6:
status: New → Fix Released
Changed in sun-java5:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.