Ubuntu

Incomplete/broken java support, app stalls

Reported by Corey T. Brochu on 2008-04-12
8
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sun-java6-plugin

All java runtimes/plugins , from 1.4 to 1.6 (also iced tea, openjdk), have incomplete functionality. This is only noticed when an app is attempting to open up external windows to display information. The bug did not exist in Feisty (other distro's like freespire .etc), but Gutsy and Hardy Beta retain this bug.

I'm not entirely sure if this is a firefox or java-plugin bug, since firefox 3 beta5 still exhibits this behavior, on top of firefox 2.

Here is what happens:

I navigate to www.investools.com , login, and go to the investors toolbox (link near top-left).

Move over to the portfolio section, (just beneath), and it will load the market matrix app (designed by prophet charts I think). It used to be that the whole thing would remain blank, but an update allowed it to load, and it still does. From there, attempting to view the app's extra windows, marked 'ch' and such, will result in nothing, or an error saying that it is still loading. On occasion, the app will launch a bunch of windows upon shutting down firefox, disappearing just as fast.

One time I tried debugging it in a java console, and it seemed like it could not reach their servers, as though it was a firewall issue. I know it had been an issue at one place, but I've tested this on many other systems, to no avail.

Other Distro's are fine regarding this, and I've heard of other's with the same issue on some forum (I forgot where).

Thanks in advance, I'm available to do debugging, since an account is required to get to this app.

Corey T. Brochu (cbrochu) wrote :

Here is a java console's log. Sometimes, it will start working (long time after the fact), so I'll try and get some data from that event as well.
It seems to be a connectivity issue related to some proxy settings, and an apparently empty cookie??

Here is the file.

Corey T. Brochu (cbrochu) wrote :

I've spontaneously managed to get the app to load (pretty random), here is an updated log file.

Matthias Klose (doko) wrote :

this is 1.6.0_03; please could you recheck with 05 (adn 06 if it becomes available)?

Changed in sun-java6:
status: New → Incomplete
Corey T. Brochu (cbrochu) wrote :

Yes, unfortunately, update 5 is still exhibiting this problem (running it on Hardy). The old packages from feisty were fine though, so maybe I could try and compile it's version of the java runtime (assuming no changes to the layout for hardy).

Do you think it would be possible for the feisty java6 packages to run on Hardy???

Matthias Klose (doko) wrote :

please check the 06 update

Corey T. Brochu (cbrochu) wrote :

I confirm that the 06 update still exhibits the problem... I noticed they released a beta version marked 10, I'll give that a shot for what it's worth. Next, I'll find the version in feisty, and try that one.

By the way, the console still gets stuck on a proxy request of sorts.

Corey T. Brochu (cbrochu) wrote :

Ugh... I confirm this bug for beta 10 as well. Only possibility is jre7, which I believe is in alpha?? Hopefully they'll get it right that time. Either that, or ubuntu has something configured that interferes with java (I dunno, networking??). I'll now try to find the old version, to see if that theory is correct.

Corey T. Brochu (cbrochu) wrote :

Well, that's it. I've tested every jre from 6.0.0 to 6.06, as well as the u10 beta AND jre7 build 25 (jre7 is FAST!!!), they all have the bug. Well, actualy, jre u0-2 are unworkable, they don't load at all, and u3 is unavailable for some reason. I even tried the debs from feisty, but I couldn't get them set up because of a library dependency issue (old gcc required).

If you have any ideas, I'll try them out.

Matthias Klose (doko) on 2008-04-18
Changed in sun-java6:
status: Incomplete → Confirmed
Corey T. Brochu (cbrochu) wrote :

Just a thought, if I can get the feisty package to work in hardy, would it be possible to setup a sort of alternative package in the repos? I ask this, because I just noticed that you're the maintainer (kudos to you for that).

Corey T. Brochu (cbrochu) wrote :

Here is a peculiar thing that happens using the icedtea plugin, it actualy works for some advanced stuff (in the main window), but will NOT open any windows at all, not even then ones that sun-java6 did. It seems like an access rights issue of some sort, here is a screenshot of the window that pops up...

Oh, and I can't seem to find the control panel for icedtea, just the standard java-policy tool.

Dan Am (da-lonx) wrote :

I can confirm this bug too, my Java VPN app is not loading, which is a nuissance

Corey T. Brochu (cbrochu) wrote :

I just tested this on debian etch using update 5 again, same results (more sluggish... is etch ever out of date, lol). Oh well, I was hoping this was a ubuntu only thing, now it seems it's at least debian-wide. Maybe rpm based distro's are alright (assuming it's not actually the plugin).

Corey T. Brochu (cbrochu) wrote :

WOHOO! Ok, I knew that Freespire somehow managed to get this thing to work, so I got a hold of their java package (old style j2re1.5), modified it so it could work on Hardy, and presto! This here deb is in working condition, feel free to modify it to your liking should wish to incorporate it in the official repos. Its properly set so as not to conflict with the current sun and openjdk jre's and plugins (but not the jdk's).

If you feel this can be counted as a fix or triage, please set it as such, since I'm not sure what protocols exist for bug closures.

Corey T. Brochu (cbrochu) wrote :

Would anyone like to test this package? If so, I'd like to know how it all works out - I'll work on it some more if it doesn't, or maybe I'll try splitting it into its individual components like jre/plugin (should be fine like this though).

Changed in sun-java6:
status: Confirmed → In Progress
Aaron Hill (aaron-hill) wrote :

Corey: I've installed your package and I can confirm that it works appropriately (at least with the minimal amount of testing that I did). The browser plugin with Firefox 3 Beta 5 makes Sun's Java test page at www.java.com work (the little logo dances around like it's supposed to), and--more importantly for me--it allows me to successfully launch both the java-based HP Integrated Lights-Out applet and the java-based applet of my IP KVM switch from my Ubuntu Hardy laptop (upgraded from Gutsy). I could do none of these things before with Hardy's icedtea/openjdk-6 or sun-java6 packages, and wow, was that a frustrating experience!

Note that this was the extent of my tests--verifying at www.java.com, successfully launching the applets, and using them to connect remotely to the consoles of my servers.

This package conflicted with the openjkd-6 and sun-java6 jre packages; I had to remove them in order to install this package. Is this expected behavior?

Corey T. Brochu (cbrochu) wrote :

@Aaron: Yes, the openjdk-6 and java jre's are set as conflicts, since this one package does not only contain the plugin, it is a mashup of jre/plugin etc... its so that the simlink is not overwritten (I did not set the jdk's as conflicts, since this package does not provide a jdk [and who would want a j2re jdk???]). The reasoning behind this is the same as why you would not have java5 and 6 at the same time (usualy). Anyway, thanks for testing!!

Matthias Klose (doko) wrote :

6-07 can be found in intrepid now

Robert Drake (rdrake-ipsek) wrote :

lrwxrwxrwx 1 root root 40 2008-09-16 09:51 java -> /usr/lib/jvm/java-6-openjdk/jre/bin/java
lrwxrwxrwx 1 root root 39 2008-09-11 02:45 java_vm -> /usr/lib/jvm/java-6-sun/jre/bin/java_vm

The sun page says I'm using sun-java6, so I guess I'm using 6.07. From what I can tell, HP iLO is still broken with intrepid. (Virtual media and remote console open up new windows, but the JVM never seems to start)

But then again, I don't know anything about java (hence my posting of my alternatives folder) so maybe I broke it when I was messing with it earlier.

Doug Holton (edtechdev) wrote :

External applet windows work fine for me. Hopefully the site will work better when the next java6 update hits ubuntu (6 update 11), which will switch to use the new java plugin. Or you can switch to use it now with a couple of commands.

See https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/291135

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers