[hardy] Java plugin not registered in Firefox 2

Bug #211309 reported by Sebastian Kapfer on 2008-04-03
24
Affects Status Importance Assigned to Milestone
icedtea-gcjwebplugin (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Matthias Klose
sun-java5 (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
sun-java6 (Ubuntu)
High
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Java plugin is not registered with Firefox 2, only Firefox 3.

Solution: In sun-java6-plugin.postinst script, extend the

browser_dirs="xulrunner-addons"

variable by "firefox" or "firefox-addons".

whichever is right.

Revision history for this message
Matthias Klose (doko) wrote :

why is this needed? we don't have firefox in hardy anymore.

Changed in sun-java6:
status: New → Incomplete
Changed in icedtea-gcjwebplugin:
status: New → Incomplete
Revision history for this message
Sebastian Kapfer (caci) wrote :
Revision history for this message
Ronald Hummelink (ronald-hummelink) wrote :

Firefox-2 is part of hardy alright, its just not installed by default. I for one have 2 options. Either plugins will work reasonable soon on hardy's firefox-2, or i'll downgrade to Gutsy, simple as that.

So, if I start firefox-2 on a fresh hardy install, and hit a page that needs Java, it pops up the prompt giving me a choise to install one of the 4 java plugins. Java gets installed... and is not registered with FF2, only with FF3B5.

Revision history for this message
Rolf Leggewie (r0lf) wrote :

Sebastian, thank you for the report and providing information as to how to fix the package. How does one go about fixing this until an updated package gets uploaded?

Changed in sun-java6:
importance: Undecided → High
status: Incomplete → Triaged
Revision history for this message
Sebastian Kapfer (caci) wrote :

Edit the shell script /var/lib/dpkg/info/sun-java6-plugin.postinst; extend the variable "browser_dirs" to read

browser_dirs="xulrunner-addons firefox"

And run the resulting shell script. You will have to restart Firefox 2 for the changes to take effect IIRC.

Revision history for this message
Rolf Leggewie (r0lf) wrote :

Sebastian, thank you. Yes, that did the trick. Nominating for Hardy.

Changed in sun-java6:
assignee: nobody → mozillateam
Rolf Leggewie (r0lf) on 2008-04-24
Changed in sun-java6:
assignee: mozillateam → motu
Revision history for this message
SV (sv22342) wrote :

I had the same problem with firefox-2. sun-java6-plugin packages is installed, but there is no symlink in /usr/lib/firefox/plugins for java plugin (/usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so), so I created it and everything is fine now, but this bug still appears in 8.04 official release, so let's hope it will be resolved quite fast.

Revision history for this message
vbbasti (vbbasti-googlemail) wrote : plugins in general

This fault isn't only related on the java plugin. The only registered plugins that appears in the about:plugin page in firefox 2 is the flash plugin, after installing it.

Revision history for this message
Sebastian Kapfer (caci) wrote :

vbbasti: Please file separate bugs for those plugins. This bug is specifically about the Java plugin having dropped firefox2 from its postinst script. Other plugins will have a different mechanism of registering with the browser.

Revision history for this message
Patricio (patricio-stwing) wrote :

Sorry! I am new, I understand the concepts but what do I have to do after fixing sun-java6-plugin.postinst
i.e. how do I ran the script?
How do I know if should use "firefox" or "firefox-addons"?
Thanks!
Patricio

Revision history for this message
Matti Lindell (mlind) wrote :

Patricio,

edit /var/lib/dpkg/info/sun-java6-plugin.postinst and change browser_dirs in line 6 as browser_dirs="xulrunner-addons firefox-addons". Then do "sudo dpkg-reconfigure sun-java6-plugin. Then restart your firefox-2 browser.

about:plugins URL in firefox-2 should display that Java 6 plugin is registered.

Revision history for this message
Patricio (patricio-stwing) wrote :

Matti,
It worked! I used "browser_dirs="xulrunner-addons firefox" Java is up with hardy, firefox 2, AMD32 bits.
Patricio
patricio@patricio-desktop:~$ java -version
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) Client VM (build 10.0-b22, mixed mode, sharing)

berkant (bekir88) on 2008-05-09
Changed in sun-java6:
status: Triaged → In Progress
Matthias Klose (doko) on 2008-05-15
Changed in icedtea-gcjwebplugin:
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package icedtea-gcjwebplugin - 1.0-1ubuntu1

---------------
icedtea-gcjwebplugin (1.0-1ubuntu1) intrepid; urgency=low

  * Don't build the transitional icedtea packages anymore.
  * Register for browsers based on firefox2. LP: #211309.

 -- Matthias Klose <email address hidden> Thu, 15 May 2008 11:04:16 +0200

Changed in icedtea-gcjwebplugin:
status: Incomplete → Fix Released
Revision history for this message
Matthias Klose (doko) wrote :
Changed in sun-java6:
assignee: motu → nobody
status: In Progress → Fix Released
Changed in icedtea-gcjwebplugin:
status: Confirmed → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

Subscribed ~motu-sru to get their ack.

Why did you add the dependency to xul? If this package works for firefox 2 as well, it doesn't seem to be needed?

Revision history for this message
Matthias Klose (doko) wrote : Re: [Bug 211309] Re: [hardy] Java plugin not registered in Firefox 2

Martin Pitt schrieb:
> Why did you add the dependency to xul? If this package works for firefox
> 2 as well, it doesn't seem to be needed?

it is linked against libxul.so

Revision history for this message
Luke Yelavich (themuso) wrote :

AK, but it looks like the version number may need adjustment.

Changed in icedtea-gcjwebplugin:
status: In Progress → Confirmed
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here.

description: updated
Changed in icedtea-gcjwebplugin:
status: Confirmed → Fix Committed
Revision history for this message
nyékhelyi gábor (n0gabor) wrote :

hardy-proposed: doesn't work with firefox-2

Revision history for this message
nyékhelyi gábor (n0gabor) wrote :

Neither the icedtea plugin nor the sun-java6-plugin

Revision history for this message
Philippe Coval (rzr) wrote :

I confirm this bug, this is annoying for most french user who have to do their tax declaration on the web,

How it worked for me :

sudo aptitude install firefox-2 sun-java-plugin

cat | patch -p0 << EOF
--- /var/lib/dpkg/info/sun-java5-plugin.postinst.orig 2008-05-25 13:00:19.000000000 +0200
+++ /var/lib/dpkg/info/sun-java5-plugin.postinst 2008-05-25 13:00:53.000000000 +0200
@@ -3,7 +3,7 @@
 PATH=/sbin:/bin:/usr/sbin:/usr/bin

 priority=53
-browser_dirs="xulrunner-addons"
+browser_dirs="xulrunner-addons firefox"
 PLUGIN=libjavaplugin_oji.so
 PLUGINPTH=/usr/lib/jvm/java-1.5.0-sun/jre/plugin/i386/ns7/$PLUGIN
EOF

sudo dpkg-reconfigure sun-java5-plugin

firefox-2 about:plugins

Good luck with other configurations

Revision history for this message
Martin Pitt (pitti) wrote :

Verification failed, giving back to Matthias for further fixing.

Changed in icedtea-gcjwebplugin:
assignee: nobody → doko
status: Fix Committed → In Progress
Revision history for this message
Steve Langasek (vorlon) wrote :

the icedtea-gcjwebplugin version 1.0-0ubuntu6 currently in hardy-proposed includes a regression, bug #231748, which must be resolved in any SRU for this package. (I believe the fix is already in progress).

Revision history for this message
Steve Langasek (vorlon) wrote :

1.0-0ubuntu7 has been accepted into -proposed, so this is back to needing testing.

Martin Pitt (pitti) on 2008-06-16
Changed in icedtea-gcjwebplugin:
status: In Progress → Fix Committed
Revision history for this message
Kjell Braden (afflux) wrote :

I recreated the bug with icedtea-gcjwebplugin 1.0-0ubuntu5. After upgrading to 1.0-0ubuntu7, it didn't fix the issue at first (I got the following error: libxul.so: cannot open shared object file: No such file or directory). After installing libxul-dev it worked and fixed the issue for me.

Revision history for this message
Martin Pitt (pitti) wrote :

Thank you for testing. This indicates a bug, it is definitively wrong to link against something that is only provided by a -dev package, and also it is wrong that the plugin links to xulrunner in the first place (it is not needed for firefox-2).

Changed in icedtea-gcjwebplugin:
status: Fix Committed → Confirmed
Revision history for this message
Matthias Klose (doko) wrote :

fixed in sun-java5 1.5.0-16 in intrepid

Changed in sun-java5:
status: New → Fix Released
Revision history for this message
Joel Ebel (jbebel) wrote :

Given bug 258624 that identifies that openjdk-6 isn't compiled for firefox-2 it seems this bug isn't valid for icedtea-gcjwebplugin anymore. Sad since there is now now 64 bit java plugin that works in firefox 2.

Revision history for this message
Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in sun-java5 (Ubuntu Hardy):
status: New → Won't Fix
Changed in sun-java6 (Ubuntu Hardy):
status: New → Won't Fix
Rolf Leggewie (r0lf) on 2014-11-23
Changed in icedtea-gcjwebplugin (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers