[hardy] netbeans doesn't run

Bug #159749 reported by Vicente Ruiz on 2007-11-03
6
Affects Status Importance Assigned to Milestone
Sun Java
Fix Released
Unknown
xlibs
Invalid
Unknown
sun-java6 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: netbeans5.5

When I try run netbeans, it show this output:

$ netbeans
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted (core dumped)

More info:

$ dpkg -l netbeans5.5 | grep ii
ii netbeans5.5 5.5.1-2 NetBeans IDE for development of applications in Java

$ dpkg -l sun-java5-bin | grep ii
ii sun-java5-bin 1.5.0-13-0ubuntu1 Sun Java(TM) Runtime Environment (JRE) 5.0 (architecture dependent files)

$ dpkg -l sun-java5-demo | grep ii
ii sun-java5-demo 1.5.0-13-0ubuntu1 Sun Java(TM) Development Kit (JDK) 5.0 demos and examples

$ dpkg -l sun-java5-jdk | grep ii
ii sun-java5-jdk 1.5.0-13-0ubuntu1 Sun Java(TM) Development Kit (JDK) 5.0

$ dpkg -l sun-java5-jre | grep ii
ii sun-java5-jre 1.5.0-13-0ubuntu1 Sun Java(TM) Runtime Environment (JRE) 5.0 (architecture independent files)

$ uname -r
2.6.22-14-generic

ProblemType: Bug
Architecture: i386
Date: Sat Nov 3 16:03:22 2007
DistroRelease: Ubuntu 8.04
Package: netbeans5.5 5.5.1-2
PackageArchitecture: all
SourcePackage: netbeans5.5
Uname: Linux SamsungX05 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Vicente Ruiz (uve) wrote :
Vicente Ruiz (uve) wrote :
Vicente Ruiz (uve) wrote :

The same problem with java6.

$ sudo apt-get install sun-java6-jdk

$ sudo update-alternatives --config java

Hay 3 alternativas que proveen `java'.

  Selección Alternativa
-----------------------------------------------
          1 /usr/bin/gij-4.2
 + 2 /usr/lib/jvm/java-6-sun/jre/bin/java
* 3 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java

Pulse <Intro> para mantener el valor por omisión [*] o pulse un número de selección: 2
Se utiliza `/usr/lib/jvm/java-6-sun/jre/bin/java' para proveer `java'.

$ netbeans --jdkhome /usr/lib/jvm/java-6-sun/
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Aborted (core dumped)

Vicente Ruiz (uve) wrote :

The problem is in libraries libxcb1 and libxcb-xlib0. If I force the feisty version (1.0-1.1ubuntu2) then it work fine.

Marek Slama (mslama-email) wrote :

It is JDK problem as mentioned above.

Changed in netbeans5.5:
status: New → Invalid
Richard Johnson (nixternal) wrote :

I can confirm this bug and it is indeed a Java bug as it is also effecting Eclipse.

Changed in netbeans5.5:
importance: Undecided → High
status: Invalid → Confirmed
Daniel Hahler (blueyed) wrote :

I'm going to mark this as duplicate of bug 86103.

Please note that you should use "update-java-alternatives" to update all java-related alternatives-links.

Changed in sun-java6:
status: Confirmed → Invalid
Changed in sun-java:
status: Unknown → Confirmed
Changed in xlibs:
status: Unknown → Invalid
Changed in sun-java:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.