Java 6 system tray not working in Gutsy Tribe 6

Bug #139177 reported by xlinuks on 2007-09-12
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
In Gutsy Gibbon Tribe 6 (build date 4th September 2007) the Java version 6 from Sun (java full version "1.6.0_02-ea-b01") can't use the system tray _if_ Gutsy has "Desktop Effects" enabled (System->Preferences->Appearance->Desktop Effects: Normal Effects or Extra Effects).
Please note that:
- Java 6 _can_ use the system tray if it has been launched _before_ desktop effects have been enabled.
- Java 6 _cannot_ use the system tray (throws an exception) if it has been launched with desktop effects already enabled.
I understand that Java 6 from Sun is not fully opened yet so the Ubuntu developers might not be able to help here, but my duty is to at least report this problem.
I would provide a short video demonstrating this but the recording application I'm using (gtk-recordMyDesktop) doesn't work correctly during desktop effects being enabled/disabled.

Additional info (if that matters, using Sysinfo app to get info):
Release: lenny/sid
Gnome: 2.19.92
GCC version: 4.1.3 (i486-linux-gnu)
Xorg version: 1.3.0 (04 September 2007)
Kernel: 2.6.22-11-generic (#1 SMP Fri Sep 7 05:07:05 GMT 2007)
CPU Model Name: Intel(R) Pentium(R) D CPU 3.40GHz
RAM: 2GB
Graphics Card: Nvidia GeForce 7600 GT 256MB on PCI-Express

Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

xlinuks (xlinuks-yahoo) wrote :

Yes, by now I have the final Gutsy release (I formatted the partition and made a brand new installation) and the issue is (still) there. I don't know how to help you. However I recorded it.

The Java app from the video I'm using to show that the system tray works/doesn't work (only 74KB):
http://xlinuks.googlepages.com/JDocBrowser.jar

The first part where I start the Java app _after_ I have enabled desktop effects (only 0.9MB), the system tray doesn't work:
http://xlinuks.googlepages.com/java_tray1.ogg

The first part of the video where I start the Java app _after_ I have disabled desktop effects (1.1MB), the system tray works:
http://xlinuks.googlepages.com/java_tray2.ogg

On the videos I'm 'shaking' the windows to let you know whether the desktop effects are enabled or not.

If needed - Java app contains the source code (unzip the jar and find the 'src' folder, I wrote it a while ago..).
ps: I can live with this issue... IMHO the biggest issue with Java on Ubuntu 7.10 is that it cannot print...

xlinuks (xlinuks-yahoo) wrote :

typo: I actually mean "the second part" in the place where I'm saying that the system tray works.
a remark: to run the app you need Java 6 from Sun (just making sure you can reproduce it..)

machaval (achaval) wrote :

There is a way to workaround this .
package com;

import sun.awt.X11.XToolkit;

public class CompizToolkit extends XToolkit {

    public CompizToolkit() {

    }

    public boolean isTraySupported() {
        return true;
    }
}

and specify -Dawt.toolkit=com.CompizToolkit as a System Property
Thanks to Patricio Barletta ideas

Kamil Páral (kamil.paral) wrote :

This bug is reported in Sun
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6438179
and apparently will be fixed in Java 6 update 10.

xlinuks (xlinuks-yahoo) wrote :

I just finished checking Java 6 update 10 and I can confirm that the system tray works fine.
There remains only one major Java bug in Ubuntu: Java cannot print.

Aleksandr Panzin (jalexoid) wrote :

Tried the repository versions on Hardy (OpenJDK 6b11-2ubuntu2 and java-sun-sdk 6.07-3ubuntu2).
Tray DOES NOT WORK! Tried Java SDK 6 update 11 from Sun, works.

pinzia (pinzia) wrote :

Gutsy is EOL.

Changed in sun-java6 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers