Ubuntu

compiz - java problems

Reported by domagoj on 2007-07-07
This bug report is a duplicate of:  Bug #118983: compiz & java windows always grey. Edit Remove
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sun-java6 (Fedora)
Fix Released
Unknown
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi all,
this is my java settings:

dpkg -l sun-java* | grep ii
ii sun-java6-bin 6-00-2ubuntu2 Sun Java(TM) Runtime Environment (JRE) 6 (ar
ii sun-java6-demo 6-00-2ubuntu2 Sun Java(TM) Development Kit (JDK) 6 demos a
ii sun-java6-fonts 6-00-2ubuntu2 Lucida TrueType fonts (from the Sun JRE)
ii sun-java6-jdk 6-00-2ubuntu2 Sun Java(TM) Development Kit (JDK) 6
ii sun-java6-jre 6-00-2ubuntu2 Sun Java(TM) Runtime Environment (JRE) 6 (ar

$ update-alternatives --list java
/usr/bin/gij-wrapper-4.1
/usr/lib/jvm/java-6-sun/jre/bin/java

I am having ati radeon X700 video card, and i am using radeo driver. I have set up compiz as described here:
https://help.ubuntu.com/community/CompositeManager/ConfiguringCompiz

After that all java swing application just desplay empty blank windows?
After few hours of plying around, i found out that if i kill compiz by. for example killall compiz
i can se content of java windows but i do not have an more window title bar etc - since compiz was drawing them.

domagoj (domagoj-madunic) wrote :

This is how for example JXplorer looks like.

John Clarke (jrc61) wrote :

I see the same behaviour with java (sun-java5 or sun-java6) + beryl +nvidia-glx on Feisty. If I change the window manager from Beryl to Metacity, the java app (JOSM) works normally.

Sitsofe Wheeler (sitsofe) wrote :

(Might be a duplicate of Bug #118983 )

Matthias Klose (doko) wrote :

please recheck with current gutsy

Changed in sun-java6:
status: New → Incomplete
Sergey Nazarov (phearnot) wrote :

I confirm for current Gutsy - the problem persists.

Daniel Moyne (dmoyne) wrote :

I have also the same problems in the following conditions :
- Gutsy,
- any Jdk's from 5 to 6
- Compiz

All Java windows after activation of Compiz are grayed.

Rocko (rockorequin) wrote :

On my system I *occasionally* get greyed windows opening from java apps, using

java build 1.6.0_03-b05
compiz 1:0.6.0+git20071008-0ubuntu1
video card: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

I've seen it happen to Netbeans as well as my own java apps.

It is apparently random - usually the windows are fine.

Sometimes when the windows open, they are also an incorrect size; other times, they are the expected size, but just blank.

If I turn off compiz effects, the windows always open fine.

davie (daviemoston) wrote :

I still see intermittently on 1.6.0_03-b05 - mostly in dialog (modal) boxes. The sun bug for this is marked as fixed (http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6429775), but there are plenty of recent comments suggesting that it's still a problem.
exporting AWT_TOOLKIT=MToolkit isn't a long term solution, Mtoolkit was replaced by default with XToolkit in java 5, and is likely to be removed at some point.

davie (daviemoston) wrote :

There's another sun bug here http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6632124, marked as in-progress.
There is also a thread about it here http://forums.java.net/jive/thread.jspa?threadID=33311.
Marking as new.

Changed in sun-java6:
status: Incomplete → New
davie (daviemoston) on 2008-01-11
Changed in sun-java6:
status: New → Confirmed
Changed in sun-java6:
status: Unknown → Incomplete
Changed in sun-java6:
status: Incomplete → Invalid
Changed in sun-java6:
status: Invalid → Fix Released
Michael Vondung (mivo) wrote :

This bug still occurs in Hardy Heron (8.04) and Java6. (Both 32- and 64-bit versions.)

frado (frado) wrote :

Hi, my compiz exits when I switch Netbeans ide from Source to Design mode (sometime).

Benjamin Popp (haven1433) wrote :

I've been having similar problems with Java under Compiz. I noticed that on my Mepis computer and Kubuntu notebook that only the Dialogs fail, not the Frames. I was also able to make the glitch happen with less frequency by calling the garbage collector. I basically set it so the garbage collector ran at the beginning of each actionPerformed(), and this made the Dialogs much more reliable.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.