java plugin does not work

Bug #112994 reported by Martin on 2007-05-07
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
High
Alexander Sack
sun-java5 (Ubuntu)
High
Alexander Sack
sun-java6 (Ubuntu)
High
Alexander Sack

Bug Description

Solution for sun-java5 and sun-java6 (Ubuntu):

  -> move plugin links to /usr/lib/firefox/plugins/ (currently they point to not-inspected /usr/lib/mozilla-firefox/plugins/)

Սահակ (petrosyan) wrote :

I can confirm this bug.
Typing "about:plugins" in Firefox address bar doesn't display any java plugins even though sun-java6-plugin package and all of its dependencies have been installed.

Nicola Rosati (supernaicol) wrote :

Same as Ani to me too.
I think it's worth to note that the plugin function well with the mozilla (icemonkey) browser, but not with firefox.

Nicola Rosati (supernaicol) wrote :

I tried to downgrade firefox from the gutsy version (2.0.0.3+3) to the feisty version (2.0.0.3+1) and now the java plugin seems to work as expected (and other plugins too). Maybe the bug is to be assigned to firefox?

Nicola Rosati (supernaicol) wrote :

Update:
I've resolved manually adding a simlink to /usr/lib/jvm/java-6-sun-1.6.0.00/jre/plugin/i386/ns7/libjavaplugin_oji.so in "/home/user/.mozilla/plugin".
Bye.

John Vivirito (gnomefreak) wrote :

sudo update-alternatives --config java is all you need to run im not sure why you added --firefox in there since it is a system wide setting. did you restart firefox after running that command? I have no issues on either of my feisty systems and sun-java6-plugin package.

sorry, it does not work here!

John Vivirito (gnomefreak) wrote :

Nicolo what didnt work there?

Nicolò Chieffo (yelo3) wrote :

the update-alternative command did not have the expected result!
(plugin still not found by firefox) This is maybe because I'm using
ubuntu gutsy...

Iain Houston (iainhouston) wrote :

Even though update-alternative says: Using `/usr/lib/jvm/java-6-sun/jre/bin/java' to provide `java'.
On Feisty, Firefox won't run Java applets.
http://java.com/en/download/help/testvm.xml confirms this even after restarting Firefox.

Nicolò Chieffo (yelo3) wrote :

even in feisty? I thought only gutsy...

Iain Houston (iainhouston) wrote :

Sorry if I'm confusing things!
In Feisty I did:
 cd ~/.mozilla/plugins
 ln -s /usr/lib/jvm/java-6-sun-1.6.0.00/jre/plugin/i386/ns7/libjavaplugin_oji.so libjavaplugin_oji.so
as recommended elsewhere and Java plugins work

... well, to the extent that
 http://java.com/en/download/installed.jsp says ...
...that I'm not up-to-date with Java 1.6.0
and that it recommends Version 6 Update 1!
Well, too bad ... it'll have to wait!

John Vivirito (gnomefreak) wrote :

Trismegister please read your link a bit closer it states
JRE version(s):
1.4.2_xx, 1.5.0, 1.3.0_xx, 1.3.1_xx, 1.4.0_xx, 1.4.1_xx

notice it is not testing 1.6.

Nicolò Chieffo (yelo3) wrote :

Anyway the plugin should work without linking it...

Thank you all for your comments. I have confirmed this due to multiple comments and assigned it to the correct team for Firefox

Changed in firefox:
assignee: nobody → mozilla-bugs
status: Unconfirmed → Confirmed
Mikael Gerdin (mgerdin) wrote :

In gutsy the problem seems to be that /usr/lib/firefox/plugins is missing the symlink libjavaplugin.so->/etc/alternatives/firefox-javaplugin.so

Alexander Sack (asac) wrote :

On Sat, Jun 16, 2007 at 11:05:15AM -0000, Mikael Gerdin wrote:
> In gutsy the problem seems to be that /usr/lib/firefox/plugins is
> missing the symlink libjavaplugin.so->/etc/alternatives/firefox-
> javaplugin.so
>

Thanks for finding this out ... but is it really the responsibility of
firefox to ship that link? I think no, but I am open to hear why
:). When did this alternative for firefox-javaplugin.so first appear?
In gutsy?

 - Alexander

Alexander Sack (asac) wrote :

taking it to keep on radar. Setting milestone tribe-2 for now.

Changed in firefox:
assignee: mozilla-bugs → asac
importance: Undecided → High
Mikael Gerdin (mgerdin) wrote :

I think I've found a reason to this problem, the package making the libjavaplugin.so symlinks (whichever it is) is creating the symlink in /usr/lib/mozilla-firefox/plugins/ this was no problem on Feisty since /usr/lib/mozilla-firefox was a symlink to /usr/lib/firefox. In Gutsy the symlink has been removed, but libjavaplugin.so continues to install the symlink in /usr/lib/mozilla-firefox/plugins where firefox does not look for it anymore.

Mikael Gerdin (mgerdin) wrote :

And now I've found a way to fix it (I hope)
This is a patch to the sun-java5 source package, to JB-plugin.postinst.in
to change the path to /usr/lib/firefox/plugins
it should work with java6 too, but I haven't tried it.

Alexander Sack (asac) wrote :

On Sat, Jun 16, 2007 at 03:25:00PM -0000, Mikael Gerdin wrote:
> And now I've found a way to fix it (I hope)
> This is a patch to the sun-java5 source package, to JB-plugin.postinst.in
> to change the path to /usr/lib/firefox/plugins
> it should work with java6 too, but I haven't tried it.

Thanks for your contribution. Could you please prepare a tested java6
patch as well?

 - Alexander

Mikael Gerdin (mgerdin) wrote :

I've tested it and the same patch applies to java6 as well, and installs the alternatives-file in the correct location.

Alexander Sack (asac) wrote :

this should be dealt with by sun-java6

Changed in firefox:
status: Confirmed → Rejected
Alexander Sack (asac) wrote :

sun-java6 plugin installs symlink to old firefox plugins dir. Patch is attached.

Changed in sun-java6:
importance: Undecided → High
status: Unconfirmed → Confirmed
Alexander Sack (asac) wrote :

appears to affect sun-java5 as well (patch attached was developed against sun-java5)

Changed in sun-java5:
importance: Undecided → High
status: Unconfirmed → Confirmed
Alexander Sack (asac) on 2007-06-21
description: updated
description: updated
Changed in sun-java5:
status: Confirmed → Triaged
Changed in sun-java6:
status: Confirmed → Triaged
Áron Sisak (asisak) on 2007-06-22
Changed in sun-java5:
assignee: nobody → asisak
status: Triaged → In Progress
Alexander Sack (asac) on 2007-06-22
Changed in sun-java6:
assignee: nobody → asac
Áron Sisak (asisak) wrote :
Áron Sisak (asisak) wrote :
Áron Sisak (asisak) on 2007-06-22
Changed in sun-java5:
assignee: asisak → asac
status: In Progress → Triaged
Alexander Sack (asac) wrote :

sun-java6 (6-00-2ubuntu3) gutsy; urgency=low

  * debian/JB-plugin.postinst.in: s/mozilla-firefox/firefox/
    install alternative to new firefox plugin directory
    (LP: #112994).
  * debian/rules: don't dh_installdirs for mozilla-firefox
    plugins directory anymore.

 -- Alexander Sack <email address hidden> Mon, 25 Jun 2007 11:05:33 +0200

Alexander Sack (asac) wrote :

sun-java5 (1.5.0-11-1ubuntu3) gutsy; urgency=low

  * debian/JB-plugin.postinst.in: s/mozilla-firefox/firefox/
    install alternative to new firefox plugin directory
    (LP: #112994).
  * debian/rules: don't dh_installdirs for mozilla-firefox
    plugins directory anymore.

 -- Alexander Sack <email address hidden> Mon, 25 Jun 2007 10:59:32 +0200

Changed in sun-java5:
status: Triaged → Fix Released
Changed in sun-java6:
status: Triaged → Fix Released
ReveueWired (aaronbick) wrote :

How do i install this patch?

I am still an ubuntu-noob

I have installed java6, so far is does not show in about:plugins...

Alexander Sack (asac) wrote :

On Tue, Jul 17, 2007 at 07:17:23PM -0000, ReveueWired wrote:
> How do i install this patch?
>
> I am still an ubuntu-noob
>
> I have installed java6, so far is does not show in about:plugins...
>

how did you install java6?

 - Alexander

Thom Pischke (thom-pischke) wrote :

Had this problem in the gutsy final release, but the solution above didn't work.

To fix I had to update the symbolic link /etc/alternatives/firefox-javaplugin

Old Incorrect location: /usr/lib/jvm/java-1.6.0-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so
New Correct location: /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so

Seems that if you had java 6 installed in feisty, then upgraded to gutsy, this got broke. Installing the plugin via firefox didn't help, since that only points to the alternatives link, which was pointing at a nonexistent java.

Hope this helps someone else whose still trying to get the java plugin working after update...

Thom Pischke (thom-pischke) wrote :

Perhaps sudo update-alternatives --config java would have worked.

I didn't try it because it was already pointing at java 6. Maybe if I had pointed it at gcj, then back at java 6, it would have updated the plugin link automatically to the correct new java 6 location. Worth trying I guess, before messing with links manually.

I'm another victim of this problem, and I also confirm that the

sudo update-alternatives --config java

solution does not work. I have installed and reinstalled so many damn things that I have no idea what is going on at this point. I do have the hypothesis that the real problem was caused by gcj being installed first. I think that it is not uninstalling correctly, and that this is somehow preventing proper installation of any other Java.

The gcj itself does seem to install and execute from Firefox, but it's broken Java, with lots of minor problems and a couple of fatal show stoppers.

Right now I feel like the solution is to use an alternative browser for Java stuff... Overall Gutsy has been a major disappointment, and it has been driving me back to Windows much more often these days. I really don't need the frustration, and I didn't sign on to be a beta tester. I really do hate Microsoft's attacks on my freedom, but lately Ubuntu seems to be going in the wrong direction.

Look,

I got a odd thing when I update firefox. The option to enable java was set to off after update. To enable, I simply set Edit -> Preferences -> Content ->Allow Java to on.

Shanen, when you find a problem, don't give up and became a Windows apologist. We don't fight for All Free Software makes better than Windows. We fight to build a better world to us. A world that we can call "Our World", free from monopolists companies.

Think about this.

Um grande abraço a todos,

Amarelo.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers