[needs-packaging] sun-java-fonts

Bug #1034921 reported by Pander on 2012-08-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

The package with these fonts has disappeared but should be repaclaged again in order not to break with older software.

Hi,

The Lucida TrueType fonts (ttf-lucida) were used to be provided by sun-java6-fonts,
but it is not in Ubuntu 11.10 Oneiric any more.

How do I get he Lucida fonts and what is java default font then?

Thanks

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sun-java6 (Ubuntu):
status: New → Confirmed
Revision history for this message
Pander (pander) wrote :
Revision history for this message
Sylvestre Ledru (sylvestre) wrote :

It is not something what we wanted but we had to remove sun-java6 from the Debian and Ubuntu archives... The license does not allow the redistribution.

See: http://sylvestre.ledru.info/blog/sylvestre/2011/10/25/removal_of_sun_java6_from_debian

And a workaround is:
http://sylvestre.ledru.info/blog/sylvestre/2012/02/29/java_package_replacement_of_sun_java6

Changed in sun-java6 (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Won't Fix
Revision history for this message
Pander (pander) wrote :

I understand sun-java6 is no longer packaged because of critical bugs that aren't fixed. This was relating only to the font files but I respect if these cannot packaged separately.

tags: added: fonts
Revision history for this message
Sylvestre Ledru (sylvestre) wrote :

I wish I could but it is not possible for licensing reasons.
In the license of the sun jdk, the dependencies were part of the license.
See: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=625617

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.