Ubuntu

badly-formatted orbd manpage

Reported by Ori Avtalion on 2007-04-05
4
Affects Status Importance Assigned to Milestone
man-db (Ubuntu)
Medium
Colin Watson
sun-java6 (Ubuntu)
Medium
Matthias Klose

Bug Description

Due to a bug in man-db (already fixed up-stream), ".RS 3" in the manpage causes it to be aliased as "3"

The effect is that any execution of "man 3" or "man 3 unexisting-command" will show the orbd output.

To side-step the bug, he man page should put the text below "orbd \- The Object Request Broker Daemon" in a section other than NAME.

Colin Watson (cjwatson) wrote :

Matthias, could you look at this in time for Feisty, please? The bug seems minor but the consequences are annoying. I'm not ultra-confident enough in my code fix to push that into Feisty, especially as man-db is in main and sun-java6 is in multiverse.

Please also check whether other man pages in this package or in sun-java5 suffer from the same bug (.RS 3 in a NAME section).

Changed in sun-java6:
assignee: nobody → doko
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Matthias Klose (doko) wrote :

Tom, are we allowed to fix this in the man page? That would be a (minimal) change, but the license allows unmodified distribution only

Changed in sun-java6:
status: Confirmed → Needs Info
Colin Watson (cjwatson) wrote :

The licence doesn't allow modification so we can't fix this for Feisty. I'll (reluctantly) fix man-db instead.

Changed in sun-java6:
status: Needs Info → Confirmed
Changed in man-db:
assignee: nobody → kamion
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Tom Marble (tmarble) wrote :

I'm looking into it now... My temptation is to "do the right thing" which is have you fix the man page.

Colin Watson (cjwatson) wrote :

man-db (2.4.3-5ubuntu1) feisty; urgency=low

  * Backport from upstream:
    - src/lexgrog.l: Break whatis definitions at .IP, .HP, .RS, and .RE
      (thanks to Ori Avtalion for the report; LP: #103384).

 -- Colin Watson <email address hidden> Thu, 5 Apr 2007 18:54:30 +0100

Changed in man-db:
status: Confirmed → Fix Released
Tom Marble (tmarble) wrote :

I'm sorry, modifying the man pages is not currently permitted under the DLJ (I've made a note to fix the README).

--Tom

Matthias Klose (doko) wrote :

man-db was fixed, closing the sun-java6 task, because we are not allowed to change it.

Changed in sun-java6:
status: Confirmed → Invalid
Ori Avtalion (salty-horse) wrote :

Was the problem reported upstream to Sun?

Tom Marble (tmarble) wrote :

@Ori:

Yes, I reported it on April 5 and I have just sent another reminder.

--Tom

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers