SuiteSparse fails to link in shared library due to missing -fPIC in libsuitesparseconfig.a

Bug #1319687 reported by Arne Morten Kvarving on 2014-05-15
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
suitesparse (Debian)
Fix Released
Unknown
suitesparse (Ubuntu)
Low
Unassigned

Bug Description

The config library is only available as a .a which is not compiled with -fPIC. Thus, linking into shared libraries fails on AMD64.

Attaching a minimal program to trigger the bug.

gcc -shared -fPIC -o test.so suitetest.cpp -lumfpack -lsuitesparseconfig

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in suitesparse (Ubuntu):
status: New → Confirmed
Budo Zindovic (bzindovic) wrote :

I've added a fix to official libraries and packaged it in my ppa. To install libraries with a fix of this bug, do the following:

1. sudo add-apt-repository ppa:bzindovic/suitesparse-bugfix-1319687
2. sudo apt-get update
3. sudo apt-get upgrade

I hope it will be resolved in the official package.

doh, missed your response. thanks a lot!

Hi Budo,
I don't think your approach is the right one, working against the package maintainer's intent to provide both types of libraries, one with -fPIC and one without.
Check out my update to Debian bug #684116: the package already builds a libsuitesparseconfig_pic.a and simply misses to include it in the binary .deb file. I noticed when going through the patches that were already in the package before yours.

The attachment "include libsuitesparseconfig_pic.a in libsuitesparse-dev" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thanks bug reading bugs.debian.org/cgi-bin/bugreport.cgi?bug=684116 it seems the Debian maintainer disagrees with the change, unsubscribing sponsors until that's resolved, no need to have the discussion in 2 different bug trackers

Changed in suitesparse (Ubuntu):
importance: Undecided → Low
Changed in suitesparse (Debian):
status: Unknown → Fix Released
Pedro (pedro-cavestany) wrote :

Hi, this bug has been around for near 2 years now, when will it be fixed in Ubuntu?
thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.