Network Manager 0.7 support

Bug #295113 reported by Morgan Collett
6
Affects Status Importance Assigned to Milestone
Sugar
Won't Fix
Unknown
sugar (Ubuntu)
Medium
Unassigned
sugar-base (Ubuntu)
Undecided
Unassigned
sugar-presence-service (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sugar

Sugar 0.82 has an interface to NM 0.6 but Intrepid has NM 0.7, so accessing and using Access Points on the Neighborhood View doesn't work.

Upstream sugar developers are working on a patch.

Luke Faraone (lfaraone)
Changed in sugar:
importance: Undecided → Medium
status: New → Triaged
Changed in sugar-presence-service:
status: Unknown → Confirmed
Changed in sugar:
status: Unknown → New
Changed in sugar:
status: New → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sugar-presence-service - 0.83.3-0ubuntu1

---------------
sugar-presence-service (0.83.3-0ubuntu1) jaunty; urgency=low

  * New upstream release.
    + Provides NetworkManager 0.7 support (LP: #295113)
  * Update debian/control*:
    + Remove Vcs-Git and Vcs-Browser since they are debian-specific
      and we're not yet using git for packaging in Ubuntu
    + Set Maintainer to ubuntu-motu
    + Drop dependency on telepathy-stream-engine (LP: #217693)
  * debian/watch: Add sugarlabs URL

 -- Morgan Collett <email address hidden> Mon, 02 Feb 2009 16:09:21 +0200

Changed in sugar-presence-service:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sugar - 0.83.5-0ubuntu1

---------------
sugar (0.83.5-0ubuntu1) jaunty; urgency=low

  * New upstream release.
    + Provides NetworkManager 0.7 support (LP: #295113)
  * debian/{control,control.in}:
    + Remove Vcs-Git and Vcs-Browser since they are debian-specific
      and we're not yet using git for packaging in Ubuntu
    + Add Build-Depends on libgconf2-dev and Depends on libgconf2-4
  * Remove 0001 patch - merged in upstream release.
  * Remove 0002, 2004, 2992 patches - no longer relevant.
  * Update 2002 patch for path of wpa_passphrase
    - upstream code was refactored.
  * Disable 2001 patch (empy) - has no effect as Makefile.in not patched.
  * debian/sugar.install:
    + drop /etc path as NetworkManagerInfo.conf is no longer included
  * debian/watch: Remove 0.82.* restriction

 -- Morgan Collett <email address hidden> Mon, 02 Feb 2009 14:00:55 +0200

Changed in sugar:
status: Triaged → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sugar-base - 0.83.3-0ubuntu1

---------------
sugar-base (0.83.3-0ubuntu1) jaunty; urgency=low

  * New upstream release.
    + Provides NetworkManager 0.7 support (LP: #295113)
  * Update debian/control*:
    + Remove Vcs-Git and Vcs-Browser since they are debian-specific
      and we're not yet using git for packaging in Ubuntu
  * Remove 0000 patch - merged in upstream release
  * Add sugarlabs URL to watch file, update to 0.83.x
  * Update debian/copyright and copyright hints (from Debian 0.82.2-5):
    + Bump to version 428 of new format (no structural changes)
    + Set Sugarlabs (not Redhat) as upstream maintainer, and add both
      old laptop.org and new sugarlabs.org source URLs.
    + Merge entries with same authors and licensing (varying only in
      copyright years).
    + Update copyright years
    + Include GAP licenses verbatim.

 -- Morgan Collett <email address hidden> Mon, 02 Feb 2009 13:30:16 +0200

Changed in sugar-base:
status: New → Fix Released
Revision history for this message
Eduardo Silva (jobezone) wrote :

I'm using an updated Ubuntu Intrepid, and using Intrepid sugar packages, and still don't see any AP's in the neighborhood. Could it be because I use the bcm43 chipset which I use with ndiswrapper?

Revision history for this message
Luke Faraone (lfaraone) wrote :

Eduardo,

The new sugar versions are present in Jaunty, the current development release of Ubuntu, and are unlikely to be backported to hardy or intrepid until after the Jaunty release, if ever.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.