Ubuntu

Sugar Browse fails on startup

Reported by Edward Cherlin on 2008-08-31
18
Affects Status Importance Assigned to Milestone
hulahop (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by James Westby
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
sugar-hulahop (Ubuntu)
Undecided
Unassigned
Declined for Jaunty by James Westby
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
sugar-web-activity (Ubuntu)
Medium
Unassigned
Declined for Jaunty by James Westby
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: sugar-web-activity

Ubuntu Hardy 8.04
Browse installed from package sugar-web-activity 86-0ubuntu-1

When I click on the Browse icon to start it, it indicates that it is starting, and then goes away rather than opening.

The log file, org.laptop.WebActivity-1.log, says

ImportError: libxul.so: cannot open shared object file: No such file or directory

In fact, /usr/lib/xulrunner-1.9.0.1/libxul.so is present. Adding a symlink from /usr/lib/libxul.so fixes this problem, but then,

ImportError: libxpcom.so: cannot open shared object file: No such file or directory

In fact, /usr/lib/xulrunner-1.9.0.1/libxpcom.so is present. Adding a symlink from /usr/lib/libxpcom.so fixes this problem, but then,

ImportError: libpyxpcom.so: cannot open shared object file: No such file or directory

In fact, /usr/lib/xulrunner-1.9.0.1/libpyxpcom.so is present. Adding a symlink from /usr/lib/libpyxpcom.so fixes this problem, but then,

ImportError: libsqlite3.so: cannot open shared object file: No such file or directory

In fact, /usr/lib/sqlite3.0.8.6.so is present. Adding a symlink from /usr/lib/sqlite3.so fixes this problem, but then,

ImportError: libmozjs.so: cannot open shared object file: No such file or directory

In fact, /usr/lib/mozjs.so is present. Adding a symlink from /usr/lib/mozjs.so fixes this problem.

But then, we get serious problems. From org.laptop.WebActivity-9.log:

Obtaining the module object from Python failed.

<type 'exceptions.AttributeError'>: 'module' object has no attribute 'NS_GetModule'
Creating an interface object to be used as a result failed

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 443, in MakeInterfaceResult
    return Component(ob, iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 229, in __init__
    self.QueryInterface(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 299, in QueryInterface
    self._remember_interface_info(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 272, in _remember_interface_info
    method_infos, getters, setters, constants = BuildInterfaceInfo(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 147, in BuildInterfaceInfo
    interface = xpt.Interface(iid)
  File "/var/lib/python-support/python2.5/xpcom/xpt.py", line 83, in __init__
    item = iim.GetInfoForIID(iid)
<type 'exceptions.TypeError'>: Objects of type 'IID' can not be converted to an IID
Creating an interface object to be used as a result failed

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 443, in MakeInterfaceResult
    return Component(ob, iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 229, in __init__
    self.QueryInterface(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 299, in QueryInterface
    self._remember_interface_info(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 272, in _remember_interface_info
    method_infos, getters, setters, constants = BuildInterfaceInfo(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 147, in BuildInterfaceInfo
    interface = xpt.Interface(iid)
  File "/var/lib/python-support/python2.5/xpcom/xpt.py", line 83, in __init__
    item = iim.GetInfoForIID(iid)
<type 'exceptions.TypeError'>: Objects of type 'IID' can not be converted to an IID
Obtaining the module object from Python failed.

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/xpcom/server/__init__.py", line 82, in NS_GetModule
    import loader
  File "/var/lib/python-support/python2.5/xpcom/server/loader.py", line 74, in <module>
    class PythonComponentLoader:
  File "/var/lib/python-support/python2.5/xpcom/server/loader.py", line 75, in PythonComponentLoader
    _com_interfaces_ = components.interfaces.nsIComponentLoader
  File "/var/lib/python-support/python2.5/xpcom/components.py", line 103, in __getattr__
    return self._get_one(attr)
  File "/var/lib/python-support/python2.5/xpcom/components.py", line 153, in _get_one
    raise xpcom.COMException(nsError.NS_ERROR_NO_INTERFACE, "The interface '%s' does not exist" % (name,))
<class 'xpcom.Exception'>: 0x-7fffbffe (-2147467262)
Creating an interface object to be used as a result failed

Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 443, in MakeInterfaceResult
    return Component(ob, iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 229, in __init__
    self.QueryInterface(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 299, in QueryInterface
    self._remember_interface_info(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 272, in _remember_interface_info
    method_infos, getters, setters, constants = BuildInterfaceInfo(iid)
  File "/var/lib/python-support/python2.5/xpcom/client/__init__.py", line 147, in BuildInterfaceInfo
    interface = xpt.Interface(iid)
  File "/var/lib/python-support/python2.5/xpcom/xpt.py", line 83, in __init__
    item = iim.GetInfoForIID(iid)
<type 'exceptions.TypeError'>: Objects of type 'IID' can not be converted to an IID
Traceback (most recent call last):
  File "/usr/bin/sugar-activity", line 147, in <module>
    create_activity_instance(constructor, handle)
  File "/usr/bin/sugar-activity", line 44, in create_activity_instance
    activity = constructor(handle)
  File "/usr/share/activities/Web.activity/webactivity.py", line 94, in __init__
    self._browser = Browser()
  File "/usr/share/activities/Web.activity/browser.py", line 76, in __init__
    WebView.__init__(self)
  File "/usr/lib/python2.5/site-packages/hulahop/webview.py", line 214, in __init__
    self.browser.containerWindow = self._chrome
TypeError: nsISupports has read-only attributes

Luke Faraone (lfaraone) on 2008-10-03
Changed in sugar-web-activity:
importance: Undecided → Medium
status: New → Confirmed
Morgan Collett (morgan) wrote :

The problem is in hulahop, which needs to be rebuilt when a new xulrunner is released with firefox updates.

Changed in sugar-web-activity:
status: Confirmed → Invalid
Changed in sugar-hulahop:
status: New → Confirmed
Changed in hulahop:
status: New → Confirmed
Morgan Collett (morgan) wrote :

The solution is to rebuild sugar-hulahop on intrepid, and hulahop on hardy, with no changes. That will build it against the new xulrunner.

Morgan Collett (morgan) wrote :

The impact of this bug is that the Sugar web browser fails to start.

There is no fix to backport - just a rebuild against the newer xulrunner-1.9 will fix it.

TEST CASE: Install sugar and sugar-activities. Run "sugar-emulator" which runs Sugar in Xephyr. Press F3 to get to the Home View. Click the "List View" icon at the top right of the screen. Click on the Browse icon to launch it. Success means the browser launches with an about:blank page. Press alt-shift-q to exit Sugar.

Please note that the source package is hulahop in hardy, and sugar-hulahop in intrepid and jaunty.

Morgan Collett (morgan) wrote :

This is a regression - the packages were broken by a firefox update, which changed the xulrunner paths.

I have mailed the mozillateam list asking to work together so that we can do sugar-hulahop with future FF/xulrunner updates.

James Westby (james-w) wrote :

Hi,

Declining for Jaunty, there's no need to put it on the release
team's radar, and there is loads of time to fix it.

Thanks,

James

Morgan Collett (morgan) wrote :

motu-sru, can this be approved please?

Morgan Collett (morgan) wrote :

This needs sponsorship now please.

LaserJock (laserjock) on 2008-12-17
Changed in hulahop:
status: New → Invalid
Changed in sugar-hulahop:
status: New → Invalid
Changed in sugar-web-activity:
status: New → Invalid
status: New → Invalid
Changed in hulahop:
status: Confirmed → Invalid
status: New → Confirmed
Changed in sugar-hulahop:
status: New → Confirmed
LaserJock (laserjock) wrote :

I've uploaded hulahop 0.4-1ubuntu3.1 to hardy-proposed and sugar-hulahop 0.4.6-0ubuntu2.1 to intrepid-proposed.

Stefan Ebner (sebner) wrote :

Unsubscribed u-u-s because no work for jaunty needed.

Morgan Collett (morgan) wrote :

There was a firefox update, bumping xulrunner to 1.9.0.5. I don't see the hulahop updates in -proposed yet, hopefully they will build with the newest version.

Changed in hulahop:
status: Unknown → New
Morgan Collett (morgan) wrote :

<marcopg> morgs: not sure it's possible to use the glue yet
<morgs> marcopg: yeah I don't see any reference to pyxpcom
<marcopg> right

Shikhar (shikhar) wrote :

facing same issue, on intrepid

Martin Pitt (pitti) wrote :

Accepted hulahop into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in hulahop:
status: Confirmed → Fix Committed
Changed in sugar-hulahop:
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted sugar-hulahop into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Nubae (dvanassche) wrote :

installed hulahop and python-hulahop from -proposed and now browse launches without issues on intrepid...

ACK

Mattias Ohlsson (mattias-oh) wrote :

I can also confirm that the packade python-hulahop that is in intrepid-proposed works, at least on my 32-bits Intrepid installation. By works I mean that the Browse-activity now launches.

Morgan Collett (morgan) wrote :

hulahop_0.4-1ubuntu3.1_i386.deb from hardy-proposed fixed the problem on hardy.

ACK

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sugar-hulahop - 0.4.6-0ubuntu2.1

---------------
sugar-hulahop (0.4.6-0ubuntu2.1) intrepid-proposed; urgency=low

  * no change upload to rebuild against newer xulrunner
    Closes LP: #263173

 -- Jordan Mantha <email address hidden> Wed, 17 Dec 2008 12:45:42 -0800

Changed in sugar-hulahop:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Can this please be fixed in jaunty ASAP?

Morgan Collett (morgan) wrote :

The jaunty issue is a dependency on python-xpcom 1.9 from debian, whereas we ship that within xulrunner-1.9 and ship python-xpcom 1.8.

debdiff attached for jaunty - please sponsor.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sugar-hulahop - 0.4.8~dfsg-3ubuntu3

---------------
sugar-hulahop (0.4.8~dfsg-3ubuntu3) jaunty; urgency=low

  * debian/rules: Replace dependency on python-xpcom with xulrunner-1.9
    (LP: #263173)

 -- Morgan Collett <email address hidden> Wed, 04 Feb 2009 14:22:13 +0200

Changed in sugar-hulahop:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package hulahop - 0.4-1ubuntu3.1

---------------
hulahop (0.4-1ubuntu3.1) hardy-proposed; urgency=low

  * no change upload to rebuild against newer xulrunner
      Closes LP: #263173

 -- Jordan Mantha <email address hidden> Wed, 17 Dec 2008 12:54:30 -0800

Changed in hulahop:
status: Fix Committed → Fix Released
Changed in hulahop:
status: New → Confirmed
Changed in hulahop:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.