Ubuntu

Please sync sugar-journal-activity 97-1 (universe) from Debian unstable (main).

Reported by Luke Faraone on 2008-10-03
10
Affects Status Importance Assigned to Milestone
sugar-journal-activity (Ubuntu)
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/sugar-journal-activity
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync sugar-journal-activity 97-1 (universe) from Debian unstable (main).

Explanation of the Ubuntu delta and why it can be dropped:

per FFE: Bug #274820

We're discarding the ubuntu packaging and switching to debian's.

Changelog since current intrepid version 86-0ubuntu1:

sugar-journal-activity (97-1) unstable; urgency=low

  * New upstream release.
  * Fix cdbs hints for get-orig-source target.
  * Drop workarounds for no longer used MANIFEST file.
  * Install setup.py again (does no harm, and simplifies our rules).
  * Update cdbs snippets:
    + Move dependency cleanup to new local snippet package-relations.mk.
    + Update copyright-check output to more closely match proposed new
      copyright file format. Update copyright-hints.
    + Update README.cdbs-tweaks.
  * Add DEB_MAINTAINER_MODE in debian/rules (thanks to Romain Beauxis).

 -- Jonas Smedegaard <email address hidden> Sat, 16 Aug 2008 21:29:03 +0200

sugar-journal-activity (92-1) unstable; urgency=low

  * New upstream release.
  * Unfuzz patches.
  * Update local cdbs snippets:
    + Relax copyright-check to only warn about its discoveries. Closes:
      bug#486984.
    + Fix python-sugar.mk to work with recent python-sugar-toolkit where
      MANIFEST files are ignored and an internal hardcoded exception
      list is used instead. Tighten build-dependency.
  * Update debian/copyright-hints.
  * Semi-auto-update debian/control to update build-dependencies:
      DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean

 -- Jonas Smedegaard <email address hidden> Sat, 21 Jun 2008 01:43:32 +0200

sugar-journal-activity (91-1) unstable; urgency=low

  * New upstream release.
  * Adjust debian/rules and debian watch to use new upstream tarball
    name.
  * Adjust cdbs dependency cleanup in debian/rules to reflect a recent
    change to use non-debian-versioned dependency.
  * Reorganize debian/copyright to only mention each license once.

 -- Jonas Smedegaard <email address hidden> Mon, 09 Jun 2008 13:06:56 +0200

sugar-journal-activity (89-1) unstable; urgency=low

  * New upstream release.
  * Add URL to upstream tarball source in debian/copyright.
  * Fix upstream URL in watch file.
  * Update local cdbs snippets:
    + Use upstream-tarball.mk to track upstream source releases.
  * Semi-auto-update debian/control to update build-dependencies:
      DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean

 -- Jonas Smedegaard <email address hidden> Mon, 26 May 2008 14:22:28 +0200

sugar-journal-activity (87~git-2) unstable; urgency=low

  * Update cdbs tweaks:
    + Clean *.xo and locale in python-sugar.mk (based on initial work by
      Santiago Ruano Rincón).
    + Fix preserve upstream MANIFEST files only once in python-sugar.mk.
    + Support multiple activity packages from one source in
      python-sugar.mk.
    + Tighten python-sugar.mk build-dependency on python-sugar-toolkit
      to versions properly installing zip-based bundles (*.xo files).
  * Semi-auto-update debian/control to update build-dependencies:
      DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean

 -- Jonas Smedegaard <email address hidden> Sat, 26 Apr 2008 01:47:17 +0200

sugar-journal-activity (87~git-1) unstable; urgency=low

  * New upstream (Git-based) release.
    Highlights (since Git snapshot d0715c4):
    + Some translations added
    + Various updates to visual design
    + Improve formatting of relative dates
    + Add support for inline renaming of Journal entries
    + Add palettes to people and objects in Journal
    + Fix behavior of deletion from detail view.
  * Update cdbs tweaks:
    + Update copyright-check cdbs snippet to store newline-delimited
      hints and strip any non-printable characters. Update
      copyright-hints.
    + Drop unused update-tarball.mk.
  * Add new file palettes.py (GPLv2+) to debian/copyrights.
  * Bump debhelper compatibility level to version 6 (was 5).
  * Mention exact upstream Git source in debian/copyright.
  * Semi-auto-update debian/control to update build-dependencies:
      DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean

 -- Jonas Smedegaard <email address hidden> Fri, 25 Apr 2008 01:02:43 +0200

sugar-journal-activity (79~git.d0715c4-2) unstable; urgency=low

  * Add patch 1002 adding danish l10n.
  * Avoid installing setup.py.
  * Update local cdbs snippets:
    + Use full path in python-sugar.mk, and tighten python-sugar-toolkit
      build-dependency to at least 0.79.2 changing this.
    + Fix simultanously setting DEB_PYTHON_SUGAR_MANIFEST and
      DEB_PYTHON_SUGAR_MANIFEST_REGEX in python-sugar.mk.
    + Relax python-central and python-support build-dependencies in
      python-sugar.mk.
  * Semi-auto-update debian/control to update build-dependencies:
      DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean

 -- Jonas Smedegaard <email address hidden> Thu, 17 Apr 2008 21:09:05 +0200

sugar-journal-activity (79~git.d0715c4-1) unstable; urgency=low

  * Initial release. Closes: bug#444021.

 -- Jonas Smedegaard <email address hidden> Sat, 22 Mar 2008 19:40:52 +0100

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFI5nnttrC51grHAgYRAhmRAJsEfQfu/QbFLNvxB4R50IPALbmoWACgr+qd
xUKflloEp/b3zqUau2aEFcw=
=Qhnb
-----END PGP SIGNATURE-----

James Westby (james-w) wrote :

Hi,

A few minor problems with this one:

  * debhelper version
  * Arch: all only package with everything Build-Depends (very minor)
  * python-dev not python-all
  * This one does actually have a problem with ${shlibs:Depends}, ${python:Depends}

Apart from that it looks ok.

Thanks,

James

James Westby (james-w) wrote :

ACK from me, thank you.

James

Changed in sugar-journal-activity:
status: New → Confirmed
Jonathan Riddell (jr) wrote :

[Updating] sugar-journal-activity (86-0ubuntu1 [Ubuntu] < 97-1 [Debian])
 * Trying to add sugar-journal-activity...
  - <sugar-journal-activity_97-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <sugar-journal-activity_97-1.diff.gz: downloading from http://ftp.debian.org/debian/>
  - <sugar-journal-activity_97.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: sugar-journal-activity [universe] -> sugar-journal-activity_86-0ubuntu1 [universe].

Changed in sugar-journal-activity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers