Ubuntu

Typo in package description

Reported by Reuben Thomas on 2012-03-14
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sugar-0.90 (Debian)
Fix Released
Unknown
sugar-0.90 (Ubuntu)
Undecided
Unassigned

Bug Description

"low-ressource" should be "low-resource"

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: sugar-session-0.90 (not installed)
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 14 20:42:20 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: sugar-0.90
UpgradeStatus: Upgraded to precise on 2012-03-06 (8 days ago)

Reuben Thomas (rrt) wrote :
kroq-gar78 (kroq-gar78) on 2012-03-24
tags: added: bitesize string-fix
kroq-gar78 (kroq-gar78) wrote :

OK. I did a "Find and Replace All" from Geany to fix the typo. I'll attach the patch and link my branch.

kroq-gar78 (kroq-gar78) on 2012-03-24
Changed in sugar-0.90 (Ubuntu):
assignee: nobody → kroq-gar78 (kroq-gar78)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sugar-0.90 (Ubuntu):
status: New → Confirmed

The attachment "Fix typo "low-ressource" to "low-resource" in debian/control" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Colin Watson (cjwatson) wrote :

Thanks for your patch. I agree that it looks correct. I don't think it's worth diverging from Debian for cosmetic issues like this, though, so, instead, I've forwarded your patch to Debian (I'll link the Debian bug to this one once I have its number), and we can close this bug with a sync from Debian later.

Changed in sugar-0.90 (Debian):
status: Unknown → New
kroq-gar78 (kroq-gar78) on 2012-04-12
tags: added: patch-forwarded-debian
removed: patch
Changed in sugar-0.90 (Ubuntu):
assignee: kroq-gar78 (kroq-gar78) → nobody
Changed in sugar-0.90 (Debian):
status: New → Fix Released
Logan Rosen (logan) wrote :

This package has been removed from Debian per http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665820, so this patch should either be applied to the Ubuntu package, or the package should be removed from the Ubuntu repository as well. Thoughts?

Alessandro Losavio (alo21) wrote :

I attached the patch to fix this bug. I hope it is OK

Changed in sugar-0.90 (Ubuntu):
assignee: nobody → Alessandro Losavio (alo21)
status: Confirmed → In Progress
Alessandro Losavio (alo21) wrote :

This patch is for Ubuntu, to correct the issue

tags: added: patch
kroq-gar78 (kroq-gar78) wrote :

It looks good, but I already submitted a patch and Colin Watson said it would be better just to send to Debian (which I already did; see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=665820). Good work, but it was already done. Don't get discouraged from fixing other bugs, though!

tags: removed: patch
Changed in sugar-0.90 (Ubuntu):
status: In Progress → Confirmed
assignee: Alessandro Losavio (alo21) → nobody
Logan Rosen (logan) wrote :

Er, see comment #6. The status of the Debian bug on Launchpad is a bit misleading - the bug was not fixed, as sugar-0.90 was removed from the Debian repository. Thus, as I said in comment #6, the bug should either be fixed in Ubuntu, or the package should be removed from Ubuntu as well.

Alessandro Losavio (alo21) wrote :

I checked in Ubuntu repository, and the bug is not fixed yet. This is why I uploaded the patch for Ubuntu here.

kroq-gar78: It was a pleasure, and I am not discourage

kroq-gar78 (kroq-gar78) wrote :

Oh... eh, sorry about that... I completely forgot about your comment, Logan! I agree, it should be fixed or removed from Ubuntu as well.

Again, sorry Alessandro. If you want, assign it back to yourself.

Alessandro Losavio (alo21) wrote :

What should I do with this patch? Should I send it upstream?

kroq-gar78 (kroq-gar78) wrote :

No; it's not an upstream problem. Leave the patch here, I'd say, and assign the bug to you again. I'll retag this bug with "patch".

tags: added: patch
removed: patch-forwarded-debian
Changed in sugar-0.90 (Ubuntu):
assignee: nobody → Alessandro Losavio (alo21)
status: Confirmed → In Progress
Changed in sugar-0.90 (Ubuntu):
assignee: Alessandro Losavio (alo21) → nobody
status: In Progress → Confirmed
Reuben Thomas (rrt) wrote :

Closing, since the package is no longer in new Ubuntu. The typo is still present in newer versions; I've reported it against sugar-base-0.98 in Debian.

Changed in sugar-0.90 (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.