sudo env_reset and env_keep

Bug #31690 reported by atie on 2006-02-16
6
Affects Status Importance Assigned to Milestone
sudo (Ubuntu)
High
Martin Pitt

Bug Description

sudo 1.6.8p12-1ubunutu3

sudo in dapper doesn't use env_reset and env_keep options. With curren sudo, I have bug 30432 and 30077.

I put the following options with visudo,
Defaults env_reset
Defaults env_keep = "COLORS DISPLAY HOSTNAME HISTSIZE INPUTRC KDEDIR \
                       LS_COLORS MAIL PS1 PS2 QTDIR USERNAME \
                       LANG LC_ADDRESS LC_CTYPE LC_COLLATE LC_IDENTIFICATION \
                       LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC \
                       LC_PAPER LC_TELEPHONE LC_TIME LC_ALL LANGUAGE LINGUAS \
                       _XKB_CHARSET"

these options are from
https://www.redhat.com/archives/fedora-devel-list/2006-February/msg00389.html

After applying the options,
sudo kate is working
kdesu kate is working
sudo synaptic is working
gksudo synaptic isn't working
( Xlib: connection88H7 to ":0.0" refused by server
Xlib: No protocol specified )

I think somehow KDEDIR option may fix my "sudo kate" problem in half way, but don't know how to fix "gksudo synaptic".

Please take a look these options.

atie (atie-at-matrix) wrote :

In addition, said "half way" above, because sudo kate is working with the above options, but skim is not (There is no more two skim icons on system tray, but couldn't input other languages than English. I think skim/scim is simply deactivated by the options). I added XMODIFIRERS, GTK_IM_MODULE and QT_IM_MODULE to env_keep, but it's hang same as before.

/subscribe ubuntu-cjk-testers

Martin Pitt (pitti) on 2006-02-17
Changed in sudo:
assignee: nobody → pitti
atie (atie-at-matrix) wrote :

Just for the record, I added GTK2_RC_FILES and GTK_RC_FILES as env_keep to make same look for GNOME applications for user and sudo from my KDE desktop.

Martin Pitt (pitti) on 2006-03-28
Changed in sudo:
status: Unconfirmed → Confirmed
Martin Pitt (pitti) on 2006-03-28
Changed in sudo:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

 sudo (1.6.8p12-1ubuntu5) dapper; urgency=low
 .
   * env.c: Unbreak the env_keep option. Closes: LP#31690
   * sudoers: Add some explanatory text why it is a REALLY good idea to use
     visudo. Closes: LP#11620

Changed in sudo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers