[hardy] update-manager freezes after clicking on install updates

Bug #231565 reported by Andrew King on 2008-05-18
8
Affects Status Importance Assigned to Milestone
sudo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

After clicking on "install updates" in update-manager window freezes and hangs when launched from the tray icon.
The rest of the system is still usable.
Force-quit needs to be used to close the update-manager window.

Running update manager from the system->administration menu works without a problem, and can be used as a workaround.

This is possibly a duplicate of bug #218299. Not sure though, so submitted a separate report.

Sfjfudnfj (safjlw) wrote :

I confirm this bug. I have had this problem since upgrading from 7.10. As a workaround I have been using "sudo apt-get update" and "sudo apt-get upgrade" as a workaround to install patches.

Daniel Hollocher (chogydan) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as attachments? Thanks in advance.

Changed in update-manager:
status: New → Incomplete
Sfjfudnfj (safjlw) wrote :
Sfjfudnfj (safjlw) wrote :
Sfjfudnfj (safjlw) wrote :
Sfjfudnfj (safjlw) wrote :
Sfjfudnfj (safjlw) wrote :
Sfjfudnfj (safjlw) wrote :

I also observe after choosing "Install all updates" from the tray icon that a minimized window for the gksu password prompt appears on the taskbar, but the actual window does not appear. After some time, the indicator on the taskbar disappears.

Changed in update-manager:
status: Incomplete → New
jon partsch (jpartsch1979) wrote :

I have had the exact same problem, altought it does not always occur. Sometimes install updates completes without a hitch.

sudo apt-get update is the best workaround I have found.

I am on a 933 MHz PIIIM
265 MB RAM
i830MG chip set

Andrew King (anders-king-00) wrote :

Further to my initial report, i think gksu/sudo was hanging on a failed hostname lookup.

May 27 16:44:41 anders-vostro sudo: anders : unable to resolve host anders-vostro
(from /var/log/auth.log)

anders-vostro was not in my hosts file (however anders-vostro.anders was). adding anders-vostro (no domainname) to my /etc/hosts file seems to have fixed the issue.

Michael Vogt (mvo) wrote :

Thanks for your additional information.

I reassign to sudo. It should not hang if it cannot resolve the hostname.

wvhillbilly (pete-rose) wrote :
Download full text (3.6 KiB)

This has been happening ever since I upgraded to Hardy Heron (8.04). Until the latest update I was able to get it to work by doing a force quit and restarting it. Now it will not work at all, not even from the System -> Administration menu.

I tried the sudo apt-get updates command in terminal and it downloaded quite a number of items, but I got no indication of anything being installed. Is there another sudo command required to install the updates?

Below is a copy of the Terminal window after completion of the get updates command.
--------------------------------------------------------------
pete@pete-desktop:~$ sudo apt-get update
sudo: unable to resolve host pete-desktop
[sudo] password for pete:
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/main Translation-en_US
Ign cdrom://Ubuntu 8.04 _Hardy Heron_ - Release i386 (20080423) hardy/restricted Translation-en_US
Hit http://archive.canonical.com hardy Release.gpg
Ign http://archive.canonical.com hardy/partner Translation-en_US
Hit http://security.ubuntu.com hardy-security Release.gpg
Ign http://security.ubuntu.com hardy-security/main Translation-en_US
Hit http://us.archive.ubuntu.com hardy Release.gpg
Ign http://us.archive.ubuntu.com hardy/main Translation-en_US
Hit http://archive.canonical.com hardy Release
Ign http://security.ubuntu.com hardy-security/restricted Translation-en_US
Ign http://security.ubuntu.com hardy-security/multiverse Translation-en_US
Ign http://security.ubuntu.com hardy-security/universe Translation-en_US
Ign http://us.archive.ubuntu.com hardy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com hardy/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com hardy/universe Translation-en_US
Get:1 http://us.archive.ubuntu.com hardy-updates Release.gpg [191B]
Ign http://us.archive.ubuntu.com hardy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com hardy-updates/restricted Translation-en_US
Hit http://archive.canonical.com hardy/partner Packages
Hit http://security.ubuntu.com hardy-security Release
Ign http://us.archive.ubuntu.com hardy-updates/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com hardy-updates/universe Translation-en_US
Hit http://us.archive.ubuntu.com hardy Release
Get:2 http://us.archive.ubuntu.com hardy-updates Release [58.5kB]
Hit http://security.ubuntu.com hardy-security/main Packages
Hit http://security.ubuntu.com hardy-security/restricted Packages
Hit http://security.ubuntu.com hardy-security/main Sources
Hit http://security.ubuntu.com hardy-security/restricted Sources
Hit http://security.ubuntu.com hardy-security/multiverse Packages
Hit http://security.ubuntu.com hardy-security/universe Packages
Hit http://us.archive.ubuntu.com hardy/main Packages
Hit http://us.archive.ubuntu.com hardy/restricted Packages
Hit http://us.archive.ubuntu.com hardy/main Sources
Hit http://us.archive.ubuntu.com hardy/restricted Sources
Hit http://us.archive.ubuntu.com hardy/multiverse Packages
Hit http://us.archive.ubuntu.com hardy/universe Packages
Get:3 http://us.archive.u...

Read more...

wvhillbilly (pete-rose) wrote :

Came across a workable workaround elsewhere in Launchpad-run Update Manager from Terminal. sudo update-manager.

Update manager from both tray icon and Administrative menu dead in the water, locks up every time I try to install updates, been that way since last kernel update.

greenphreak (greenphreak) wrote :

wvhillbilly: you need to run update *and* upgrade to actually install the new software updates. update merely updates your system to what is available in the repositories, whereas upgrade actually downloads the appropriate files and upgrades your system.

$ sudo apt-get update

$ sudo apt-get upgrade

hey, thanks. I saw sudo apt-get upgrade mentioned, but I didn't know
the two of them went together. I thought get upgrade was to upgrade the
system to a new version. I've been using Linux for a number of years,
but have never had to use Terminal and shell commands until now. Do you
know of a web address where I could find a good tutorial on shell commands?

I've found I can also run sudo upgrade-manager from Terminal and that
works. Have you guys made any progress on finding the bug that's
killing update manager from the tray icon and the administrative menu?

Thanks again.

Pete <wvhillbilly>

greenphreak wrote:
> wvhillbilly: you need to run update *and* upgrade to actually install
> the new software updates. update merely updates your system to what is
> available in the repositories, whereas upgrade actually downloads the
> appropriate files and upgrades your system.
>
> $ sudo apt-get update
>
> $ sudo apt-get upgrade
>
>

Octavi (ofullana) wrote :

I had the same problem after upgrading from gutsy to hardy. I noticed that when runing any sudo command from the terminal I got a "sudo: unable to resolve host <hostname>". I edited /etc/hosts and modyfied the second line that was

127.0.1.1 <hostname>.<workgroup_name>

to

127.0.1.1 <hostname>

Now everything seems to work fine. Can you verify if it's the same problem?

Oct

Andrew King (anders-king-00) wrote :

Hi,

I was the original bug reporter. modifying /etc/hosts fixed it for me. (see comment #10 above).

Cheers,
Andrew

Robert Zelnik (rzelnik) wrote :

I have
127.0.1.1 <hostname>
in my /etc/hosts (I did not change it), anyway the problem still occurs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers