After upgrading svnadmin gives "Expected repository format '3' or '5'; found format '4'". My SVN repository is broken

Bug #658501 reported by David Pottage on 2010-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
subversion (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: subversion

Before upgrading to maverick my SVN repository worked fine. It was served to users over the apache2 dav-svn module.

Since I have upgraded the repository does not work. My Apache2 error log contains:

[Mon Oct 11 16:52:14 2010] [error] [client 87.194.166.225] (20014)Internal error: Berkeley DB error for filesystem '/var/lib/svn/repository/db' while opening environment:\n
[Mon Oct 11 16:52:14 2010] [error] [client 87.194.166.225] Could not fetch resource information. [500, #0]
[Mon Oct 11 16:52:14 2010] [error] [client 87.194.166.225] Could not open the requested SVN filesystem [500, #160029]
[Mon Oct 11 16:52:14 2010] [error] [client 87.194.166.225] Could not open the requested SVN filesystem [500, #160029]

I tried running svnadmin recover:

# svnadmin verify /var/lib/svn/repository/db
svnadmin: Expected repository format '3' or '5'; found format '4'

It looks like the berkley DB version has been upgraded, without a way to upgrade existing databases.

Mine is a small repository, and I have a set of checkin dumps for everything in the repository, so I could just create a new repository, and load the checkin dumps to recreate my SVN database, but that is hardly a nice solution.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: subversion 1.6.12dfsg-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Mon Oct 11 17:13:56 2010
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
SourcePackage: subversion

I don't know what causes your problem, but a little comment: The svnadmin command should point to the main repository dir and not to the db subdirectory, i.e.
  svnadmin verify /var/lib/svn/repository
should work -- the error message about the repository format is quite misleading :-/

Thanks for the tip, but it did not fix the problem:

$ svnadmin verify /var/lib/svn/repository
svnadmin: Berkeley DB error for filesystem '/var/lib/svn/repository/db' while opening environment:

svnadmin: DB_VERSION_MISMATCH: Database environment version mismatch
svnadmin: bdb: Build signature doesn't match environment

Looks like all it has done is rephrased the error message.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers