psvn.el: cannot commit changes over Tramp; temp file is local

Bug #651850 reported by era on 2010-09-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
subversion (Debian)
New
Unknown
subversion (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: emacs23

When editing files in a remote SVN work directory, you cannot perform a commit from within Emacs, because one of the temporary files used in the commit is apparently created locally, not on the remote host where the SVN commit command is run.

Steps to repro:
 1. Edit a file in a remote SVN work directory, e.g. C-x C-f /me@remote:/tmp/testcheckout/file.txt
 2. Make some local changes
 3. Run M-x svn-status
 4. Mark file.txt to be committed with *; press c to actually commit. Write a short log message in the *svn-log-edit* buffer
 5. Attempt to commit with C-c C-c

Actual results:
The following message is displayed in the minibuffer:
svn failed:
Can't open file '/tmp/svn.arg.2331QTe': No such file or directory
^M

Expected results:
Committed revision 12345

For debugging, (setq debug-on-error t) doesn't help in this situation, because the SVN error is not an Emacs error; Emacs simply displays the error message from the back end.

The function which removes temporary files used by psvn.el is called svn-status-remove-temp-file-maybe; I guess it might be useful to instrument, replace, or advice this function to see what is being removed when.

 lucid$ apt-cache policy emacs23
 emacs23:
   Installed: 23.1+1-4ubuntu7
   Candidate: 23.1+1-4ubuntu7
   Version table:
  *** 23.1+1-4ubuntu7 0
  500 http://mirrors.nic.funet.fi/ubuntu/ lucid/main Packages
  100 /var/lib/dpkg/status

 lucid$ lsb_release -rd
 Description: Ubuntu 10.04.1 LTS
 Release: 10.04

era (era) wrote :

Sorry, forgot to include Emacs version! Silly me ...

description: updated
era (era) wrote :

The newest upstream[1] upstream[2] upstream[3] version at http://www.xsteve.at/prg/emacs/psvn.el appears to have fixes related to this in the function svn-log-edit-done

I can't seem to access the upstream[3] repo at http://svn.collab.net/repos/svn/trunk/contrib/client-side/emacs -- I get a 403 error.

$Id: psvn.el 40299 2009-10-29 19:38:54Z xsteve $

[1] Debian is Ubuntu's upstream for emacs23
[2] GNU Emacs is Debian's upstream for emacs23
[3] xsteve.at is GNU Emacs' upstream

era (era) wrote :

Oops, psvn.el is provided by subversion, not emacs. Reassigning.

 lucid$ apt-cache policy subversion
 subversion:
   Installed: 1.6.6dfsg-2ubuntu1
   Candidate: 1.6.6dfsg-2ubuntu1
   Version table:
  *** 1.6.6dfsg-2ubuntu1 0
         500 http://mirrors.nic.funet.fi/ubuntu/ lucid/main Packages
         100 /var/lib/dpkg/status

affects: emacs23 (Ubuntu) → subversion (Ubuntu)
era (era) wrote :

The latest debian subversion package seems to lack this fix. They mangle the $Id$ tag so it's not clear which upstream version they are shipping.

era (era) wrote :

Forwarded to Debian.

Changed in subversion (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subversion (Ubuntu):
status: New → Confirmed
era (era) wrote :

The version in Trusty does not contain psvn.el at all so I suppose this can be closed.

Changed in subversion (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
era (era) wrote :

Take that back, the file is now in subversion-tools, same source package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.