svn is failing to process response from client, though network is available

Bug #544125 reported by Arun S L on 2010-03-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neon
New
Undecided
Unassigned
subversion (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: subversion

arun@arun-desktop:~/test/trunk$ svn up
svn: OPTIONS of 'http://svn......com/public/ps/trunk': timed out waiting for server (http://svn........com)

Debugging this issue I have found that no matter whatever svn repository I am loging on, there is no response for the OPTIONS method send and after the timeout period, the client terminates with the above error.

The site is reachable from the network and I can open the source in firefox as well.

I am using http_proxy and https_proxy as well, still did not help.

ProblemType: Bug
Architecture: i386
Date: Sat Mar 20 18:04:58 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: libsvn1 1.6.6dfsg-2ubuntu1
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: subversion
Uname: Linux 2.6.32-16-generic i686

Arun S L (arun-sl) wrote :
Arun S L (arun-sl) wrote :

The failing case is:

socket(PF_INET, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, IPPROTO_TCP) = 4
setsockopt(4, SOL_TCP, TCP_NODELAY, [1], 4) = 0
fcntl64(4, F_GETFL) = 0x802 (flags O_RDWR|O_NONBLOCK)
connect(4, {sa_family=AF_INET, sin_port=htons(...), sin_addr=inet_addr(".........")}, 16) = -1 EINPROGRESS (Operation now in progress)
poll([{fd=4, events=POLLOUT}], 1, 100000) = 1 ([{fd=4, revents=POLLOUT}])
getsockopt(4, SOL_SOCKET, SO_ERROR, [0], [4]) = 0
fcntl64(4, F_SETFL, O_RDWR) = 0
send(4, "OPTIONS http://svn.......com/public/ps/trunk HTTP/1.1\r\nUser-Agent: SVN/1.6.6 (r40053) neon/0"..., 435, 0) = 435
send(4, "<?xml version=\"1.0\" encoding=\"utf-8\"?><D:options xmlns:D=\"DAV:\"><D:activity-collection-set/></D:opti"..., 104, 0) = 104
poll([{fd=4, events=POLLIN}], 1, 100000) = 0 (Timeout)
close(4) = 0

I have tried taking similar trace for working tools (this one using wget)

socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 3
connect(3, {sa_family=AF_INET, sin_port=htons(....), sin_addr=inet_addr("......")}, 16) = 0
select(4, NULL, [3], NULL, {900, 0}) = 1 (out [3], left {899, 999994})
write(3, "GET http://www.google.com/ HTTP/1.0\r\nUser-Agent: Wget/1.12 (linux-gnu)\r\nAccept: */*\r\nHost: www.google.com\r\n\r\n", 109) = 109
select(4, [3], NULL, NULL, {900, 0}) = 1 (in [3], left {899, 588868})
recv(3, "....
.....

this is working fine

can I know if there are any options I can select with svn / configure it with to make it work for me any workarounds?

Maarten Bezemer (veger) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect 544125 and any other logs that are relevant for this particular issue.

Changed in subversion (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers