package libapache2-svn 1.6.17dfsg-3ubuntu3.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1363663 reported by GorVas on 2014-08-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
subversion (Ubuntu)
Undecided
Unassigned

Bug Description

Cant install libapache2-svn it says that:

Setting up libapache2-svn (1.6.17dfsg-3ubuntu3.4) ...
ERROR: Module authz_svn does not exist!
dpkg: error processing libapache2-svn (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 libapache2-svn
E: Sub-process /usr/bin/dpkg returned an error code (1)

Try to fix it by installing authz_svn but it dosent work.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: libapache2-svn 1.6.17dfsg-3ubuntu3.4
ProcVersionSignature: Ubuntu 3.13.0-35.62~precise1-generic 3.13.11.6
Uname: Linux 3.13.0-35-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.7
AptOrdering: libapache2-svn: Configure
Architecture: amd64
Date: Sun Aug 31 16:19:15 2014
DpkgTerminalLog:
 Setting up libapache2-svn (1.6.17dfsg-3ubuntu3.4) ...
 ERROR: Module authz_svn does not exist!
 dpkg: error processing libapache2-svn (--configure):
  subprocess installed post-installation script returned error exit status 1
DuplicateSignature: package:libapache2-svn:1.6.17dfsg-3ubuntu3.4:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release amd64 (20130820.1)
MarkForUpload: True
SourcePackage: subversion
Title: package libapache2-svn 1.6.17dfsg-3ubuntu3.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
modified.conffile..etc.apache2.mods.available.authz.svn.load: [deleted]
modified.conffile..etc.apache2.mods.available.dav.svn.load:
 # Depends: dav
 LoadModule dav_svn_module /usr/lib/apache2/modules/mod_dav_svn.so
 LoadModule authz_svn_module /usr/lib/apache2/modules/mod_authz_svn.so
mtime.conffile..etc.apache2.mods.available.dav.svn.conf: 2014-06-03T23:51:04.439500
mtime.conffile..etc.apache2.mods.available.dav.svn.load: 2014-06-03T23:51:04.439500

GorVas (gvpajkar) wrote :
tags: removed: need-duplicate-check
GorVas (gvpajkar) wrote :

I solved it by making my own authz_svn.load file. Then i could re-install the package.

Added the following lines in to authz_svn.load:

# Depends: dav_svn
LoadModule authz_svn_module /usr/lib/apache2/modules/mod_authz_svn.so
LoadModule authz_svn_module /usr/lib/apache2/modules/mod_dav_svn.so

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subversion (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers