Ubuntu

meld and svn can not work with subclipse

Reported by Jerikojerk on 2007-06-12
6
Affects Status Importance Assigned to Milestone
subversion (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: subversion

i work on a directory under control version, i use eclipse and subclise to edit some file in a subdirectory (called 'gestion' ).
Now, meld and svn command tool refuse to make one svn up.
it says that svn client is too old and i have to upgrade. i'm currently using packaged version of meld and svn.

to fix the problem, i add to remove my working copy of the subdirectory.

it is a compatibility issue on different subversion products.

eclipse: 3.2, subclipse: 1.2.0
svn : version 1.3.2.
meld: 1.1.4

error message was (french):
svn: Ce client est trop vieux pour travailler sur la copie de travail 'gestion' ; récupérer une version plus réçente du client

Dan Forward (danforward) wrote :

Subversion 1.4.x uses a different (non-XML) format for the .svn/entries file. It automatically updates your working copy if it finds the older-style XML format. It is important to upgrade all Subversion clients at the same time to ensure they all can read the new format. Your Subversion client is too old (version 1.3.2) to read the working copy updated by Subclipse 1.2.0. The latest version of Subversion available for Ubuntu Feisty is 1.4.3.

Venkatraman.S (blizzardz) wrote :

As mentioned in the previous comment(by Dan), this requires a new client to be used. Hence am Inavalidating this bug.
However, kindly do not hestitate to reopen this bug, if the problem persists with the newer versions.

Thanks for reporting this and making Ubuntu better.

Changed in subversion:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers