subversion crashes when finds a conflict while updating

Bug #1065312 reported by jose on 2012-10-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
subversion
Fix Released
Low
subversion (Debian)
Fix Released
Unknown
subversion (Ubuntu)
High
Unassigned

Bug Description

After modifying some files (Makefile and Config.in) and upgrading (something changed in the latest subversion since ubuntu precise) and updating the repo below, I get a crash and a "core dumped" message.
I already reported the crash in irc.freenode.net / #svn channel, but I did not try the latest subversion package from the svn devs.

$ LANG=en_US.utf8 LANGUAGE=en_US svn up
Updating '.':
svn: E235000: In file '/build/buildd/subversion-1.7.5/subversion/libsvn_wc/update_editor.c' line 1583: assertion failed (action == svn_wc_conflict_action_edit || action == svn_wc_conflict_action_delete || action == svn_wc_conflict_action_replace)
Abortado (`core' generado)

Repo info:
$ LANG=en_US.utf8 LANGUAGE=en_US svn info
Path: .
Working Copy Root Path: /home/user/openwrt
URL: svn://svn.openwrt.org/openwrt/trunk
Repository Root: svn://svn.openwrt.org/openwrt
Repository UUID: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revision: 33716
Node Kind: directory
Schedule: normal
Last Changed Author: nbd
Last Changed Rev: 31835
Last Changed Date: 2012-05-20 17:58:03 -0400 (Sun, 20 May 2012)

$ lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10
$ LANG=en_US.utf8 LANGUAGE=en_US apt-cache policy subversion
subversion:
  Installed: 1.7.5-1ubuntu2
  Candidate: 1.7.5-1ubuntu2
  Version table:
 *** 1.7.5-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
        100 /var/lib/dpkg/status
$ file /usr/bin/svn
/usr/bin/svn: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=0x38513bd2bf514af7ff1a31685f631dff026a8576, stripped

I hope this helps.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: subversion 1.7.5-1ubuntu2
Uname: Linux 3.6.1-030601-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Wed Oct 10 19:55:53 2012
EcryptfsInUse: Yes
ProcEnviron:
 LANGUAGE=es_CL
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_CL.UTF-8
 SHELL=/bin/bash
SourcePackage: subversion
UpgradeStatus: Upgraded to quantal on 2012-10-10 (0 days ago)

jose (o1485726) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subversion (Ubuntu):
status: New → Confirmed
jose (o1485726) on 2012-10-24
information type: Public → Public Security
information type: Public Security → Public
jose (o1485726) wrote :

Updated to the ppa version from https://launchpad.net/~svn/+archive/ppa , still crashing.
Should I report it somewhere else?

Changed in subversion:
status: Unknown → Confirmed
Logan Rosen (logan) on 2013-04-07
Changed in subversion:
status: Confirmed → Unknown
Logan Rosen (logan) on 2013-04-07
Changed in subversion (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in subversion (Debian):
status: Unknown → Confirmed
Changed in subversion:
importance: Unknown → Low
status: Unknown → Fix Released
Changed in subversion (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.