Should build-depend on python-all-dbg, not python-dbg

Bug #1018633 reported by Max Bowsher
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
subversion (Ubuntu)
Won't Fix
Undecided
Unassigned

Bug Description

subversion 1.7.5-1ubuntu1 build-depends on python-all-dev, but python-dbg. This is incorrect, it should build-dep on python-all-dbg instead of python-dbg.

This causes a FTBFS if the package is rebuilt in a series with more than 1 supported python version.

Revision history for this message
Paolo Rotolo (paolorotolo) wrote :

Hi,
Thanks for the bug report.
I've attached the patch to solve this issue.

Regards.

Changed in subversion (Ubuntu):
assignee: nobody → Paolo Rotolo (paolorotolo)
assignee: Paolo Rotolo (paolorotolo) → nobody
status: New → Confirmed
tags: added: packaging patch
Revision history for this message
Martin Pitt (pitti) wrote :

In my opinion this is not worth introducing a delta for in Ubuntu. There will not _ever_ be a second Python 2.x version that Ubuntu supports (there won't be a Python 2.8). You can forward this bug report to Debian, it seems to be relevant there because they still support 2.6. Thanks!

Changed in subversion (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers