write through proxy doesn't work with a filename that has a space

Bug #1003168 reported by Joseph Isenberg on 2012-05-22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
subversion (Ubuntu)

Bug Description

I was trying to se up a write through proxy svn mirror using the instructions in the svn book. It worked OK until I tried to commit a file in a directory with a space in the name. The space gets converted to %20 which is fine, but then the % gets converted to %25 so the space becomes %2520 which is wrong. I found more info here:

Release Info:
Description: Ubuntu 12.04 LTS
Release: 12.04

package info:
  Installed: 1.6.17dfsg-3ubuntu3
  Candidate: 1.6.17dfsg-3ubuntu3
  Version table:
 *** 1.6.17dfsg-3ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Joseph Isenberg (jisenberg-a) wrote :

After some more research, I've found this was fixed in the upstream subversion trunk in revision 1088602. This is present in all 1.7 versions but wasn't backported to 1.6 even as of 1.6.18

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in subversion (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers