I cannot login to connect to the server (OpenSubtitles, I guess)

Bug #452036 reported by lespedretes on 2009-10-15
82
This bug affects 18 people
Affects Status Importance Assigned to Milestone
SubDownloader
Undecided
Marco Rodrigues
subdownloader (Ubuntu)
High
Marco Rodrigues

Bug Description

Binary package hint: subdownloader

-Ubuntu 9.04 Jaunty
-Subdownloader 2.0.9.3-1 0
-I expect to obtain a subtitles file.
-Instead I obtain something like "You must login to connect to server". When I try to login I can't in any way.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: subdownloader 2.0.9.3-1
PackageArchitecture: all
ProcEnviron:
 LANG=ca_AD.UTF-8
 SHELL=/bin/bash
SourcePackage: subdownloader
Uname: Linux 2.6.28-15-generic i686

Related branches

lespedretes (lespedretes-b) wrote :
Marco Rodrigues (gothicx) wrote :

This looks like a problem of opensubtitles.org network failure. Please reopen the bug if it still happens.

Thank you

Changed in subdownloader:
assignee: nobody → Marco Rodrigues (gothicx)
Changed in subdownloader (Ubuntu):
status: New → Fix Released
assignee: nobody → Marco Rodrigues (gothicx)
Changed in subdownloader:
status: New → Fix Released
stimpak (vespenegeyser) wrote :

its not a problem. opensubtitles.org published that they gonna change the host for their API a couple months ago.

check this blog post for more information http://blog.opensubtitles.org/opensubtitlesorg/host-for-api-definitely-changed

Ubuntu 9.04 Users still have this problem with the version available in 9.04's repositories. Why is no update released?

The 2.0.9 version from Ubuntu 9.04 is still affected by this. Why is no update released for 9.04 despite it's still in it's support cycle?

Changed in subdownloader (Ubuntu):
status: Fix Released → Incomplete

I updated last week, and subdownloader works fine. Thanks.

2010/3/18 freak42 <email address hidden>

> Ubuntu 9.04 Users still have this problem with the version available in
> 9.04's repositories. Why is no update released?
>
> --
> I cannot login to connect to the server (OpenSubtitles, I guess)
> https://bugs.launchpad.net/bugs/452036
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SubDownloader - Find Subtitles for your Videos: Fix Released
> Status in “subdownloader” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: subdownloader
>
> -Ubuntu 9.04 Jaunty
> -Subdownloader 2.0.9.3-1 0
> -I expect to obtain a subtitles file.
> -Instead I obtain something like "You must login to connect to server".
> When I try to login I can't in any way.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: subdownloader 2.0.9.3-1
> PackageArchitecture: all
> ProcEnviron:
> LANG=ca_AD.UTF-8
> SHELL=/bin/bash
> SourcePackage: subdownloader
> Uname: Linux 2.6.28-15-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/subdownloader/+bug/452036/+subscribe
>

Marco Rodrigues (gothicx) wrote :

freak42: Only when the latest Ubuntu version in development has the new version 2.0.10, I could ask for a backport of it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package subdownloader - 2.0.10-1

---------------
subdownloader (2.0.10-1) unstable; urgency=low

  * New upstream version (Closes: #515664, #515665),
    (LP: #452036, #359294).
  * debian/subdownloader.install:
    + Use upstream xpm icon.
  * debian/control:
    + Bump Standards-Version to 3.8.4 (no changes).
    + Add pyqt4-dev-tools to rebuild qt ui files.
    + Change XS-Python-Version to >= 2.5 and bump python dependency
      to 2.5.2 as upstream needs python 2.5 to work correctly.
    + Replace python-central by python-support.
  * debian/rules:
    + Replace python-central by python-support.
    + Rebuild QT ui files.
    + Don't remove mmpython. Not at tarball anymore.
  * debian/copyright:
    + Add myself as upstream developer.
    + Bump copyright year to 2010.
    + Change from GPL-2 to GPL-3 as upstream.

subdownloader (2.0.9.3-2) unstable; urgency=low

  * debian/rules:
    + Move generate-mo-files to build and add to PHONY.
    + Force use of dh_pycentral instead of dh_pysupport.
  * debian/copyright:
    + Update to current year in translations and authors.
 -- Marco Rodrigues <email address hidden> Fri, 26 Mar 2010 17:40:18 +0000

Changed in subdownloader (Ubuntu):
status: Incomplete → Fix Released
Mco09 (mco09) wrote :

Again it is impossible to sign in....appears login error....It says "You are not connected to the server. Please reconnect first"...

Mco09 (mco09) wrote :

How can i fix this problem?????? Still i can not sign in!!!!!!

lespedretes (lespedretes-b) wrote :

Solution I found out was upgrade to Karmic and install Subdownloader 2.0.10.
I hope it serves you.

2010/4/22 Mco09 <email address hidden>

> How can i fix this problem?????? Still i can not sign in!!!!!!
>
> --
> I cannot login to connect to the server (OpenSubtitles, I guess)
> https://bugs.launchpad.net/bugs/452036
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SubDownloader - Find Subtitles for your Videos: Fix Released
> Status in “subdownloader” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: subdownloader
>
> -Ubuntu 9.04 Jaunty
> -Subdownloader 2.0.9.3-1 0
> -I expect to obtain a subtitles file.
> -Instead I obtain something like "You must login to connect to server".
> When I try to login I can't in any way.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: subdownloader 2.0.9.3-1
> PackageArchitecture: all
> ProcEnviron:
> LANG=ca_AD.UTF-8
> SHELL=/bin/bash
> SourcePackage: subdownloader
> Uname: Linux 2.6.28-15-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/subdownloader/+bug/452036/+subscribe
>

How can i upgrade it????...Where should i go to make this?????

> Date: Thu, 22 Apr 2010 12:10:43 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: Re: [Bug 452036] Re: I cannot login to connect to the server (OpenSubtitles, I guess)
>
> Solution I found out was upgrade to Karmic and install Subdownloader 2.0.10.
> I hope it serves you.
>
> 2010/4/22 Mco09 <email address hidden>
>
> > How can i fix this problem?????? Still i can not sign in!!!!!!
> >
> > --
> > I cannot login to connect to the server (OpenSubtitles, I guess)
> > https://bugs.launchpad.net/bugs/452036
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in SubDownloader - Find Subtitles for your Videos: Fix Released
> > Status in “subdownloader” package in Ubuntu: Fix Released
> >
> > Bug description:
> > Binary package hint: subdownloader
> >
> > -Ubuntu 9.04 Jaunty
> > -Subdownloader 2.0.9.3-1 0
> > -I expect to obtain a subtitles file.
> > -Instead I obtain something like "You must login to connect to server".
> > When I try to login I can't in any way.
> >
> > ProblemType: Bug
> > Architecture: i386
> > DistroRelease: Ubuntu 9.04
> > Package: subdownloader 2.0.9.3-1
> > PackageArchitecture: all
> > ProcEnviron:
> > LANG=ca_AD.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: subdownloader
> > Uname: Linux 2.6.28-15-generic i686
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/subdownloader/+bug/452036/+subscribe
> >
>
> --
> I cannot login to connect to the server (OpenSubtitles, I guess)
> https://bugs.launchpad.net/bugs/452036
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SubDownloader - Find Subtitles for your Videos: Fix Released
> Status in “subdownloader” package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: subdownloader
>
> -Ubuntu 9.04 Jaunty
> -Subdownloader 2.0.9.3-1 0
> -I expect to obtain a subtitles file.
> -Instead I obtain something like "You must login to connect to server". When I try to login I can't in any way.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> Package: subdownloader 2.0.9.3-1
> PackageArchitecture: all
> ProcEnviron:
> LANG=ca_AD.UTF-8
> SHELL=/bin/bash
> SourcePackage: subdownloader
> Uname: Linux 2.6.28-15-generic i686
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/subdownloader/+bug/452036/+subscribe

_________________________________________________________________
Hotmail: Trusted email with powerful SPAM protection.
https://signup.live.com/signup.aspx?id=60969

Marco Rodrigues (gothicx) wrote :

Mco09, looks like you've Jaunty, so you need to install from subdownloader PPA.

https://launchpad.net/~subdownloader-developers/+archive/ppa

Download full text (3.9 KiB)

To upgrade your OS you must to dowload a Karmic Koala CD and install it.
When you have done that, install Subdownloader from Synaptic.

2010/4/22 Mco09 <email address hidden>

>
> How can i upgrade it????...Where should i go to make this?????
>
>
>
>
> > Date: Thu, 22 Apr 2010 12:10:43 +0000
> > From: <email address hidden>
> > To: <email address hidden>
> > Subject: Re: [Bug 452036] Re: I cannot login to connect to the server
> (OpenSubtitles, I guess)
> >
> > Solution I found out was upgrade to Karmic and install Subdownloader
> 2.0.10.
> > I hope it serves you.
> >
> > 2010/4/22 Mco09 <email address hidden>
> >
> > > How can i fix this problem?????? Still i can not sign in!!!!!!
> > >
> > > --
> > > I cannot login to connect to the server (OpenSubtitles, I guess)
> > > https://bugs.launchpad.net/bugs/452036
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > >
> > > Status in SubDownloader - Find Subtitles for your Videos: Fix Released
> > > Status in “subdownloader” package in Ubuntu: Fix Released
> > >
> > > Bug description:
> > > Binary package hint: subdownloader
> > >
> > > -Ubuntu 9.04 Jaunty
> > > -Subdownloader 2.0.9.3-1 0
> > > -I expect to obtain a subtitles file.
> > > -Instead I obtain something like "You must login to connect to server".
> > > When I try to login I can't in any way.
> > >
> > > ProblemType: Bug
> > > Architecture: i386
> > > DistroRelease: Ubuntu 9.04
> > > Package: subdownloader 2.0.9.3-1
> > > PackageArchitecture: all
> > > ProcEnviron:
> > > LANG=ca_AD.UTF-8
> > > SHELL=/bin/bash
> > > SourcePackage: subdownloader
> > > Uname: Linux 2.6.28-15-generic i686
> > >
> > > To unsubscribe from this bug, go to:
> > > https://bugs.launchpad.net/subdownloader/+bug/452036/+subscribe
> > >
> >
> > --
> > I cannot login to connect to the server (OpenSubtitles, I guess)
> > https://bugs.launchpad.net/bugs/452036
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in SubDownloader - Find Subtitles for your Videos: Fix Released
> > Status in “subdownloader” package in Ubuntu: Fix Released
> >
> > Bug description:
> > Binary package hint: subdownloader
> >
> > -Ubuntu 9.04 Jaunty
> > -Subdownloader 2.0.9.3-1 0
> > -I expect to obtain a subtitles file.
> > -Instead I obtain something like "You must login to connect to server".
> When I try to login I can't in any way.
> >
> > ProblemType: Bug
> > Architecture: i386
> > DistroRelease: Ubuntu 9.04
> > Package: subdownloader 2.0.9.3-1
> > PackageArchitecture: all
> > ProcEnviron:
> > LANG=ca_AD.UTF-8
> > SHELL=/bin/bash
> > SourcePackage: subdownloader
> > Uname: Linux 2.6.28-15-generic i686
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/subdownloader/+bug/452036/+subscribe
>
> _________________________________________________________________
> Hotmail: Trusted email with powerful SPAM protection.
> https://signup.live.com/signup.aspx?id=60969
>
> --
> I cannot login to connect to the server (OpenSubtitles, I guess)
> https://bugs.launchpad.net/bugs/452036
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in SubD...

Read more...

Y Shreb (shreby) wrote :

i'm having the same problem
Using subdownloader 2.0.11

Alice (mini-corni) on 2010-09-01
Changed in subdownloader (Ubuntu):
status: Fix Released → Confirmed
Rolf Leggewie (r0lf) wrote :

I'm running version 2.0.10-1 of the package on lucid and nothing seems to be able to get subdownloader to log in to the server. Random lines from the console:

$ subdownloader
/usr/lib/python2.6/dist-packages/kaa/metadata/disc/cdrom.py:37: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
[22:55] ERROR::subdownloader.SDService.SDService # Unable to connect. Try setting a proxy.
[22:55] ERROR::subdownloader.SDService.SDService # Unable to connect. Try setting a proxy.
[22:55] ERROR::subdownloader.SDService.SDService # ServerInfo error connection.
Traceback (most recent call last):
  File "/usr/share/subdownloader/gui/main.py", line 556, in login_user
    if self.OSDBServer._login(username, password):
  File "/usr/share/subdownloader/modules/SDService.py", line 209, in _login
    info = self.xmlrpc_server.LogIn(username, password, s

Changed in subdownloader (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers