dh_strip_nondeterminism crashing due to missing Archive::Zip::computeCRC32

Bug #1703746 reported by Robert Ancell on 2017-07-12
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
strip-nondeterminism (Ubuntu)
Critical
Gianfranco Costamagna

Bug Description

From building gnome-software:

dh_strip_nondeterminism
dh_strip_nondeterminism: debian/gnome-software-common/usr/share/gnome-software/featured-gnome-sudoku.png: Undefined subroutine &Archive::Zip::computeCRC32 called at /usr/share/perl5/File/StripNondeterminism/handlers/png.pm line 33.

From https://launchpadlibrarian.net/328403951/buildlog_ubuntu-artful-amd64.gnome-software_3.24.3-0ubuntu6_BUILDING.txt.gz

Works once:
use Archive::Zip;

added to the top of the perl module.

Changed in strip-nondeterminism (Ubuntu):
importance: Undecided → Critical
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in strip-nondeterminism (Ubuntu):
status: New → Confirmed
summary: - Crashing due to missing Archive::Zip::computeCRC32
+ dh_strip_nondeterminism crashing due to missing
+ Archive::Zip::computeCRC32
Daniel van Vugt (vanvugt) wrote :

A fix is in proposed...

strip-nondeterminism (0.037-1ubuntu1) artful; urgency=medium

  * Add missing Archive::Zip to fix build of reverse-dependencies
    using png.pm

 -- Gianfranco Costamagna <email address hidden> Wed, 12 Jul 2017 08:06:53 +0200

Changed in strip-nondeterminism (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → LocutusOfBorg (costamagnagianfranco)

I missed that bug, sorry!

and already retried gnome-foo

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package strip-nondeterminism - 0.038-1~build2

---------------
strip-nondeterminism (0.038-1~build2) artful; urgency=high

  [ Gianfranco Costamagna ]
  * Upload to artful (LP: #1703746)

  [ Niels Thykier ]
  * Add missing use statements in handler modules. This is yet more fallout
    from lazily-loading the handlers in #867982. Thanks to Christian Marillat
    for the report. (Closes: #868111)

 -- Chris Lamb <email address hidden> Wed, 12 Jul 2017 09:04:11 +0100

Changed in strip-nondeterminism (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers