strigi encoding problem - cannot read i.e. Greek

Bug #146518 reported by vista killer on 2007-09-28
10
Affects Status Importance Assigned to Milestone
strigi (Ubuntu)
Undecided
Unassigned

Bug Description

strigi dont show the greek names of my home folders.It show them in result like this home/spiros/my documents/deb package προγραμματα/pidgin-data_2.2.0-1~getdeb1_all.deb/data.tar.gz/./usr/share/icons/hicolor/scalable/apps/pidgin.svg
The strange is that with konqueror and dolphin i can see this folder

vista killer (vistakiller) wrote :

it seem that is not only a strigi problem.It happens and with gdeb,kpackage.They canot see the right name of the folders and canot read some deb file that exist in these folder.The message i take from kpackage is this
dpkg -i '///home/spiros/my documents/deb package ???????????/amsn_0.96-1getdeb1_i386.deb' ;echo RESULT=$?

vista killer (vistakiller) wrote :

I like to say that this system is gutsy from feisty upgrade.I dont have this problem with feisty.I see that i have the same problem and with amsn.I cant see the greek menu in this programmes.I dont have it before upgrade.

Let me express my fear about this problem too. As we are approaching the final release of Gutsy, it would be very unpleasant for us to see an innovative tool coming with Kubuntu Gutsy just not working for our language (Greek)!

The problem exists for me as described above for Strigi. Neither the icon in the notification area nor Strigi running from Kmenu works with Greek. As for the icon it returns the results using symbols as described in the first report of this bug. As for Strigi from Kmenu it will never return files or folders with greek names, although there are indexed.

Please let us now what we should expect.

Let me add too, that there is not any general problem with Greek in Kubuntu, so it seems to be a deficiency in Strigi. Also other similar tools (like Google desktop and Beagle) work well (if it ever has any sense mentioning...). Dolphin has no problem showing Greek names.

I changed the title of the reported bug to be more precise. Could now somebody take it into consideration please?

Simos Xenitellis  (simosx) wrote :

When you see text such as προγραμματα (many Î) or ?????????????, then it is an encoding issue.
In the first case I think what happens is that non-Unicode text (iso-8859-7) is considered as UTF-8 and is shown like that.
In the second case, there is severe corruption; there was a conversion necessary to a limited encoding, so all missing characters are shown as ???.

In encoding situations like this it is good to supply a screenshot demonstrating the problem. Could you please create a screenshot and attach it to this bug report?

In addition, the problem may have arisen from user configuration changes. You may have changed the system encoding to iso-8859-7 to make some programs work? Can you verify whether this has been done?

Finally, it would be important to verify that a clean Gutsy install has or does not have this bug. This would help verify the report and put resources to fix it. Are you able to install a Beta Gutsy and try to reproduce the bug? If not, can you provide a list of instructions so that someone can try to reproduce? It is important to be able to reproduce the bug.

I hope this helps.

vista killer (vistakiller) wrote :

Is strange because i create this folder with dolphin and i use utf-8 and no iso-8859-7.I dont change the system encoding and the problem exist only to these programs.I have attach some screenshot from the strigi,gdebi,kdesudo and kpackage

vista killer (vistakiller) wrote :
vista killer (vistakiller) wrote :
vista killer (vistakiller) wrote :
Simos Xenitellis  (simosx) wrote :

It looks to me that the problem is with a specific folder only. You have a folder with invalid name, probably Greek, under

/home/spiros/my documents/<here>/

Now, the question is, how did you create that folder? Did you use konqueror? Did you use another program?

If you download the packages (I think you were trying to install something called winff) again and place them in a different folder, you should be able to install problem.

What happened on your system is that you got a corrupted folder name, so anything inside is not easily accessible.
The source of the problem is the tool you used to create the folder. It is not "strigi" that fails to work; any application will struggle with the corrupt folder name.

Simos, as I have already said, I have the same problem with ALL greek names and at the same time other similar tools like Google Desktop and Beagle work fine!

vista killer (vistakiller) wrote :

it seems that some programs can not regognize the greek folders.I create all of them with konqueror.The package winff i put it only for example.The same package i can install it if i remove it to other folder.

H1bakusha (lumpi-online) wrote :

got the same problem with german specuial characters like ä ö ü.

I cant open a file via strigi if name or path contains special characters. it gives me an error message that it couldn't read the file.

H1bakusha, have you done a clean installation of Gutsy or does your system come from an upgrade from Feisty?

H1bakusha (lumpi-online) wrote :

its a feisty upgrade.

H1bakusha (lumpi-online) on 2007-10-09
Changed in strigi:
status: New → Confirmed
vista killer (vistakiller) wrote :

I have found and other programme that have problem with encodings.I think we must change the bug title.It seems that kubuntu have enconding problems .Here is the new pic

Simos Xenitellis  (simosx) wrote :

To help figure out what the problem is about, we need a test.

@vistakiller,
1. Could you please open a terminal window and run "locale".
Post the results here.
2. Change to the directory (still on the terminal) called "/home/spiros/my documents/" and type "ls".
Check visually if the Greek text appears ok.
If the Greek text does not appear ok, can you please type "ls > /tmp/buginfo.txt".
This will create a file called buginfo.txt with the directory contents. Make sure there is no private information there.
Then, you can post the contents here. This will help to identify the exact nature of the encoding problem.

Perhaps it is a bug of feisty update and not one of the forthcoming Ubuntu. Who knows....

vista killer (vistakiller) wrote :

1.locale in terminal

LANG=el_GR.UTF-8
LC_CTYPE="el_GR.UTF-8"
LC_NUMERIC="el_GR.UTF-8"
LC_TIME="el_GR.UTF-8"
LC_COLLATE="el_GR.UTF-8"
LC_MONETARY="el_GR.UTF-8"
LC_MESSAGES="el_GR.UTF-8"
LC_PAPER="el_GR.UTF-8"
LC_NAME="el_GR.UTF-8"
LC_ADDRESS="el_GR.UTF-8"
LC_TELEPHONE="el_GR.UTF-8"
LC_MEASUREMENT="el_GR.UTF-8"
LC_IDENTIFICATION="el_GR.UTF-8"
LC_ALL=

2. ls my\ documents
2007-07-25-12-30-49.056-VirtualBox-6989.log bookmarks.xml downloads
aptitude deb package-προγράμματα

Simos Xenitellis  (simosx) wrote :

Thanks for the update.

This shows that the directory name "deb package-προγράμματα" is saved on the filesystem are correct UTF-8 text, therefore there is no data corruption whatsoever.

The kpackage screenshot shows that the program probably runs in Unicode (you can see Greek), but the filename/directory name is garbled. It appears as if KDE considers that the filesystem encoding is not UTF-8 but rather something else, such as the legacy encoding iso-8969-1. If you could search in the settings to find something like "filesystem/filename encoding", it might provide help.

vista killer (vistakiller) wrote :

I cant find in the setting something like that but i found tha the system is in utf-8.The strange is that i dont have problem before the upgrade.

sotos65 (alterego-freemail) wrote :

I have the same problem with strigi and greek characters in a new (clean) installation of ubuntu 7.10 gutsy RC, 64bit version. I installed kubuntu-desktop after the initial installation, and all the new updates up to now. Here is also a screenshot of strigi demonstrating this problem,

sotos65 (alterego-freemail) wrote :

There is one more similar problem with the menu title of akregator. It doesn't display proper greek characters, but the same "¼Î¼Î±Ï„α" garbage! You may see this in the attached screenshot,

vista killer (vistakiller) wrote :

Another same problem with ark.Look here

vista killer (vistakiller) wrote :

I have found new problem in gnome this time with the greek fonts.

vista killer, is this a screenshot from a Kubuntu installation running GNOME? Or have you encountered this problem on an Ubuntu installation?

vista killer (vistakiller) wrote :

ubuntu fresh installation and i have install akregator with kde libs.

vista killer (vistakiller) wrote :

I have install kubuntu hardy heron alpha 4 and the problem still exist.The problem now is more difficult because they have translate files like dekstop,movies,music etc.Now you can search all the files with strigi and you cant install a deb package because gdebi dont recognize greek names.I dont know if other programmes have problem with greek names.Here is and some pictures from hardy with the problem

vista killer (vistakiller) wrote :
vista killer (vistakiller) wrote :

O/H vista killer έγραψε:
> I have install kubuntu hardy heron alpha 4 and the problem still
> exist.The problem now is more difficult because they have translate
> files like dekstop,movies,music etc.Now you can search all the files
> with strigi and you cant install a deb package because gdebi dont
> recognize greek names.I dont know if other programmes have problem with
> greek names.Here is and some pictures from hardy with the problem
>
>
> ** Attachment added: "kubuntuhardy.png"
> http://launchpadlibrarian.net/11798642/kubuntuhardy.png
>
>
Not 100% sure. Try the following:

1. Open a terminal and back up the existing fstab file sudo cp
/etc/fstab /etc/fstab.bak
2. Edit the fstab sudo kate /etc/fstab
3. Change the line to:
/dev/scd0 /media/cdrom0 auto iocharset=utf8,user,noauto
0 0

vista killer (vistakiller) wrote :

Stathis nothing happens.The problem still exist.

Simos Xenitellis  (simosx) wrote :

The way I would summarise the problem with the existing information, is with a title

"KDE applications assume directories/filenames have iso-8859-1 encoding".

Whether it is strigi or the Greek language, it appears is not relevant.

vista killer (vistakiller) wrote :

It seems that they fix the problem with strigi.Here is the new pic

vista killer (vistakiller) wrote :

The problem dont exist anymore in hardy heron but still exist in gutsy.Here is the pic

Changed in strigi:
status: Confirmed → Fix Released
vista killer (vistakiller) wrote :

The problem still exist in Kubuntu Ibex with gdeb. I cant install a deb package when the package is inside a folder with greek name. Here is a pic

Savvas Radevic (medigeek) wrote :

Setting this bug back to "New", using the last comments.

Changed in strigi:
status: Fix Released → New
Savvas Radevic (medigeek) wrote :

I apologise, removed "Duplicate" state - strigi is not part of jaunty KDE 4 as far as I can see.
Setting it back to "Fix released"

Changed in strigi:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers