stress-ng --timer-slack option should be a zero arg option, it currently skips over the next arg

Bug #1853832 reported by Colin Ian King on 2019-11-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stress-ng (Ubuntu)
Medium
Colin Ian King
Xenial
Medium
Colin Ian King
Bionic
Medium
Colin Ian King
Disco
Medium
Colin Ian King
Eoan
Medium
Colin Ian King

Bug Description

== SRU [Bionic][Disco][Eoan] ==

stress-ng --timer 1 --timer-freq 100000 --timer-slack -t 1 runs for a whole day and not 1 second. The timer-slack option eats the -t1 arg because it is defined as having an arg when in fact it is a zero arg option.

== Fix ==

Upstream fix (in Focal):

commit e044133ed6ebdbac16775d8ae0d130bc2dac96ea
Author: Colin Ian King <email address hidden>
Date: Mon Nov 25 12:05:30 2019 +0000

    Fix --timer-slack from consuming the following arg (LP: #1853832)

== Test ==

stress-ng --timer 1 --timer-freq 100000 --timer-slack -t 1

Without the fix, this will run by default for 24 hours. With the fix the -t option is parsed and it will run for 1 second as intended.

== Regression Potential ==

This is a one line arg parsing change so change set is really limited to this one --timer-slack option. Users may find the behaviour now changes because it no longer consumes the next arg and hence the next arg works and hence changes functionality.

Colin Ian King (colin-king) wrote :
Changed in stress-ng:
status: New → Fix Committed
Changed in stress-ng:
importance: Undecided → Medium
assignee: nobody → Colin Ian King (colin-king)
Changed in stress-ng:
status: Fix Committed → Fix Released
affects: stress-ng → stress-ng (Ubuntu)
description: updated
Changed in stress-ng (Ubuntu Eoan):
importance: Undecided → Medium
status: New → In Progress
description: updated
description: updated
summary: - stress-ng --timer-slack option should be a zero arg option, it current
- eats the next arg
+ stress-ng --timer-slack option should be a zero arg option, it currently
+ skips over the next arg

Hello Colin, or anyone else affected,

Accepted stress-ng into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/stress-ng/0.10.07-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in stress-ng (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Changed in stress-ng (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed-disco
Timo Aaltonen (tjaalton) wrote :

Hello Colin, or anyone else affected,

Accepted stress-ng into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/stress-ng/0.09.57-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in stress-ng (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Timo Aaltonen (tjaalton) wrote :

Hello Colin, or anyone else affected,

Accepted stress-ng into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/stress-ng/0.09.25-1ubuntu6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in stress-ng (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Timo Aaltonen (tjaalton) wrote :

Hello Colin, or anyone else affected,

Accepted stress-ng into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/stress-ng/0.05.23-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

All autopkgtests for the newly accepted stress-ng (0.05.23-1ubuntu3) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

stress-ng/0.05.23-1ubuntu3 (arm64, s390x, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#stress-ng

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Colin Ian King (colin-king) wrote :

Tested xenial, it now segfaults, so this fails testing.

tags: added: verification-failed-xenial
removed: verification-needed-xenial
Colin Ian King (colin-king) wrote :

Tested on Bionic, fixes the issue. Marking as verification-done-bionic

tags: added: verification-done-bionic
removed: verification-needed-bionic
Colin Ian King (colin-king) wrote :

Tested on Eoan, fixes the issue. Marking as verification-done-eoan

tags: added: verification-done-eoan
removed: verification-needed-eoan
Colin Ian King (colin-king) wrote :

Ignore comment #7, I tested with the wrong version in Bionic. The new version in Bionic segfaults, so this fails testing and should not be promoted.

tags: added: verification-failed-bionic
removed: verification-done-bionic
Changed in stress-ng (Ubuntu Xenial):
assignee: nobody → Colin Ian King (colin-king)
Changed in stress-ng (Ubuntu Bionic):
assignee: nobody → Colin Ian King (colin-king)
Changed in stress-ng (Ubuntu Disco):
assignee: nobody → Colin Ian King (colin-king)
Changed in stress-ng (Ubuntu Eoan):
assignee: nobody → Colin Ian King (colin-king)
Changed in stress-ng (Ubuntu Bionic):
importance: Undecided → Medium
Changed in stress-ng (Ubuntu Xenial):
importance: Undecided → Medium
Changed in stress-ng (Ubuntu Disco):
importance: Undecided → Medium
Colin Ian King (colin-king) wrote :

Tested on Disco, fixes the issue, Marking as verification-done-disco

tags: added: verification-done-disco
removed: verification-needed-disco

The verification of the Stable Release Update for stress-ng has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package stress-ng - 0.09.57-0ubuntu5

---------------
stress-ng (0.09.57-0ubuntu5) disco; urgency=medium

  * Fix --timer-slack from consuming the following arg (LP: #1853832)
    Currently the timer slack option eats the next argument, causing
    missing argument parsing behaviour on the command line.
  * Fix mwc8() being reset when using mwc1() (LP: #1855851)
    Fic Psuedo-random 8 bit numbers from mwc8() accidentally
    being zero'd when mwc1() is called.

 -- Colin King <email address hidden> Tue, 10 Dec 2019 09:32:11 +0000

Changed in stress-ng (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package stress-ng - 0.10.07-1ubuntu3

---------------
stress-ng (0.10.07-1ubuntu3) eoan; urgency=medium

  * Fix --timer-slack from consuming the following arg (LP: #1853832)
    Currently the timer slack option eats the next argument, causing
    missing argument parsing behaviour on the command line.
  * Fix mwc8() being reset when using mwc1() (LP: #1855851)
    Fic Psuedo-random 8 bit numbers from mwc8() accidentally
    being zero'd when mwc1() is called.

 -- Colin King <email address hidden> Tue, 10 Dec 2019 09:32:11 +0000

Changed in stress-ng (Ubuntu Eoan):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson) on 2020-02-04
tags: removed: verification-needed
Colin Ian King (colin-king) wrote :

I've re-uploaded the bionic version ready for another SRU test

Hello Colin, or anyone else affected,

Accepted stress-ng into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/stress-ng/0.09.25-1ubuntu8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-failed-bionic
Colin Ian King (colin-king) wrote :

Bionic: Argument is being parsed correctly.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
tags: added: verification-needed
removed: verification-done

All autopkgtests for the newly accepted stress-ng (0.09.25-1ubuntu8) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

stress-ng/0.09.25-1ubuntu8 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#stress-ng

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Colin Ian King (colin-king) wrote :

The re-test on armhf worked, so this has passed testing if I understand the update excuses page.

tags: added: verification-needed-xenial
removed: verification-failed-xenial
tags: added: verification-needed-bionic
removed: verification-done-bionic

All autopkgtests for the newly accepted stress-ng (0.05.23-1ubuntu3) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

stress-ng/0.05.23-1ubuntu3 (s390x, ppc64el, arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#stress-ng

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Colin Ian King (colin-king) wrote :

The above test failure is not a regression but an existing issue found with the testing because the allowable number of file descriptors limit has been increased and now trips the dup stress test failure during regression testing. I have a fix for this in, see bug 1873448

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package stress-ng - 0.09.25-1ubuntu8

---------------
stress-ng (0.09.25-1ubuntu8) bionic; urgency=medium

  * Ensure --aggressive mode terminates early (LP: #1858858)
    Add a waitpid NOHANG wait on each child process and if we get ESRCH
    on all the child pids we can terminate the loop early.
  * Fix --timer-slack arg handling (LP: #1853832)
  * Fix mwc8() being reset when using mwc1() (LP: #1855851)
    Fix Psuedo-random 8 bit numbers from mwc8() accidentally
    being zero'd when mwc1() is called.

 -- Colin King <email address hidden> Tue, 10 Dec 2019 09:32:11 +0000

Changed in stress-ng (Ubuntu Bionic):
status: Fix Committed → Fix Released

The fix for this bug has been awaiting testing feedback in the -proposed repository for xenial for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Colin Ian King (colin-king) wrote :

This fails testing on Xenial, still segfaults. Should be rejected

tags: added: verification-failed-xenial
removed: verification-needed-xenial

The version of stress-ng in the proposed pocket of Xenial that was purported to fix this bug report has been removed because one or more bugs that were to be fixed by the upload have failed verification and been in this state for more than 10 days.

Changed in stress-ng (Ubuntu Xenial):
status: Fix Committed → Won't Fix
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers