streamripper does not connect to server

Bug #326239 reported by lukyluke on 2009-02-06
2
Affects Status Importance Assigned to Milestone
streamripper (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: streamripper

whatever stream I try to connect I get the same error:streamripper

http://localhost:1881/lastfm.mp3
Connecting...

error -3 [SR_ERROR_INVALID_URL]
bye..
shutting down

http://scastsrv2.shoutcast.com:8038/
Connecting...

error -3 [SR_ERROR_IN
VALID_URL]
bye..
shutting down

streamripper http://67.225.203.20:9000
Connecting...

error -3 [SR_ERROR_INVALID_URL]
bye..
shutting down

the same stream are working with mplayer and amarok
streamripper -v
Streamripper 1.63.5

on kubuntu intrepid amd64

lukyluke (luca-tagliacozzo) wrote :

The problem is related to the http_proxy variable
I had it set to
http_proxy=
For most of the program this does not affect, for streamripper it implies it does not interpret the url correctly.
The problem is solved by
unset http_proxy
Every thing goes back to normal

Changed in streamripper:
status: New → Fix Released
lukyluke (luca-tagliacozzo) wrote :

Just a note,
the same fix works with vlc,
now it also connects, so try avoid having an empty http_proxy variable

Cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers