straight.plugin 1.4.1-3 source package in Ubuntu

Changelog

straight.plugin (1.4.1-3) unstable; urgency=medium

  * Team upload.
  * d/control: Set Vcs-* to salsa.debian.org
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field
  * Convert git repository from git-dpm to gbp layout
  * Use debhelper-compat instead of debian/compat.
  * Drop Python 2 support.

 -- Ondřej Nový <email address hidden>  Fri, 26 Jul 2019 19:26:22 +0200

Upload details

Uploaded by:
Debian Python Modules Team
Uploaded to:
Sid
Original maintainer:
Debian Python Modules Team
Architectures:
all
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Impish release universe misc
Hirsute release universe misc
Groovy release universe misc
Focal release universe misc

Builds

Eoan: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
straight.plugin_1.4.1-3.dsc 2.2 KiB b435e3c4e0d7ff9632dabba3120a348f590b06897ed5ea640bd052ddc1810e29
straight.plugin_1.4.1.orig.tar.gz 15.2 KiB 27209b4aa1887e84430d2f1e1ac35c597d73c242e4b7801e7e4d34f26cf5c77b
straight.plugin_1.4.1-3.debian.tar.xz 2.6 KiB 31693d336056238b8f0ab27b8977ca893f5047491f7075bae757735da4630572

Available diffs

No changes file available.

Binary packages built by this source

python-straight.plugin-doc: No summary available for python-straight.plugin-doc in ubuntu eoan.

No description available for python-straight.plugin-doc in ubuntu eoan.

python3-straight.plugin: Simple namespaced plugin facility (Python 3)

 straight.plugin is a Python plugin loader inspired by twisted.plugin
 with two important distinctions:
 .
 - Fewer dependencies
 - Python 3 compatible
 .
 The system is used to allow multiple Python packages to provide
 plugins within a namespace package, where other packages will locate
 and utilize. The plugins themselves are modules in a namespace
 package where the namespace identifies the plugins in it for some
 particular purpose or intent.
 .
 This package installs the library for Python 3.