Crash with "segmentation fault" executing strace with -S name switch

Bug #1766060 reported by grofaty on 2018-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
strace (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
I am reading docker documentation https://training.play-with-docker.com/security-seccomp/ and there are samples how to use strace command for example to strace the whoami there is a sample to be run from terminal:
strace -c -f -S name whoami

When I execute this command every time error appears:
"Segmentation fault (core dumped)"

I tried:
strace -c whoami
works fine

I tried:
strace -c -f whoami
also works fine.

But:
strace -c -f -S name whoami
every time returns "segmentation fault".

It looks like "-S name" switch is the cause of the problem.

Regards

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: strace 4.11-1ubuntu3
ProcVersionSignature: Ubuntu 4.13.0-38.43~16.04.1-generic 4.13.16
Uname: Linux 4.13.0-38-generic i686
ApportVersion: 2.20.1-0ubuntu2.16
Architecture: i386
CurrentDesktop: Unity
Date: Sun Apr 22 10:03:58 2018
Dependencies:
 gcc-6-base 6.0.1-0ubuntu1
 libc6 2.23-0ubuntu10
 libgcc1 1:6.0.1-0ubuntu1
InstallationDate: Installed on 2018-01-20 (91 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release i386 (20170801)
SourcePackage: strace
UpgradeStatus: No upgrade log present (probably fresh install)

grofaty (grofaty) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers