stow version in wily unusable: possible precedence issue with control flow...

Bug #1516588 reported by Sergio Callegari on 2015-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stow (Ubuntu)
Undecided
Unassigned

Bug Description

Any stow invocation results in

stow: Possible precedence issue with control flow operator at /usr/share/perl5/Stow.pm line 1736.

even asking for the stow program version as in

stow --version --verbose=3
Possible precedence issue with control flow operator at /usr/share/perl5/Stow.pm line 1736.
stow (GNU Stow) version 2.2.0

The bug is known and a fix is avaliable

https://lists.gnu.org/archive/html/bug-stow/2015-06/msg00002.html
http://git.savannah.gnu.org/cgit/stow.git/commit/?id=d788ce0c1c59b3158270143659f7a4363da73056

Please, either provide a bugfix update soon or consider removing stow from the repos, since it is not sensible to have a program that can just error out.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: stow 2.2.0-2
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Uname: Linux 4.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
CurrentDesktop: KDE
Date: Mon Nov 16 12:05:26 2015
EcryptfsInUse: Yes
PackageArchitecture: all
SourcePackage: stow
UpgradeStatus: Upgraded to wily on 2015-10-26 (20 days ago)

Sergio Callegari (callegar) wrote :
tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers