stellarium version 0.11.0-1 failed to build on armhf

Bug #841503 reported by Ricardo Salveti on 2011-09-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
stellarium (Ubuntu)
High
Unassigned

Bug Description

stellarium version 0.11.0-1 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+source/stellarium/0.11.0-1/+build/2679016

Direct link to the build log: https://launchpad.net/ubuntu/+source/stellarium/0.11.0-1/+build/2679016/+files/buildlog_ubuntu-oneiric-armel.stellarium_0.11.0-1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 857 lines into the build log:

-- Performing Test ICONV_SECOND_ARGUMENT_IS_CONST - Failed
-- Found Iconv: /usr/lib/arm-linux-gnueabi/libc.so
-- Found xgettext: /usr/bin/xgettext
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find OpenGL (missing: OPENGL_gl_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindOpenGL.cmake:153 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:225 (FIND_PACKAGE)

-- Configuring incomplete, errors occurred!
dh_auto_configure: cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE=ON returned exit code 1
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110902-0707
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/stellarium-0.11.0

Changed in stellarium (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: added: opengles
Pekko Metsä (pjmetsa) wrote :

Dear Ricardo,

also ovito uses CMake and fails to build on armel, because CMake is not able to find OPENGL_gl_LIBRARY.
So, this bug is pretty similar to bug #809758, probably both have the same solution. Currently unsolved, though.

cheers,
Pekko

Jeremy Bicha (jbicha) on 2013-08-04
summary: - stellarium version 0.11.0-1 failed to build on armel
+ stellarium version 0.11.0-1 failed to build on armhf
Timo Jyrinki (timo-jyrinki) wrote :

This used to be fixed in Stellarium, so marking as bug fixed.

However, I have just failed bug #1395655 about Stellarium failing to build on armhf against Qt 5.4.0 beta.

Changed in stellarium (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers