Steam Installer cannot be found using GNOME Software anymore

Bug #1754852 reported by AsciiWolf on 2018-03-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
appstream-generator (Ubuntu)
Undecided
Unassigned
steam (Ubuntu)
Medium
Jeremy Bicha

Bug Description

Since some recent update, Steam Installer is not showing in GNOME Software on Ubuntu 18.04. It looks like there is something wrong with the icon: http://appstream.ubuntu.com/bionic/multiverse/issues/steam-installer.html

AsciiWolf (asciiwolf) wrote :

It looks like it is some appstream-generator relased issue.

AsciiWolf (asciiwolf) wrote :

s/relased/related/g

Simon Quigley (tsimonq2) wrote :

tsimonq2> Someone here might have a better idea about bug 1754852 than I.
seb128> tsimonq2, Laney, ximion, or robert_ancell are probably the persons who can help you with such issues
Laney> tsimonq2: The icon needs to be in the same package as the appdata.

Changed in appstream-generator (Ubuntu):
status: New → Invalid
Changed in steam (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) wrote :

Actually, Jeremy is the one who added the extra steam-installer package. I'm not exactly sure how to get this to work all in one package without regressing something. He should fix this.

Changed in steam (Ubuntu):
assignee: Simon Quigley (tsimonq2) → Jeremy Bicha (jbicha)
AsciiWolf (asciiwolf) wrote :

I have just tried it on Ubuntu 17.10 and Steam shows without any issues in GNOME Software. And there are no changes in the steam-installer package in Ubuntu 18.04.

AsciiWolf (asciiwolf) wrote :

It looks like that the Steam Installer is missing in GNOME Software even after being manually installed by apt.

AsciiWolf (asciiwolf) wrote :

Artful: http://appstream.ubuntu.com/artful/multiverse/issues/steam-installer.html
Bionic: http://appstream.ubuntu.com/bionic/multiverse/issues/steam-installer.html
As I said, as far as I know, there were no changes in the steam/steam-installer package that could cause this issue.

Jeremy Bicha (jbicha) wrote :

AsciiWolf, I think the AppStream generator got more strict.

Personally, I'd like to just remove the steam .deb packages in Ubuntu completely.
1. It does not integrate well in GNOME Software because of the 32-bit issue, which I hacked around earlier.
2. It breaks badly with the "Install Steam" .deb you can find on the Steam website.

I'd like us to just offer the Steam Snap that Solus is working on ("Linux Steam Integration"). I hope that will be ready in time for Ubuntu 18.04 LTS.

AsciiWolf (asciiwolf) wrote :

@jbicha: This sounds like a good idea to me.

Simon Quigley (tsimonq2) wrote :

> Personally, I'd like to just remove the steam .deb packages in Ubuntu completely.

Do the installers work correctly in LTS releases? If they don't, then I agree, it's a candidate for removal.

> 2. It breaks badly with the "Install Steam" .deb you can find on the Steam website.

Could you elaborate?

> I'd like us to just offer the Steam Snap that Solus is working on ("Linux Steam Integration"). I hope that will be ready in time for Ubuntu 18.04 LTS.

I'm personally hesitant to endorse removals "just because there's a snap" but if it bitrots over time/is insecure then I think it certainly needs to be removed.

Jeremy Bicha (jbicha) wrote :

To follow up, I filed the removal bug now with details and some history LP: #1759715

AsciiWolf (asciiwolf) wrote :

It looks like that Steam installer started showing again in GNOME Software on Ubuntu 18.04! So this issue seems to be fixed.

AsciiWolf (asciiwolf) on 2018-10-08
Changed in steam (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers