Please update udev rules for newer Steam builds

Bug #1645141 reported by Teg on 2016-11-27
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
steam (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned

Bug Description

Impact
------
Steam needs new udev rules to interact with their Steam controller, the HTC Vive and the PlayStation 4 DualShock controller. The udev rules also allow Steam to update the firmware in these devices.

Steam won't work properly if these rules are not updated.

Test Case
---------
If you have this hardware, you can test that the hardware works with Steam and that your hardware has the latest firmware.

Otherwise, for 16.10, this should update
/lib/udev/rules.d/60-HTC-Vive-perms.rules and
/lib/udev/rules.d/99-steam-controller-perms.rules

99-HTC-Vive-perms.rules has been renamed to 60-HTC-Vive-perms.rules

For 14.04 and 16.04, it should update
/lib/udev/rules.d/99-steam-perms.rules
and add
/lib/udev/rules.d/60-HTC-Vive-perms-Ubuntu.rules

Regression Potential
--------------------
Low. These rules have been shipped directly by Steam since 1.0.0.54 released at the end of October 2016.

Other Info
----------
There is a very complicated conflict between the steam packages shipped in Debian (and fake-synced to Ubuntu) and those shipped in Valve's own repository which is automatically enabled if you install Steam directly from Steam's website.

I am working to try to fix that conflict but it may take some time and it may involve adding new packages in Ubuntu SRUs. So there will probably be another SRU but let's get this easier update taken care of first.

For the 14.04 and 16.04 SRUs, I ensured that the udev rules have different file names than the files shipped by Ubuntu 16.10+ and Valve to not make the file conflict and LP: #1638463 any worse.

Original Bug Report
-------------------
According to https://steamcommunity.com/app/353370/discussions/0/490123197956024380/ newer builds of Steam post November 22, 2016 have new udev rules that have to be implemented by distributions. Please update the steam package for Trusty and above to accommodate these rules.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in steam (Ubuntu):
status: New → Confirmed
Teg (tegskywalker) wrote :

This is an updated udev rules file included with the steam-launcher_1.0.0.54_all.deb file on November 23, 2016 from http://repo.steampowered.com/steam/pool/steam/s/steam/?C=M;O=D

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package steam - 1:1.0.0.54+repack-2ubuntu5

---------------
steam (1:1.0.0.54+repack-2ubuntu5) zesty; urgency=medium

  * Depend on steam instead of steam:i386

 -- Jeremy Bicha <email address hidden> Thu, 16 Mar 2017 12:46:54 -0400

Changed in steam (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2017-03-17
Changed in steam (Ubuntu Yakkety):
status: New → In Progress
Changed in steam (Ubuntu):
importance: Undecided → Medium
Changed in steam (Ubuntu Xenial):
importance: Undecided → Medium
Changed in steam (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in steam (Ubuntu Trusty):
importance: Undecided → Medium
Jeremy Bicha (jbicha) on 2017-03-17
Changed in steam (Ubuntu Xenial):
status: New → In Progress
Changed in steam (Ubuntu Trusty):
status: New → In Progress
Jeremy Bicha (jbicha) on 2017-03-17
description: updated
Jeremy Bicha (jbicha) on 2017-03-17
description: updated
tags: added: trusty xenial yakkety

Hello Teg, or anyone else affected,

Accepted steam into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/steam/1:1.0.0.52-5ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in steam (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in steam (Ubuntu Xenial):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Teg, or anyone else affected,

Accepted steam into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/steam/1:1.0.0.48-1ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in steam (Ubuntu Trusty):
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Teg, or anyone else affected,

Accepted steam into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/steam/1:1.0.0.45-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jeremy Bicha (jbicha) wrote :

I do not have the hardware to test these rules, but I reached out to ~jorge who does and he confirmed that the update worked for him. I believe he tested with Ubuntu 16.10. He can't comment directly because there was a problem with him being able to log in to Launchpad after leaving Canonical recently.

I also checked the build logs for steam 1:1.0.0.45-1ubuntu1.2 for Ubuntu 14.04 LTS, 1:1.0.0.48-1ubuntu4 for Ubuntu 16.04 LTS and 1:1.0.0.52-5ubuntu2 for Ubuntu 16.10 and verified that the files look correct there.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package steam - 1:1.0.0.45-1ubuntu1.2

---------------
steam (1:1.0.0.45-1ubuntu1.2) trusty; urgency=medium

  * Update udev rules for Steam controller to October 2016 version.
  * Add October 2016 udev rules for HTC Vive (LP: #1645141)
  * Be careful to use different filenames than those shipped in
    Ubuntu 16.10 or directly from Valve to avoid complicated
    file conflict issue.

 -- Jeremy Bicha <email address hidden> Thu, 16 Mar 2017 23:35:30 -0400

Changed in steam (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for steam has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package steam - 1:1.0.0.48-1ubuntu4

---------------
steam (1:1.0.0.48-1ubuntu4) xenial; urgency=medium

  * Update udev rules for Steam controller to October 2016 version.
  * Add October 2016 udev rules for HTC Vive and PlayStation 4
    DualShock controller (LP: #1645141)
  * Be careful to use different filenames than those shipped in
    Ubuntu 16.10 or directly from Valve to avoid complicated
    file conflict issue.

 -- Jeremy Bicha <email address hidden> Thu, 16 Mar 2017 23:40:13 -0400

Changed in steam (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package steam - 1:1.0.0.52-5ubuntu2

---------------
steam (1:1.0.0.52-5ubuntu2) yakkety; urgency=medium

  * Add update-udev-rules.patch:
    - Update udev rules to October 2016 version (LP: #1645141)
      + Better support for HTC Vive and PlayStation 4 DualShock controller

 -- Jeremy Bicha <email address hidden> Thu, 16 Mar 2017 21:49:15 -0400

Changed in steam (Ubuntu Yakkety):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers