package steam-devices (not installed) failed to install/upgrade: trying to overwrite '/lib/udev/rules.d/99-steam-controller-perms.rules', which is also in package steam-launcher 1.0.0.53

Bug #1638463 reported by Koobelakahn on 2016-11-02
120
This bug affects 22 people
Affects Status Importance Assigned to Milestone
steam (Debian)
Fix Released
Unknown
steam (Ubuntu)
High
Unassigned
Yakkety
High
Unassigned

Bug Description

Steam randomly crashed after unlocking synaptic package manager from taskbar

ProblemType: Package
DistroRelease: Ubuntu 16.10
Package: steam-devices (not installed)
ProcVersionSignature: Ubuntu 4.8.0-26.28-generic 4.8.0
Uname: Linux 4.8.0-26-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
AptOrdering:
 steam-devices:amd64: Install
 NULL: ConfigurePending
Architecture: amd64
Date: Mon Oct 31 22:37:12 2016
DpkgTerminalLog:
 Preparing to unpack .../steam-devices_1%3a1.0.0.52-5ubuntu1_all.deb ...
 Unpacking steam-devices (1:1.0.0.52-5ubuntu1) ...
 dpkg: error processing archive /var/cache/apt/archives/steam-devices_1%3a1.0.0.52-5ubuntu1_all.deb (--unpack):
  trying to overwrite '/lib/udev/rules.d/99-steam-controller-perms.rules', which is also in package steam-launcher 1.0.0.53
ErrorMessage: trying to overwrite '/lib/udev/rules.d/99-steam-controller-perms.rules', which is also in package steam-launcher 1.0.0.53
InstallationDate: Installed on 2016-10-31 (2 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
RelatedPackageVersions:
 dpkg 1.18.10ubuntu1
 apt 1.3.1
SourcePackage: steam
Title: package steam-devices (not installed) failed to install/upgrade: trying to overwrite '/lib/udev/rules.d/99-steam-controller-perms.rules', which is also in package steam-launcher 1.0.0.53
UpgradeStatus: No upgrade log present (probably fresh install)

Koobelakahn (steveninglese) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in steam (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Where did you get steam-launcher from?

steam-launcher is not in the Ubuntu archives. Therefore, I am marking this bug as Invalid for Ubuntu. Please contact the steam-launcher distributor to report this issue.

Changed in steam (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Jeremy Bicha (jbicha) wrote :

Oh, I see it comes from Valve themselves. I'm reopening this bug since it's bad for Valve's official steam packages to conflict like this with the Debian/Ubuntu packages.

Changed in steam (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Jeremy Bicha (jbicha) on 2017-03-13
Changed in steam (Ubuntu Yakkety):
importance: Undecided → High
status: New → Triaged
Changed in steam (Debian):
status: Unknown → New
Changed in steam (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.