Gnome Software catalog entry missing for Steam except on i386

Bug #1564570 reported by carlix on 2016-03-31
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
appstream (Ubuntu)
Medium
Unassigned
Xenial
Undecided
Unassigned
appstream-dep11 (Ubuntu)
Medium
Unassigned
steam (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

A very beautiful app, but is missing in the Gnome-Software catalog!!!
You can install it from terminal and then it appears in Gnome-software but if you search for it in gnome-software first you can´t install it.

It shows up in Ubuntu 'i386' but not Ubuntu 'amd64'.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in steam (Ubuntu):
status: New → Confirmed
AsciiWolf (asciiwolf) on 2016-06-22
tags: added: xenial yakkety
Changed in steam (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
carlix (carlixlinux) on 2016-07-04
Changed in wine (Ubuntu):
status: New → Confirmed
affects: wine (Ubuntu) → wine1.6 (Ubuntu)
Changed in wine1.6 (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
importance: Medium → Low
importance: Low → Medium
AsciiWolf (asciiwolf) wrote :

Why were the Steam and Wine bugreports merged? There are separate issues, the Steam issue is probably multiarch-related (Steam is i386-only), while the Wine is probably not showing (or is showing as "Wine Settings") because there is a "NoDisplay=true" line in the wine.desktop file (because we don't want the Wine launcher to be displayed in the menu, we just want it to handle the corresponding mimetypes).

Bruno Nova (brunonova) wrote :

Steam is also missing in Synaptic, except if I filter by the i386 architecture.

summary: - Missing in Gnome-software Ubuntu Gnome 16.04
+ Gnome Software catalog entry missing for Steam
affects: wine1.6 (Ubuntu) → ubuntu
affects: ubuntu → wine1.6 (Ubuntu)
Changed in wine1.6 (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) on 2016-10-09
summary: - Gnome Software catalog entry missing for Steam
+ Gnome Software catalog entry missing for Steam except on i386
description: updated
Matthias Klumpp (ximion) wrote :

The cause of this is AppStream not being multiarch-aware. This is a pretty tricky issue, but I am working on it (although, admittedly, it doesn't have an incredibly high priority at time).

Changed in appstream-dep11 (Ubuntu):
status: New → Won't Fix
Changed in appstream (Ubuntu):
status: New → Confirmed
Changed in appstream (Ubuntu):
importance: Undecided → Medium
Changed in appstream-dep11 (Ubuntu):
importance: Undecided → Medium
Changed in steam (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) wrote :

I'm reopening the steam task. I've not looked into it yet, but perhaps we can workaround this issue by adding a new steam-meta (or whatever you want to call it) binary for every architecture that contains the minimum data needed by appstream? And then have that new steam-meta binary depend on steam:i386.

Changed in steam (Ubuntu):
status: Invalid → Triaged
Changed in appstream (Ubuntu):
status: Confirmed → Triaged
no longer affects: wine1.6 (Ubuntu)
Jeremy Bicha (jbicha) wrote :

Ok, I have a partial solution for this in zesty-proposed. (It's in -proposed because it needs an Archive Admin to let the arch:all package depend on an arch:i386 similar to how pixfrogger was handled LP: #1585058)

The problem is the installation fails because of a debconf prompt. I get the popup message displayed below. To duplicate, be sure to first run
sudo apt purge steam

And to fix apt afterwards, run
sudo apt install -f

Sorry, this did not work
------------------------

Detailed errors from the package manager follow:

Error while installing package: subprocess new pre-installation script returned error exit status 1

Jeremy Bicha (jbicha) wrote :

I dropped the debconf prompt since I don't think there are any plans for gnome-software to support debconf.

Jeremy Bicha (jbicha) on 2017-03-16
Changed in steam (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Changed in steam (Ubuntu Yakkety):
importance: Undecided → Medium
status: New → Triaged
no longer affects: appstream-dep11 (Ubuntu Xenial)
no longer affects: appstream-dep11 (Ubuntu Yakkety)
Changed in steam (Ubuntu):
status: Triaged → Fix Committed
Matthias Klumpp (ximion) wrote :

At least with GNOME Software's PK backend, we set the Debconf mode to noninteractive if the frontend doesn't give us a Debconf-socket to communicate.
So, if GS block on it, I would assume that this is a bug in Ubuntu's APT backend for GNOME Software, and not an issue specific to the steam package.

Jeremy Bicha (jbicha) wrote :

Matthias, I'm not familiar enough with debconf to know our policy, but Debian's steam will get stuck half-installed unless the response has been set some how.

https://launchpadlibrarian.net/311078503/steam_1%3A1.0.0.54+repack-2ubuntu3_1%3A1.0.0.54+repack-2ubuntu4.diff.gz

Matthias Klumpp (ximion) wrote :

Does this happen on Debian as well? In that case, this would be a quite serious bug, and we probably need to have GNOME Software pass a Debconf socket to PackageKit in Debian as well.

If this issue isn't happening in Debian (I never tested it...) then I would bet it's in Ubuntu's APT backend for GS, or in aptdaemon.

Jeremy Bicha (jbicha) wrote :

Yes, I assume it would happen on Debian if you are running i386!

Otherwise, steam is uninstallable in GNOME Software (that's what this bug is originally about, and I haven't forwarded my changes to Debian yet).

I can verify the debconf issue with GNOME Software using the PK backend on Ubuntu.

Debian's steam uses debconf like they do because you are supposed to agree to the steam install agreement before installing :(
https://sources.debian.net/data/non-free/s/steam/1.0.0.54-2/steam_install_agreement.txt

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package steam - 1:1.0.0.54+repack-2ubuntu5

---------------
steam (1:1.0.0.54+repack-2ubuntu5) zesty; urgency=medium

  * Depend on steam instead of steam:i386

 -- Jeremy Bicha <email address hidden> Thu, 16 Mar 2017 12:46:54 -0400

Changed in steam (Ubuntu):
status: Fix Committed → Fix Released
AsciiWolf (asciiwolf) wrote :

Great, thanks! Would it be possible to backport this fix into Xenial?

AsciiWolf (asciiwolf) wrote :

I can confirm that Steam can now be installed from the Software application, however clicking on "Launch" after install does nothing. That can be confusing for many users.

AsciiWolf (asciiwolf) wrote :

The second problem is that removing Steam using the Software application doesn't remove the actual steam package, just the steam-installer one.

AsciiWolf (asciiwolf) on 2017-06-16
tags: added: artful
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appstream (Ubuntu Xenial):
status: New → Confirmed
Changed in appstream (Ubuntu Yakkety):
status: New → Confirmed
AsciiWolf (asciiwolf) wrote :

This issue is still not fully fixed. (See my previous comments.)

AsciiWolf (asciiwolf) wrote :

Any news regarding my previous comments?

AsciiWolf (asciiwolf) on 2017-11-09
tags: added: bionic
AsciiWolf (asciiwolf) wrote :

Any news? Steam still cannot be uninstalled on Ubuntu in an user-friendly way. If you uninstall Steam using Ubuntu Software, only a metapackage is removed, not the actual steam package.

Changed in appstream (Ubuntu):
assignee: nobody → Larry muters (lawrencemuters8)
status: Triaged → Confirmed
Changed in appstream-dep11 (Ubuntu):
assignee: nobody → Larry muters (lawrencemuters8)
Changed in steam (Ubuntu Xenial):
status: Triaged → Confirmed
Changed in steam (Ubuntu Yakkety):
status: Triaged → Confirmed
Changed in steam (Ubuntu):
assignee: nobody → Larry muters (lawrencemuters8)
Jeremy Bicha (jbicha) on 2018-10-13
Changed in appstream (Ubuntu):
assignee: Larry muters (lawrencemuters8) → nobody
Changed in appstream-dep11 (Ubuntu):
assignee: Larry muters (lawrencemuters8) → nobody
Changed in steam (Ubuntu):
assignee: Larry muters (lawrencemuters8) → nobody
Changed in appstream (Ubuntu):
status: Confirmed → Triaged
no longer affects: appstream (Ubuntu Yakkety)
no longer affects: steam (Ubuntu Yakkety)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers