nvidia-367 fails to install on buildds

Bug #1629274 reported by Graham Inggs on 2016-09-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eztrace-contrib (Ubuntu)
Undecided
Unassigned
hwloc-contrib (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-367 (Ubuntu)
High
Alberto Milone
pycuda (Ubuntu)
Undecided
Unassigned
starpu-contrib (Ubuntu)
Undecided
Unassigned

Bug Description

The recent sync of starpu-contrib 1.2.0~rc2+dfsg-2 FTBFS.
I believe this is the relevant part of the log:

Setting up nvidia-367 (367.44-0ubuntu3) ...
update-alternatives: using /usr/lib/nvidia-367/ld.so.conf to provide
/etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf)
in auto mode
update-alternatives: using /usr/lib/nvidia-367/ld.so.conf to provide
/etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf
(x86_64-linux-gnu_egl_conf) in auto mode
update-alternatives: using /usr/lib/nvidia-367/alt_ld.so.conf to
provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf
(i386-linux-gnu_gl_conf) in auto mode
update-alternatives: using /usr/lib/nvidia-367/alt_ld.so.conf to
provide /etc/ld.so.conf.d/i386-linux-gnu_EGL.conf
(i386-linux-gnu_egl_conf) in auto mode
update-alternatives: using /usr/share/nvidia-367/glamor.conf to
provide /usr/share/X11/xorg.conf.d/glamoregl.conf (glamor_conf) in
auto mode
dpkg: warning: version '*-*' has bad syntax: version number does not
start with digit
/var/lib/dpkg/info/nvidia-367.postinst: 211:
/var/lib/dpkg/info/nvidia-367.postinst: update-initramfs: not found
dpkg: error processing package nvidia-367 (--configure):
 subprocess installed post-installation script returned error exit status 127
Setting up freeglut3-dev:amd64 (2.8.1-3) ...
dpkg: dependency problems prevent configuration of libcuda1-367:
 libcuda1-367 depends on nvidia-367 (>= 367.44); however:
  Package nvidia-367 is not configured yet.

I did a test rebuild of starpu-contrib 1.1.5 in my PPA, after dropping the
libcnf-dev dependency, and it fails in exactly the same way.

Changed in nvidia-graphics-drivers-367 (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-367 - 367.57-0ubuntu1

---------------
nvidia-graphics-drivers-367 (367.57-0ubuntu1) yakkety; urgency=medium

  * debian/templates/nvidia-graphics-drivers.postinst.in:
    - Do not fail if update-initramfs is not available (LP: #1629274).
  * New upstream release:
    - Fixed a bug that could prevent systems with GPUs configured in
      SLI from resuming correctly from ACPI S3/S4 sleep/hibernate
      states.
    - Added support for NVIDIA 3D Vision 2 Stereo on Linux. This IR
      emitter can be used with stereo mode "10" set in the X
      configuration file.
    - Fixed a bug in nvidia-persistenced that caused it to
      incorrectly delete the PID file if a second instance of the
      daemon is started.

 -- Alberto Milone <email address hidden> Mon, 10 Oct 2016 16:53:48 +0200

Changed in nvidia-graphics-drivers-367 (Ubuntu):
status: In Progress → Fix Released
Graham Inggs (ginggs) on 2016-10-11
Changed in eztrace-contrib (Ubuntu):
status: New → Invalid
Changed in hwloc-contrib (Ubuntu):
status: New → Invalid
Changed in pycuda (Ubuntu):
status: New → Invalid
Changed in starpu-contrib (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers