vncviewer not working in fullscreen mode

Bug #1957184 reported by Lubensius
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ssvnc (Ubuntu)
Undecided
Unassigned
tightvnc (Ubuntu)
Undecided
Unassigned

Bug Description

Status:
After recent (12.01.2022) update vncviewer is not working correctly in fullscreen mode.
local and remote cursor are misaligned.
part of the remote screen is not visible.

Analysis:
Before update vncviewer was assigned to xtigervncviewer
After update vncviewer is now assigned to xtightvncviewer (watch the difference!)
The packet tigervnc-viewer:amd64 (1.10.1+dfsg-3) was intentionally installed as xtight is broken since years.
Packet tigervnc-viewer:amd64 (1.10.1+dfsg-3) was deinstalled during 'apt autoremove'

Bug:
Unwanted / unnecessary packet de-install.

Quick Fix:
'sudo apt install tigervnc-viewer'

Revision history for this message
Lubensius (lubensius) wrote :
Download full text (8.5 KiB)

/var/log/apt/history.log:
Start-Date: 2022-01-12 14:39:28
Commandline: aptdaemon role='role-commit-packages' sender=':1.177'
Install: linux-image-5.4.0-94-generic:amd64 (5.4.0-94.106, automatic), linux-headers-5.4.0-94:amd64 (5.4.0-94.106, automatic), linux-modules-extra-5.4.0-94-generic:amd64 (5.4.0-94.106, automatic), linux-headers-5.4.0-94-generic:amd64 (5.4.0-94.106, automatic), linux-modules-5.4.0-94-generic:amd64 (5.4.0-94.106, automatic)
Upgrade: qtbase5-dev-tools:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), linux-headers-generic:amd64 (5.4.0.91.95, 5.4.0.94.98), libqt5test5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), linux-libc-dev:amd64 (5.4.0-91.102, 5.4.0-94.106), qt5-gtk-platformtheme:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), qemu-system-mips:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), qemu-system-misc:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), qemu-system-ppc:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), evolution-ews:amd64 (3.36.5-0ubuntu1, 3.36.5-0ubuntu1.1), libsystemd0:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), libqt5opengl5-dev:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), linux-image-generic:amd64 (5.4.0.91.95, 5.4.0.94.98), librbd1:amd64 (15.2.14-0ubuntu0.20.04.1, 15.2.14-0ubuntu0.20.04.2), libqt5dbus5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), libqt5sql5-sqlite:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), qemu-system-x86:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), openssh-sftp-server:amd64 (1:8.2p1-4ubuntu0.3, 1:8.2p1-4ubuntu0.4), libqt5widgets5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), qemu-system-s390x:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), udev:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), libnss-mymachines:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), libudev1:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), libqt5xml5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), libqt5printsupport5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), systemd-timesyncd:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), libqt5concurrent5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), libqt5gui5:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), ubuntu-drivers-common:amd64 (1:0.9.0~0.20.04.1, 1:0.9.0~0.20.04.4), python3-commandnotfound:amd64 (20.04.4, 20.04.5), qemu-system-data:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), qt5-qmake:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), ssh:amd64 (1:8.2p1-4ubuntu0.3, 1:8.2p1-4ubuntu0.4), qemu-utils:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), firefox-locale-de:amd64 (95.0+build1-0ubuntu0.20.04.1, 95.0.1+build2-0ubuntu0.20.04.1), systemd-sysv:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), firefox-locale-en:amd64 (95.0+build1-0ubuntu0.20.04.1, 95.0.1+build2-0ubuntu0.20.04.1), libpam-systemd:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), qemu-system-sparc:amd64 (1:4.2-3ubuntu6.18, 1:4.2-3ubuntu6.19), systemd:amd64 (245.4-4ubuntu3.13, 245.4-4ubuntu3.14), libwebkit2gtk-4.0-37:amd64 (2.34.1-0ubuntu0.20.04.1, 2.34.3-0ubuntu0.20.04.1), libqt5core5a:amd64 (5.12.8+dfsg-0ubuntu1, 5.12.8+dfsg-0ubuntu2.1), openssh-server:amd64 (1:8.2p1-4ubuntu0.3, 1:8.2p1-4ubuntu0.4), openssh-client:amd64 (1:8.2p1-4ubu...

Read more...

Norbert (nrbrtx)
tags: added: focal
no longer affects: ubuntu-mate
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers