required packages missing after installation

Bug #902902 reported by Sigbjorn Lie on 2011-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sssd (Ubuntu)
Medium
Unassigned

Bug Description

Anyone attempting to use the sssd currently available in the Ubuntu package tree (1.5.13), need to also remember to install the packages: "libsasl2-modules-gssapi-mit" and "libsasl2-modules-ldap" for SSSD to work with IPA as a provider.

These packages are not set up as dependencies for the sssd package.

Timo Aaltonen (tjaalton) wrote :

Looking at the Fedora package, it only Requires the gssapi sasl-modules. I wonder if it's the freeipa-client (nonexisting package atm) that should pull -ldap?

Changed in sssd (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

oh well, I added them both as Recommends, so they get installed by default but the admin can remove them if needed (probably -gssapi-mit needs to be in Depends, dunno yet).

pushed the change to git.

Changed in sssd (Ubuntu):
importance: Undecided → Medium
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sssd - 1.5.15-0ubuntu5

---------------
sssd (1.5.15-0ubuntu5) precise; urgency=low

  * Merge changes from debian git:
    - control: Add libsasl2-modules-gssapi-mit and libsasl2-modules-ldap
      to Recommends for sssd. (LP: #902902)
    - rules: Move the rule for purging .la files before dh_install.
    - sssd.install: Fix the wildcard for plugins to include .so symlinks.
 -- Timo Aaltonen <email address hidden> Mon, 02 Jan 2012 14:34:44 +0200

Changed in sssd (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers